20/02/2023 18:21, Bili Dong: > The naming is following the existing CRC32 hash: > https://elixir.bootlin.com/dpdk/v22.11.1/source/lib/hash/rte_hash_crc.h#L168. > I believe all existing hash functions in DPDK are 32 bits, so "32" didn't > appear in other hash function names. If we add "32" here, we probably > should also rename rte_hash_crc(). I'm fine with either option.
Why all functions would be 32-bit? I don't think we need to rename all. We can just make the right thing when adding a new function. What maintainers of rte_hash think?