Provide leading and trailing zero bit count functions to abstract away compiler specific implementations.
Include basic unit test for new leading/trailing zero bit count functions. v2: * use unsigned int instead of unsigned (checkpatches) * match multiple include guard naming convention to rte_common.h * add explicit extern "C" linkage to rte_bitcount.h note: not really needed but checkpatches required * add missing space around '-' Tyler Retzlaff (2): eal: provide leading and trailing zero bit count abstraction test/bitcount: add bitcount tests app/test/meson.build | 2 + app/test/test_bitcount.c | 92 ++++++++++++++ lib/eal/include/meson.build | 1 + lib/eal/include/rte_bitcount.h | 265 +++++++++++++++++++++++++++++++++++++++++ 4 files changed, 360 insertions(+) create mode 100644 app/test/test_bitcount.c create mode 100644 lib/eal/include/rte_bitcount.h -- 1.8.3.1