On 10/9/2020 5:53 PM, Kevin Laatz wrote:
On 08/10/2020 16:41, Ferruh Yigit wrote:
On 10/7/2020 10:48 PM, Thomas Monjalon wrote:
As described in doc/guides/prog_guide/poll_mode_drv.rst,
the naming scheme for the xstats is parts separated with underscore:
* direction
* detail 1
* detail 2
* detail n
* unit
where detail 1 can be "q" followed with a queue number.
It means the name of the stats per queue should be rx_qN_* or tx_qN_*.
The second underscore was missing so far.
Fixing the basic xstat names may be considered an API change,
that's why it should not be backported.
While fixing this mistake, some examples of the naming scheme
are given as part of the API documentation of rte_eth_xstat_name.
More proposals about standardizing statistics:
http://fast.dpdk.org/events/slides/DPDK-2019-09-Ethernet_Statistics.pdf
Fixes: bd6aa172cf35 ("ethdev: fetch extended statistics with integer ids")
Signed-off-by: Thomas Monjalon <tho...@monjalon.net>
no objection,
Reviewed-by: Ferruh Yigit <ferruh.yi...@intel.com>
doc/guides/rel_notes/release_20_11.rst | 8 +++++++-
lib/librte_ethdev/rte_ethdev.c | 4 ++--
lib/librte_ethdev/rte_ethdev.h | 7 +++++++
3 files changed, 16 insertions(+), 3 deletions(-)
diff --git a/doc/guides/rel_notes/release_20_11.rst
b/doc/guides/rel_notes/release_20_11.rst
index cdf20404c9..d0d77c5d3d 100644
--- a/doc/guides/rel_notes/release_20_11.rst
+++ b/doc/guides/rel_notes/release_20_11.rst
@@ -200,7 +200,13 @@ API Changes
* ethdev: ``rte_eth_rx_descriptor_done()`` API has been deprecated.
-* Renamed internal ethdev APIs:
+* ethdev: Renamed basic statistics per queue. An underscore is inserted
+ between the queue number and the rest of the xstat name:
+
+ * ``rx_qN*`` -> ``rx_qN_*``
+ * ``tx_qN*`` -> ``tx_qN_*``
+
As far as I remember collect plugin was using xstat output, does this rename
affects it? Or any other telemetry application relying on xstats.
Harry, Ciara, Kevin, do you know anything that will be affected from rename?
Looks to me like everything will be ok in the old collectd plugins too - from
doing a code review, it seems it just gets the names from ethdev.
Thanks for checking, the workaround David highlighted in the collectd seems
preventing this change to cause an error, so we can proceed.
But it would be nice to test the 'dpdkstat' plugin with this change. Do you know
who is the maintainer of that plugin in collectd?