On Thu, Dec 03, 2015 at 02:36:53AM +0100, Thomas Monjalon wrote: > Hi Ferruh, > > Thanks for working on it. > > 2015-12-03 01:22, Ferruh Yigit: > > +ifeq ($(COMBINED_BUILD),1) > > include $(RTE_SDK)/mk/rte.sharelib.mk > > +endif > [...] > > @if [ $@ = drivers -a $(CONFIG_RTE_BUILD_COMBINE_LIBS) = y ]; then \ > > - $(MAKE) -f $(RTE_SDK)/lib/Makefile sharelib; \ > > + COMBINED_BUILD=1 $(MAKE) -f $(RTE_SDK)/lib/Makefile sharelib; \ > > What is it fixing? > The badly named sharelib is for combined build only.
lib/Makefile and drivers/net/Makefile includes sharelib.mk _always_, this flag is to include sharelib.mk only when we are compiling combined library. Previously this inclusion was not problem because there was not common variable, now we start using common CPU_LDFLAGS variable and sharedlib.mk shouldn't included when not compiling for combined lib. > > [...] > > +FILES=$(find $RTE_SDK -name "*.map" | grep -v build) > > The build dir is not always "build/" > Thanks, I will fix this and send a new patch, I assume I can rely on "*_version.map" naming convention.