I would need to look at the other instances as well. I will try to so by next week, but I think we can probably take an incremental approach of: 1. Eliminate *Ptr in src/arrow code (discuss similar changes in parquet/gandiva). 2. Decide on the Iterator/Vector.
On Fri, Nov 22, 2019 at 10:47 AM Wes McKinney <wesmck...@gmail.com> wrote: > hi Francois > > On Fri, Nov 22, 2019 at 11:17 AM Francois Saint-Jacques > <fsaintjacq...@gmail.com> wrote: > > > > I'll revert, some questions: > > > > 1. Should we revert only the pointer aliases, or also the > Vector/Iterator. > > Could you clarify what Vector/Iterator aliases you are referring to, > like RecordBatchIterator? > > I think we may need to distinguish between endogenous aliases versus > aliases involving STL types. > > IMHO > > using RecordBatchIterator = Iterator<shared_ptr<RecordBatch>>; > > is less problematic from a readability standpoint than > > using RecordBatchPtr = shared_ptr<RecordBatch>; > > > 2. Should we revert all modules, i.e. gandiva and compute. > > I would say one step at a time -- in the case of Gandiva I would say > that we should open a JIRA issue and discuss further to ensure that we > do not cause disruption for public API consumers. Since this software > has already been released multiple times, a different approach may be > needed > > > > > François >