On Fri, 15 Nov 2024 01:12:34 GMT, Stuart Marks <sma...@openjdk.org> wrote:
> First cut at removal of Security Manager stuff from RMI. > > This covers just about every SM-related case in RMI, except for a bit of > package checking in MarshalInputStream. This will be handled separately. It's > covered by [JDK-8344329](https://bugs.openjdk.org/browse/JDK-8344329). > > Further simplifications could be done in RuntimeUtil and NewThreadAction. > However, those changes started to become somewhat more intrusive than I'd > like for this PR, which is focused on removing security-related stuff. Looks ok, but some additional cleanup is recommended. src/java.rmi/share/classes/sun/rmi/runtime/NewThreadAction.java line 49: > 47: * @author Peter Jones > 48: **/ > 49: public final class NewThreadAction { Suggest inlining the methods and getting rid of the class, moving non-trivial methods to an existing Util class. Or at least renaming it to to drop the "Action" that is indicative of doPrivileged. src/java.rmi/share/classes/sun/rmi/transport/tcp/TCPChannel.java line 404: > 402: */ > 403: public void startNewAcceptor() { > 404: Thread t = Fold to previous line. ------------- PR Review: https://git.openjdk.org/jdk/pull/22129#pullrequestreview-2443440493 PR Review Comment: https://git.openjdk.org/jdk/pull/22129#discussion_r1847092598 PR Review Comment: https://git.openjdk.org/jdk/pull/22129#discussion_r1847098808