On Fri, 7 Jul 2023 10:33:10 GMT, Jorn Vernee <jver...@openjdk.org> wrote:
>> sid8606 has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Address Amit's review comments > > test/jdk/java/foreign/TestIllegalLink.java line 57: > >> 55: >> 56: private static final boolean IS_SYSV = CABI.current() == CABI.SYS_V; >> 57: private static final boolean byteorder = ByteOrder.nativeOrder() == >> ByteOrder.LITTLE_ENDIAN; > > Please rename this field to something more descriptive, e.g. `IS_LE` (and > capitalize). Thanks, Made the changes. > test/jdk/java/foreign/TestLayouts.java line 46: > >> 44: public class TestLayouts { >> 45: >> 46: boolean byteorder = ByteOrder.nativeOrder() == >> ByteOrder.LITTLE_ENDIAN; > > Same here Fixed > test/jdk/java/foreign/callarranger/platform/PlatformLayouts.java line 312: > >> 310: * This class defines layout constants modelling standard primitive >> types supported by the S390 ABI. >> 311: */ >> 312: public static final class S390 { > > These are only needed if you plan on adding a CallArranger test as well. Removed For now. ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/14801#discussion_r1257226257 PR Review Comment: https://git.openjdk.org/jdk/pull/14801#discussion_r1257226355 PR Review Comment: https://git.openjdk.org/jdk/pull/14801#discussion_r1257226562