jkorous added a comment. Hi @hokein, I am just keeping up to date with changes.
================ Comment at: clangd/ClangdServer.h:39 +// FIXME: find a better name. class DiagnosticsConsumer { ---------------- It would be unfortunate to have this name clashing with `clang::DiagnosticsConsumer` indeed. How about something like `FileEventConsumer`? ================ Comment at: clangd/TUScheduler.cpp:367 IdleASTs.take(this); + FStatus.messages.push_back("fail to build CompilerInvocation;"); + Callbacks.onFileUpdated(FStatus); ---------------- Wouldn't some different failure status like `FileStatusKind::FailedBuild` be appropriate here? Repository: rCTE Clang Tools Extra CHANGES SINCE LAST ACTION https://reviews.llvm.org/D54796/new/ https://reviews.llvm.org/D54796 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits