On 30.11.2020 11:31, Oleksandr Tyshchenko wrote: > --- a/xen/arch/x86/hvm/ioreq.c > +++ b/xen/arch/x86/hvm/ioreq.c > @@ -36,6 +36,11 @@ > #include <public/hvm/ioreq.h> > #include <public/hvm/params.h> > > +bool ioreq_complete_mmio(void) > +{ > + return handle_mmio(); > +}
As indicated before I don't like out-of-line functions like this one; I think a #define would be quite fine here, but Paul as the maintainer thinks differently. So be it. However, shouldn't this function be named arch_ioreq_complete_mmio() according to the new naming model, and then ... > --- a/xen/include/asm-x86/hvm/ioreq.h > +++ b/xen/include/asm-x86/hvm/ioreq.h > @@ -74,6 +74,8 @@ unsigned int hvm_broadcast_ioreq(ioreq_t *p, bool buffered); > > void hvm_ioreq_init(struct domain *d); > > +bool ioreq_complete_mmio(void); ... get declared next to the other arch_*() hooks? With this Reviewed-by: Jan Beulich <jbeul...@suse.com> Jan