On 12/16/19 11:10 AM, Jan Beulich wrote: > On 13.12.2019 18:37, George Dunlap wrote: >> Replace `unsigned long` with `mfn_t` as appropriate throughout >> alloc/free_lN_table, get/put_page_from_lNe, and >> get_lN_linear_pagetable. This obviates the need for a load of >> `mfn_x()` and `_mfn()` casts. >> >> Signed-off-by: George Dunlap <george.dun...@citrix.com> > > Ah, here we go. Sorry for not spotting before giving the remark > on patch 1. > >> --- a/xen/arch/x86/mm.c >> +++ b/xen/arch/x86/mm.c >> @@ -681,10 +681,10 @@ boolean_param("pv-linear-pt", opt_pv_linear_pt); >> #define define_get_linear_pagetable(level) >> \ >> static int >> \ >> get_##level##_linear_pagetable( >> \ >> - level##_pgentry_t pde, unsigned long pde_pfn, struct domain *d) >> \ >> + level##_pgentry_t pde, mfn_t pde_pfn, struct domain *d) >> \ > > Perhaps better pde_mfn then here, ... > >> { >> \ >> unsigned long x, y; >> \ >> - unsigned long pfn; >> \ >> + mfn_t pfn; >> \ > > ... pfn here, and likewise elsewhere?
Sorry, I get that you mean s/pde_pfn/pde_mfn/g; for the argument to this function; but what do you want done with the `pfn` local variable? Did you mean to suggest `mfn` here as well? -George _______________________________________________ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel