On 10/04/2019 11:24, Jan Beulich wrote:
>>>> On 09.04.19 at 19:53, <andrew.coop...@citrix.com> wrote:
>> The series 832c1803^..f61685a6 was committed without adequate review.
>>
>>  * Fix the shim build by providing a !CONFIG_HVM declaration for
>>    hvm_get_guest_bndcfgs()
>>  * Revert the bogus de-const'ing of the vcpu pointer in
>>    vmx_get_guest_bndcfgs().  vmx_vmcs_enter() really does mutate the vcpu, 
>> and
>>    may cause it to undergo a full de/reschedule, which is in violation of the
>>    ABI described by hvm_get_guest_bndcfgs().  guest_rdmsr() was always going
>>    to need to lose its const parameter, and this was the correct time for it
>>    to happen.
> I'd like to ask for a better explanation of the actual issue you see
> here. By declaring a function parameter pointer to const, nothing
> tells the compiler that the object may not change (e.g. across
> function calls made out of this function).

False.

> All it tells the compiler is
> that the function promises to not itself alter the pointed to object.

Nonsense.  The function promising not to alter the pointed-to-object
includes the entire child callgraph.


The code you insisted Paul to add is:

struct vcpu *v = cv->domain->vcpu[cv->vcpu_id];

which is identical to:

struct vcpu *v = (struct vcpu *)cv;

Which highlights very clearly that this function has undefined behaviour.

An optimising compiler which uses an object, and passes a const pointer
to that object to a function, is permitted to retain assumptions derived
from that state across the function call sequence point, because the ABI
of the function states that the content of the object doesn't change.


But if you'd prefer a different argument, how about a contradiction.

By your interpretation, the const keyword is utterly useless because a
compiler must treat all const pointers as non-const, because the
pointed-to object can change in any arbitrary way at any point.  If this
were the intended interpretation, const would never have been added to
the C language because it would waste space in the compiler for 0 gain.

The fact it was added demonstrates that it had real material gains,
which means it isn't a useless keyword, which means the compiler really
may depend on the content of a const pointed-to-object not changing at all.

>
>>  * Remove the introduced ASSERT(is_hvm_domain(d)) and check the predicate
>>    directly.  While we expect it to be true, the result is potential type
>>    confusion in release builds based on several subtle aspects of the CPUID
>>    feature derivation logic with no other safety checks.  This also fixes the
>>    a linker error in the release build of the shim, again for !CONFIG_HVM
>>    reasons.
> I don't understand "no other safety checks": To me the "S" in
>
> XEN_CPUFEATURE(MPX,           5*32+14) /*S  Memory Protection Extensions */
>
> is clear enough. While perhaps not towards "potential type confusion"

"type confusion" here is mixing up v->arch.hvm and v->arch.pv, which is
what happens when you've actually got a PV vcpu and you call an hvm_*
function.

"No other safety checks" means that cp->feat.mpx becoming accidentally
set results in bad things happening if a PV and HVM vcpu get mixed up.

It is same reasoning which causes us to do this:

if ( !cond )
{
    ASSERT_UNREACHABLE();
    goto something_safer;
}

rather than ASSERT(cond)

> as you word it, there are other cases where we make implications
> from the scope stated in the public header: MSR_FLUSH_CMD, for
> example, is supposed to be inaccessible to PV guests, but there's no
> explicit !PV check in its handling code.

Nothing with the handling of FLUSH_CMD gets into any form of UB
whatsoever if cp->feat.l1d_flush becomes accidentally set for a PV guest.

>  I would call the current state
> as inconsistent (seeing e.g. guest_{rd,wr}msr_x2apic() again being
> behind is_hvm_domain() checks), and hence it's not really possible
> to derive in which case which approach is to be preferred (or, as in
> the case here, would be objected to).

The very first thing guest_{rd,wr}msr_x2apic() does is operate on
v->arch.hvm


Anyway, as was included in the bullet point, the is_hvm_domain() check
is a critical part of making the shim build work, given that it depends
on dead code elimination.  Omitting the is_hvm_domain() check really
does result in a link error.

~Andrew

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xenproject.org
https://lists.xenproject.org/mailman/listinfo/xen-devel

Reply via email to