On Wednesday, December 11th, 2024 at 9:22 AM, Roger Pau Monné 
<roger....@citrix.com> wrote:

>
>
> On Tue, Dec 10, 2024 at 03:13:20PM +0100, Jan Beulich wrote:
>
> > On 06.12.2024 05:41, Denis Mukhin via B4 Relay wrote:
> >
> > > From: Denis Mukhin dmuk...@ford.com
> > >
> > > Updated the name to highlight the logic of selection the physical console
> > > owner: existing code does not switch only serial console, it also switches
> > > video console and debugging console (debug I/O port and console 
> > > hypercall).
> >
> > I'm especially surprised you mention "video console" here. Afaics all of
> > this is only about console input, and no input comes from a video device.
> > Arguably "serial" in the original name is too narrow now. Yet "input"
> > continues to be quite appropriate.
>
>
> switch_console_input() maybe? switch_console_input_target() even?
>
> I think the switch is also relevant, as it shuffles the input around,
> console_find_owner() doesn't seem to convey that meaning.

Renamed to console_switch_input() in v3

>
> Thanks, Roger.



Reply via email to