> -----Original Message-----
> From: Jan Beulich [mailto:jbeul...@suse.com]
> Sent: 25 June 2018 13:49
> To: Paul Durrant <paul.durr...@citrix.com>
> Cc: Andrew Cooper <andrew.coop...@citrix.com>; xen-devel <xen-
> de...@lists.xenproject.org>; Juergen Gross <jgr...@suse.com>
> Subject: RE: [PATCH for-4.11 v2] x86/EFI: further correct FPU state handling
> around runtime calls
> 
> >>> On 25.06.18 at 14:24, <paul.durr...@citrix.com> wrote:
> >> From: Jan Beulich [mailto:jbeul...@suse.com]
> >> Sent: 25 June 2018 13:18
> >> --- a/xen/arch/x86/i387.c
> >> +++ b/xen/arch/x86/i387.c
> >> @@ -206,11 +206,11 @@ static inline void fpu_fxsave(struct vcp
> >>  /*       VCPU FPU Functions    */
> >>  /*******************************/
> >>  /* Restore FPU state whenever VCPU is schduled in. */
> >> -void vcpu_restore_fpu_eager(struct vcpu *v)
> >> +void vcpu_restore_fpu_nonlazy(struct vcpu *v, bool need_stts)
> >>  {
> >>      /* Restore nonlazy extended state (i.e. parts not tracked by CR0.TS). 
> >> */
> >>      if ( !v->arch.fully_eager_fpu && !v->arch.nonlazy_xstate_used )
> >> -        return;
> >> +        goto maybe_stts;
> >
> > It's really just an 'out' label (AFAICT, since need_stts needs to be true
> > for there to be any other semantic) so how about just calling it that rather
> > than 'maybe_stts'?

Ok, I don't have a strong object the maybe_stts name so...

Reviewed-by: Paul Durrant <paul.durr...@citrix.com>

> 
> To be honest, I like "out" less, as being too generic a name. Nor am I
> convinced that, going forward (and leaving aside the fact that we may
> decide to drop lazy mode altogether), all code paths need to reach there.
> 
> Jan
> 


_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xenproject.org
https://lists.xenproject.org/mailman/listinfo/xen-devel

Reply via email to