On Wed, 8 Jun 2016, Julien Grall wrote:
> Hi Wei,
> 
> On 08/06/2016 09:17, Wei Liu wrote:
> > On Wed, Jun 08, 2016 at 02:15:27AM +0200, Edgar E. Iglesias wrote:
> > > From: "Edgar E. Iglesias" <[email protected]>
> > > 
> > > Rename map_regions_rw_cache to map_regions_cache and make it use
> > > p2m.default_access.
> > > 
> > > Suggested-by: Julien Grall <[email protected]>
> > > Signed-off-by: Edgar E. Iglesias <[email protected]>
> > 
> > I don't think this is absolutely necessary for 4.7.
> > 
> > On the other hand, it is just straight renaming, which should be quite
> > safe.
> 
> This patch does not only contain a renaming, it also contain a change to fix
> the default memaccess attribute.
> 
> However, I don't see why we should rename the function to map_regions_cache
> given this will always map the region Read-Write (p2m_mmio_direct prevents the
> execution of the memory).
> 
> > If I can get an ack or review from maintainers and confirmation that it
> > doesn't break ARM build within today, we can shovel this in; otherwise
> > it needs to wait for next version of Xen.
> 
> I would wait for a backport here. Stefano, any opinions?

Indeed, I would also wait for a backport

_______________________________________________
Xen-devel mailing list
[email protected]
http://lists.xen.org/xen-devel

Reply via email to