Note actually we just need p2m_remove_page() to unmap these mapping on
both ept and vt-d sides, and guest_physmap_remove_page is really a
wrapper of p2m_remove_page().
And I agree with Tim regarding the desire to avoid code duplication.
Yet that's no reason to do it asymmetrically:
clear_identity_p2m_entry() could still be an inline (or macro) wrapper
around guest_physmap_remove_page(). That way, apart from making
I can define that as a macro close to set_identity_p2m_entry() in p2m.h.
the code above look nicer, if the latter needs extending in the future
for some reason, simply converting the wrapper to a real function is
possible without needing to touch the call site(s).
This would need to go into patch 2; I wonder whether folding that
Yes.
and this one wouldn't be warranted, avoiding the former adding
Are you saying to fold patch #2 and patch #3? But shouldn't we always
define a new and then use that in practice subsequently? Even with two
patches, respectively.
Thanks
Tiejun
(at that point) dead code.
Jan
_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel