On 18 May 2015 at 18:42, Julien Grall <julien.grall....@gmail.com> wrote:

> Hi Parth,
>
> On 17/05/15 21:03, Parth Dixit wrote:
> > +#ifndef _ASM_ARM64_ACPI_H
> > +#define _ASM_ARM64_ACPI_H
>
> s/_ASM_ARM64_ACPI_H/_ASM_ARM_ACPI_H/
>
> > +
> > +#include <xen/init.h>
> > +
> > +#define COMPILER_DEPENDENT_INT64   long long
> > +#define COMPILER_DEPENDENT_UINT64  unsigned long long
> > +
> > +extern bool_t acpi_disabled;
> > +/* Basic configuration for ACPI */
> > +static inline void disable_acpi(void)
> > +{
> > +    acpi_disabled = 1;
> > +}
>
> It makes a little sense to add the prototype of acpi_disabled without
> effectively declaring it.
>
> Also, the code is very similar to the x86. It would make sense to
> factorize it (disable_acpi, acpi parameters...) in a common place.
>
> sure, i will take care in next patch set.

> > +#endif /*_ASM_ARM_ACPI_H*/
> >
>
> Regards,
>
> --
> Julien Grall
>
_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

Reply via email to