Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 92bcef1cb48493eb468de6af4163c783b6594fb6
https://github.com/WebKit/WebKit/commit/92bcef1cb48493eb468de6af4163c783b6594fb6
Author: Cole Carley <[email protected]>
Date: 2026-08-12 (Wed, 12 Aug 2026)
Changed paths:
M Source/JavaScriptCore/llint/InPlaceInterpreter64.asm
M Source/JavaScriptCore/wasm/WasmSectionParser.cpp
M Source/JavaScriptCore/wasm/js/JSWebAssemblyInstance.h
Log Message:
-----------
[Memory64] rename m_cachedIsMemory64
https://bugs.webkit.org/show_bug.cgi?id=321542
rdar://184653931
Reviewed by Yusuke Suzuki.
m_cachedIsMemory64 should be named m_cachedMemory0IsMemory64 to reflect that
IPInt only checks the cached value for memory 0.
* Source/JavaScriptCore/llint/InPlaceInterpreter64.asm:
* Source/JavaScriptCore/wasm/WasmSectionParser.cpp:
(JSC::Wasm::SectionParser::parseMemoryHelper):
* Source/JavaScriptCore/wasm/js/JSWebAssemblyInstance.h:
Canonical link: https://commits.webkit.org/319044@main
To unsubscribe from these emails, change your notification settings at
https://github.com/WebKit/WebKit/settings/notifications