Here are some problems. Not deal breaker but to keep in mind. > > > (db.posts.color is 'blue') #operator.is_(a, b) > > more readable than == > > > > (db.posts.color is not 'red') #operator.is_not(a, b) > > more readable than != >
You lose the ability to check whether and object is a field. b = a is db.posts.color > > > orderby=[-db.posts.date,-db.posts.title] # operator.__neg__(obj) you lose the ability to do db(...).update(field=-db.table.field) i.e. change sign to numeric values. I have no objection to contains and like but need to think more about it. Massimo --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "web2py Web Framework" group. To post to this group, send email to web2py@googlegroups.com To unsubscribe from this group, send email to web2py+unsubscr...@googlegroups.com For more options, visit this group at http://groups.google.com/group/web2py?hl=en -~----------~----~----~----~------~----~------~--~---