What about this for batched get:

db.posts([4,5,8])
-> [...]
db.posts(4,5,8)
-> [...]
always returns a list (SQLRows)

It would mostly be used internally, but it would be nice to have in
some cases.

Robin

On Feb 1, 12:09 pm, Robin B <robi...@gmail.com> wrote:
> > > (['a','b'] in db.posts.tags)  # operator.__contains__(a, b)
>
> list operations
>
> > > (db.posts.color is 'blue')    #operator.is_(a, b)
>
> more readable than ==
>
> > > (db.posts.color is not 'red')  #operator.is_not(a, b)
>
> more readable than !=
>
> > > (db.posts.title % 'keyword') #operator.__mod__(a, b)
>
> LIKE
>
> > > orderby=[-db.posts.date,-db.posts.title] # operator.__neg__(obj)
>
> a nicer way to say ~
>
> Robin
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"web2py Web Framework" group.
To post to this group, send email to web2py@googlegroups.com
To unsubscribe from this group, send email to 
web2py+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/web2py?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to