On Tue, Aug 28, 2018 at 3:50 AM wouterve <[email protected]> wrote:
> Thanks, It turned out it could not load the necessary resources (eg java > scripts). > > I needed to add proxy for location / to tomcat server. > My <virtualhost *:443> now looks something like this: > > > It depends on where you've deployed Guacamole (how you named the WAR file), but if you've deployed Guacamole as "guacamole.war" and are using the /guacamole/ URL, proxying the / location should *not* be required. Also, the error 500 would not be the result of missing a Location directive for proxying - if that were the cause you'd see Error 404 for being unable to locate the required resource. Something else is/was wrong, and I doubt it has anything to do with having the Location / block in your config. > > > <Location /> > > Order allow,deny > > Allow from all > > ProxyPass http://localhost:8080/ flushpackets=on > > ProxyPassReverse http://localhost:8080/ > > </location> > > > > <Location /guacamole/> > > Order allow,deny > > Allow from all > > ProxyPass http://localhost:8080/guacamole/ flushpackets=on > > ProxyPassReverse http://localhost:8080/guacamole/ > > </Location> > > > > <Location /guacamole/websocket-tunnel> > > Order allow,deny > > Allow from all > > ProxyPass ws://localhost:8080/guacamole/websocket-tunnel > > ProxyPassReverse ws://localhost:8080/guacamole/websocket-tunnel > > </Location> > > > > </VirtualHost> > > Not sure whether the option 'flushpackets = on' is necessary but in this > configuration it is working so guess I'll leave it that way. > Yes, it is, particularly for the tunnel portion. This is explained in the manual: http://guacamole.apache.org/doc/gug/proxying-guacamole.html -Nick
