On Mon, Sep 17, 2012 at 10:30 AM, José Miguel Gonçalves <jose.goncal...@inov.pt> wrote: > On 09/17/2012 07:47 AM, Christian Riesch wrote: >> >> Hi, >> >> On Sun, Sep 16, 2012 at 11:27 AM, José Miguel Gonçalves >> <jose.goncal...@inov.pt> wrote: >>> >>> On 09/14/2012 08:08 PM, Tom Rini wrote: >>>> >>>> On Fri, Sep 14, 2012 at 06:29:01PM +0100, Jos?? Miguel Gon??alves wrote: >>>> >>>>> Samsung's S3C24XX SoCs need this in order to generate a binary image >>>>> with the SPL and U-Boot concatenated. >>>>> >>>>> Signed-off-by: Jos?? Miguel Gon??alves <jose.goncal...@inov.pt> >>>>> --- >>>>> Changes for v2: >>>>> - None >>>>> --- >>>>> Makefile | 7 ++++--- >>>>> 1 file changed, 4 insertions(+), 3 deletions(-) >>>>> >>>>> diff --git a/Makefile b/Makefile >>>>> index 058fb53..595b5f6 100644 >>>>> --- a/Makefile >>>>> +++ b/Makefile >>>>> @@ -442,13 +442,14 @@ $(obj)u-boot.sha1: $(obj)u-boot.bin >>>>> $(obj)u-boot.dis: $(obj)u-boot >>>>> $(OBJDUMP) -d $< > $@ >>>>> -$(obj)u-boot.ubl: $(obj)spl/u-boot-spl.bin $(obj)u-boot.bin >>>>> +$(obj)u-boot-ubl.bin: $(obj)spl/u-boot-spl.bin $(obj)u-boot.bin >>>>> $(OBJCOPY) ${OBJCFLAGS} --pad-to=$(PAD_TO) -O binary >>>>> $(obj)spl/u-boot-spl $(obj)spl/u-boot-spl-pad.bin >>>>> cat $(obj)spl/u-boot-spl-pad.bin $(obj)u-boot.bin > >>>>> $(obj)u-boot-ubl.bin >>>>> + rm $(obj)spl/u-boot-spl-pad.bin >>>>> + >>>>> +$(obj)u-boot.ubl: $(obj)u-boot-ubl.bin >>>>> $(obj)tools/mkimage -n $(UBL_CONFIG) -T ublimage \ >>>>> -e $(CONFIG_SYS_TEXT_BASE) -d $(obj)u-boot-ubl.bin >>>>> $(obj)u-boot.ubl >>>>> - rm $(obj)u-boot-ubl.bin >>>>> - rm $(obj)spl/u-boot-spl-pad.bin >>>>> $(obj)u-boot.ais: $(obj)spl/u-boot-spl.bin $(obj)u-boot.bin >>>>> $(obj)tools/mkimage -s -n $(if >>>>> $(CONFIG_AIS_CONFIG_FILE),$(CONFIG_AIS_CONFIG_FILE),"/dev/null") \ >>>> >>>> This diff is hard to read, but what exactly are you changing? The >>>> u-boot-ubl target is also used on TI platforms. It looks like you're >>>> making it such that u-boot-ubl.bin produces the old binary and >>>> u-boot-ubl adds a new target which is the mkimage header on top of the >>>> same bits as before, but without possibly padding the output image. I >>>> suspect in your case you could just set PAD_TO to 8192 in >>>> board/../config.mk and use the existing target. >>>> >>> In the S3C2416 I don't need the mkimage stuff. I only need the raw SPL >>> image >>> padded at 8KB concatenated with the standard U-Boot. What I've done was >>> to >>> split the existing u-boot-ubl target in two; u-boot-ubl.bin, that I use >>> to >>> program the Flash, and u-boot-ubl that remains with the same >>> functionality >>> as before, just now it depends on u-boot-ubl.bin. >> >> I think you should drop the UBL names from your padding target >> (u-boot-ubl.bin) since this is TI specific, use something more >> generic. > > > I only reused a temporary filename used for the u-boot-ubl target and make > it a new target. > If you think this is not an adequate name, can you suggest a new one?
u-boot.pad? u-boot-pad.bin? _______________________________________________ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot