> -----Original Message----- > From: Michael Walle [mailto:mich...@walle.cc] > Sent: 29 May 2012 03:38 > To: u-boot@lists.denx.de > Cc: Prafulla Wadaskar; Valentin Longchamp; holger.bru...@keymile.com > Subject: Re: [U-Boot] [PATCH 1/3] kirkwood: add > kirkwood_mpp_save/restore functions > > Am Donnerstag 24 Mai 2012, 10:26:44 schrieb Prafulla Wadaskar: > > > + > > > +void kirkwood_mpp_save(void) > > > > This should be > > void kirkwood_mpp_save(unsigned int *mpp_ctrl, int len) > > > > > +{ > > > + int i; > > > + > > > + for (i = 0; i < MPP_NR_REGS; i++) > > > + mpp_regs[i] = readl(MPP_CTRL(i)); > > > +} > > > + > > > +void kirkwood_mpp_restore(void) > > > > Same here > > void kirkwood_mpp_restore(unsigned int *mpp_ctrl, int len) > or even better kirkwood_mpp_restore(const unsigned int *mpp_ctrl, int > len) > > btw. sometimes "unsigned int" is used and sometimes "u32", could we > agree on > one? Eg. kirkwood_mpp_conf() is declared with unsigned int but defined > with > u32.
Hi Michael Thanks for your comments. Yes, we should use u32. And const will be a problem since mpp_ctrl will be array that will be dynamically modified. Regards.. Prafulla . . . _______________________________________________ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot