Hi Simon, On Thursday 12 January 2012 05:37:00 Simon Glass wrote: > Hi, > > On Sat, Dec 10, 2011 at 10:43 AM, Simon Glass <s...@chromium.org> wrote: > > At present two parsers have similar code to execute commands. Also > > cmd_usage() is called all over the place. This series adds a single > > function which processes commands called cmd_process(). > > > > This new function understands return codes, and in particular > > CMD_RET_USAGE to indicate a usage error. So rather than calling > > cmd_usage() themselves, the command handlers can just return this > > error. > > > > There appears to be a run_command2() which is used to run commands > > with the selected parser. This series changes this in two separate > > steps to just run_command(), and renames the old run_command() to > > builtin_run_command(). No one should call this outside main.c since > > if the hush parser is being used it is wrong to call it. The > > built-in parser code could move into a separate file perhaps in a > > future patch. > > > > The overall series reduces code size on ARM by about 1KB on > > my ~160KB U-Boot text region when the hush parser is used, and around > > 60 bytes when it isn't. > > > > As an aside the only user of parse_line() is fsl_ddr_interactive() > > which seems to have its own command line interface which operates > > before DRAM is set up. Do I have this right? Is there no way this > > could be done later from a normal U-Boot command? > > > > (I have run this through MAKEALL and it seems clean) > > > > Changes in v2: > > - Fix minor errors one of which created a warning > > - Squash i2c patch into the common/ patch > > > > Simon Glass (9): > > Remove CMD_PXE's static on run_command() > > Rename run_command() to builtin_run_command() > > Rename run_command2() to run_command() > > Stop using builtin_run_command() > > Don't include standard parser if hush is used > > Create a single cmd_call() function to handle command execution > > Remove interleave of non-U-Boot code in hush > > Add cmd_process() to process commands in one place > > Convert cmd_usage() calls in common to use a return value > > Does any of the maintainers feel inclined to pick up these patches? It > still seems to rebase cleanly against master, so it might be ok as is, > but happy to resend if needed.
Looking into it right now. Stay tuned... Best regards, Stefan -- DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany Phone: (+49)-8142-66989-0 Fax: (+49)-8142-66989-80 Email: off...@denx.de _______________________________________________ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot