On Mon, Nov 28, 2011 at 11:43 AM, Jana Rapava <ferma...@gmail.com> wrote:
> Add generic functions for reading, writing and setting bits in ULPI registers.
>
> Signed-off-by: Jana Rapava <ferma...@gmail.com>
> Cc: Remy Bohmer <li...@bohmer.net>
> Cc: Stefano Babic <sba...@denx.de>
> Cc: Igor Grinberg <grinb...@compulab.co.il>
> Cc: Wolfgang Grandegger <w...@denx.de>
> Cc: Simon Glass <s...@chromium.org>
>
> Acked-by: Igor Grinberg <grinb...@compulab.co.il>
> Acked-by: Simon Glass <s...@chromium.org>

Looks good, thanks. - Simon

> ---
> Changes for v2:
>      - make code EHCI-independent
>      - use udelay() in waiting loop
>      - mark static functions as static
>      - naming changes
> Changes for v3:
>       - merge with patch ulpi: add generic ULPI support header file
>       - rewrite ULPI interface in more functionality-oriented way
> Changes for v4:
>       - add error-checking
>       - add waiting for completion into ulpi_reset() function
> Changes for v5:
>        - CodingStyle changes
>        - add comments
>        - simplify implemenation of the ULPI interface functions
> Changes for v6:
>        - cleanup function ulpi_drive_vbus()
>
>  Makefile                         |    1 +
>  drivers/usb/ulpi/Makefile        |   45 +++++++
>  drivers/usb/ulpi/ulpi-viewport.c |  114 ++++++++++++++++++
>  drivers/usb/ulpi/ulpi.c          |  161 +++++++++++++++++++++++++
>  include/usb/ulpi.h               |  238 
> ++++++++++++++++++++++++++++++++++++++
>  5 files changed, 559 insertions(+), 0 deletions(-)
>  create mode 100644 drivers/usb/ulpi/Makefile
>  create mode 100644 drivers/usb/ulpi/ulpi-viewport.c
>  create mode 100644 drivers/usb/ulpi/ulpi.c
>  create mode 100644 include/usb/ulpi.h
>
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to