On Wednesday 19 October 2011 02:34:00 Dirk Eibach wrote:
> --- /dev/null
> +++ b/include/pca9698.h
>
> +#ifndef __PCA9698_H_
> +#define __PCA9698_H_

missing copyright/license/etc... comment block at top of file

> +int pca9698_direction_input(u8 chip, unsigned offset);
> +int pca9698_direction_output(u8 chip, unsigned offset);
> +int pca9698_get_input(u8 chip, unsigned offset);
> +int pca9698_set_output(u8 chip, unsigned offset, int value);

what is "chip" ?  an i2c addr ?  and "offset" is some internal value indicating 
which pin to drive ?  if so, better names might be "u8 addr" and "unsigned 
gpio".  a single comment here would go a long way.

in terms of conforming to existing API:
 - the direction_output() function needs to take a "value"
 - get_input() should be get_value()
 - set_output() should be set_value()
 - you should have a request() func to validate the GPIO
 - add a stub free() func
-mike

Attachment: signature.asc
Description: This is a digitally signed message part.

_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to