On Tuesday, August 30, 2011 05:30:13 Michal Simek wrote:
> --- a/net/eth.c
> +++ b/net/eth.c
> @@ -224,6 +224,14 @@ int eth_write_hwaddr(struct eth_device *dev, const
> char *base_name, int eth_register(struct eth_device *dev)
>  {
>       struct eth_device *d;
> +
> +     size_t len = strlen(dev->name);
> +     if (len >= NAMESIZE) {
> +             printf("Network driver name is too long (%zu >= %zu): %s\n",
> +                                             len, NAMESIZE, dev->name);
> +             return -1;
> +     }

thinking a little more, i wonder if this wouldnt be better as an assert() or 
BUG_ON().  this isnt a normal issue and generally gets caught once -- during 
development of a new board.
-mike

Attachment: signature.asc
Description: This is a digitally signed message part.

_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to