Dear TsiChung Liew, In message <1248799132-29720-1-git-send-email-tsicl...@gmail.com> you wrote: > Provide function protocol for icache_invalid(). > > Signed-off-by: TsiChung Liew <tsicl...@gmail.com> > --- > drivers/net/mcffec.c | 4 ++++ > 1 files changed, 4 insertions(+), 0 deletions(-) > > diff --git a/drivers/net/mcffec.c b/drivers/net/mcffec.c > index 64be5de..d3741a7 100644 > --- a/drivers/net/mcffec.c > +++ b/drivers/net/mcffec.c > @@ -95,6 +95,10 @@ struct fec_info_s fec_info[] = { > #endif > }; > > +#ifdef CONFIG_SYS_UNIFY_CACHE > +extern void icache_invalid(void); > +#endif
Could you please rename this function into invalidate_icache(), and add a prototype declaration to include/asm-?/cache.h, like it is for example doene for PowerPC in include/asm-ppc/cache.h ? I would like to see that all architectures use the same names for the same functions... Thanks. Best regards, Wolfgang Denk -- DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: w...@denx.de If it has syntax, it isn't user friendly. _______________________________________________ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot