Hi, On 10/04/2014 10:30 AM, Ian Campbell wrote: > On Fri, 2014-10-03 at 17:05 +0200, Hans de Goede wrote: >> Signed-off-by: Hans de Goede <hdego...@redhat.com> >> --- >> board/sunxi/Kconfig | 27 +++++++++++++++++++++++++++ >> drivers/mmc/sunxi_mmc.c | 20 ++++++++++++++++++++ >> 2 files changed, 47 insertions(+) >> >> diff --git a/board/sunxi/Kconfig b/board/sunxi/Kconfig >> index 622f7b4..72d6dfa 100644 >> --- a/board/sunxi/Kconfig >> +++ b/board/sunxi/Kconfig >> @@ -32,4 +32,31 @@ config USB_KEYBOARD >> Say Y here to add support for using a USB keyboard (typically used >> in combination with a graphical console on HDMI). >> >> +config MMC0_CD_PIN >> + int "Card detect pin for mmc0" >> + default -1 >> + ---help--- >> + Set the card detect pin for mmc0, set to -1 to not use cd. The pins >> + are numbered as follows PA0 - PA17 are pin number 0 - 17, PB0 - PB23 >> + are 32 - 55, PC0 - PC24 are 64 - 88, etc. Most boards use PH1 for >> + mmc0 cd, which is pin nr 225. > > Is there any way we could use the same trick as for SATAPWR and allow > this to be specified as something like GPx(y) instead of requiring this > complex mapping in the help text? Might be possible with some > combination of Kconfig and cpp trickery? > > Maybe the simplest solution is to make this a string and pass it to > name_to_gpio at runtime (e.g gpio = name_to_gpio(CONFIG_MMC0_CD_PIN)), > although that has the disadvantage of being runtime only check.
I agree that being able to use symbolic names is much better, but I could not find a Kconfig / cpp trickery way to do this. I think that using name_to_gpio is a good solution for this, so that is what I'll do for v2. Regards, Hans _______________________________________________ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot