Dear [EMAIL PROTECTED], In message <[EMAIL PROTECTED]> you wrote: > Subject: [PATCH-OMAP3] OMAP3: Remove BITx magic > > From: Dirk Behme <[EMAIL PROTECTED]> > > Remove bits.h and it's macros usage. Requested by Wolfgang Denk. > > Signed-off-by: Dirk Behme <[EMAIL PROTECTED]> ... > /* device type */ > -#define DEVICE_MASK (BIT8 | BIT9 | BIT10) > +#define DEVICE_MASK (0x7 << 8)
That's a funny way to make code difficult to read. Why do you prefer "(0x7 << 8)" instead of "0x700" (which looks more obvious to me) ? > -#define DLL_NO_FILTER_MASK (BIT8 | BIT9) > +#define DLL_NO_FILTER_MASK ((0x1 << 9) | (0x1 << 8)) Ditto here - why not simply 0x300 ? > -#define GPT_EN ((0 << 2) | BIT1 | BIT0) > +#define GPT_EN ((0x0 << 2) | (0x1 << 1) | (0x1 << 0)) Why not 0x3 ? Note: especially the "(0x0 << 2) | " part in the expression i really bogus. Best regards, Wolfgang Denk -- DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: [EMAIL PROTECTED] "No problem is so formidable that you can't walk away from it." - C. Schulz _______________________________________________ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot