On 11/28/2016 06:51 PM, Andrus, Brian Contractor wrote:
I am building the RPMs on CentOS7. I merely do: rpmbuild -tb
slurm-16.05.6.tar.bz2
I do see the resulting rpm has both the init file and the unit files:
*# rpm -qlp ../RPMS/x86_64/slurm-16.05.6-1.el7.centos.x86_64.rpm|egrep
"init.d|service$"*
*/etc/init.d/slurm*
*/usr/lib/systemd/system/slurmctld.service*
*/usr/lib/systemd/system/slurmd.service*
Yes, and you start the slurmctld service on the master node by:
systemctl enable slurmctld.service
systemctl start slurmctld.service
/Ole
-----Original Message-----
From: Ole Holm Nielsen [mailto:[email protected]]
Sent: Sunday, November 27, 2016 11:12 PM
To: slurm-dev <[email protected]>
Subject: [slurm-dev] Re: PIDfile on CentOS7 and compute nodes
Hi Brian,
Did you build and install the Slurm RPMs on CentOS 7, or is it a manual
install? Which Slurm and CentOS versions do you run? We run Slurm
16.05 on CentOS 7, see instructions in our Wiki
https://wiki.fysik.dtu.dk/niflheim/SLURM
/Ole
On 11/25/2016 05:04 PM, Andrus, Brian Contractor wrote:
All,
I have been having an issue where if I try to run the slurm daemon
under systemd, it hangs for some time and then errors out with:
systemd[1]: Starting LSB: slurm daemon management...
systemd[1]: PID file /var/run/slurmctld.pid not readable (yet?) after
start.
systemd[1]: slurm.service: control process exited, code=exited
status=203
systemd[1]: Failed to start LSB: slurm daemon management.
systemd[1]: Unit slurm.service entered failed state.
systemd[1]: slurm.service failed.
Now it does actually start and is running when I do a ‘ps’.
So I DID figure out a work-around, which, for now, I will code for
changing the scripts.
If I remove the lines from the /etc/init.d/slurm file:
# processname: /usr/sbin/slurmctld
# pidfile: /var/run/slurmctld.pid
Then systemd is happy running just slurm.
Not sure what the appropriate fix is for this, but that is a
work-around that seems effective.