Hi, I am relatively to Slurm -facing the same issue. As an user I could ssh back from the compute node to the login node without being asked for a password.
My OS is CentOS 7.2, and Slurm 16.05.4. In slurmd.log, there are message as the following: [2016-11-07T11:04:31.958] [10004626.0] debug2: Before call to spank_init() [2016-11-07T11:04:31.958] [10004626.0] debug: spank: opening plugin stack /opt/slurm/etc/plugstack.conf [2016-11-07T11:04:31.959] [10004626.0] debug3: Couldn't find sym 'slurm_spank_slurmd_init' in the plugin [2016-11-07T11:04:31.959] [10004626.0] debug3: Couldn't find sym 'slurm_spank_job_prolog' in the plugin [2016-11-07T11:04:31.959] [10004626.0] debug3: Couldn't find sym 'slurm_spank_init_post_opt' in the plugin [2016-11-07T11:04:31.959] [10004626.0] debug3: Couldn't find sym 'slurm_spank_task_init_privileged' in the plugin [2016-11-07T11:04:31.959] [10004626.0] debug3: Couldn't find sym 'slurm_spank_task_init' in the plugin [2016-11-07T11:04:31.959] [10004626.0] debug3: Couldn't find sym 'slurm_spank_task_post_fork' in the plugin [2016-11-07T11:04:31.959] [10004626.0] debug3: Couldn't find sym 'slurm_spank_task_exit' in the plugin [2016-11-07T11:04:31.959] [10004626.0] debug3: Couldn't find sym 'slurm_spank_job_epilog' in the plugin [2016-11-07T11:04:31.959] [10004626.0] debug3: Couldn't find sym 'slurm_spank_slurmd_exit' in the plugin [2016-11-07T11:04:31.959] [10004626.0] debug: spank: /opt/slurm/etc/plugstack.conf:35: Loaded plugin x11.so [2016-11-07T11:04:31.959] [10004626.0] debug: SPANK: appending plugin option "x11" [2016-11-07T11:04:31.959] [10004626.0] debug2: spank: x11.so: init = 0 [2016-11-07T11:04:31.959] [10004626.0] debug2: After call to spank_init() [2016-11-07T11:04:31.959] [10004626.0] debug: mpi type = (null) [2016-11-07T11:04:31.959] [10004626.0] debug: mpi/none: slurmstepd prefork Also when running 'grep x11 ...' to the slurmd.log, I got the following: [2016-11-07T11:04:31.921] debug2: spank: /opt/slurm/lib64/slurm/x11.so: no callbacks in this context [2016-11-07T11:04:31.925] debug: unsetenv (_SLURM_SPANK_OPTION_x11_x11) [2016-11-07T11:04:31.959] [10004626.0] debug: spank: /opt/slurm/etc/plugstack.conf:35: Loaded plugin x11.so [2016-11-07T11:04:31.959] [10004626.0] debug: SPANK: appending plugin option "x11" [2016-11-07T11:04:31.959] [10004626.0] debug2: spank: x11.so: init = 0 [2016-11-07T11:04:31.972] [10004626.0] error: x11: unable to read DISPLAY value [2016-11-07T11:04:31.972] [10004626.0] debug2: spank: x11.so: user_init = -4 I appreciated any insight! Thanks, Wensheng On Tue, Sep 20, 2016 at 7:27 PM, Christopher Samuel <[email protected]> wrote: > > On 21/09/16 06:13, Simpson, Claire L wrote: > > > srun: error: x11: unable to connect node node010 > > Can users ssh back from the compute node to the login node without being > prompted for a password/passphrase or to accept an ssh key? > > That's usually the source of those issues in my experience. > > SSH host based authentication within the cluster helps with that, along > with caching SSH keys in /etc/ssh/ssh_known_hosts. > > Best of luck, > Chris > -- > Christopher Samuel Senior Systems Administrator > VLSCI - Victorian Life Sciences Computation Initiative > Email: [email protected] Phone: +61 (0)3 903 55545 > http://www.vlsci.org.au/ http://twitter.com/vlsci >
