On Mon, 10 Aug 2026 11:49:58 GMT, Johan Sjölen <[email protected]> wrote:

> The fields declaring layout support for value classes are duplicated across 
> the FieldLayoutBuilder, InlineKlass, and ClassFileParser. I suggest that we 
> move all of these into a new class, called AvailableLayouts.
> 
> This rids us of many duplicated lines of code, and makes keeping the names 
> consistent easier (today, they are not consistent).
> 
> For the design of `AvailableLayouts`, I decided on putting the size fields 
> into an array which is indexed by casting `LayoutKind` into an `int`. This 
> saves us code bloat, both in the repo, and also in our binaries. When I've 
> looked at the generated code for the inlined callsites of 
> `InlineKlass::layout_size_in_bytes`, the switch is compiled down into table 
> dispatch. Now, we can just have it be a load from an object offset. This 
> ought to be faster as well, as no prediction needs to take place.
> 
> There's a lot of added `const` stuff in this PR as well, as issues with 
> const-correctness came up during the refactoring.
> 
> ---------
> - [X] I confirm that I make this contribution in accordance with the [OpenJDK 
> Interim AI Policy](https://openjdk.org/legal/ai).

This pull request has been closed without being integrated.

-------------

PR: https://git.openjdk.org/jdk/pull/32276

Reply via email to