On Tue, 1 Sep 2026 17:22:09 GMT, Chris Plummer <[email protected]> wrote:
>> Alan Bateman has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Change sentence with examples to use either-to construct > > src/hotspot/share/prims/jvmti.xml line 3437: > >> 3435: are enabled, the current frame is a constructor of a class >> with >> 3436: strictly-initialized instance fields in its class hierarchy >> or the class >> 3437: initializer of a class with strictly-initialized static >> fields.) > > This is all one sentence and hard to read. It's ambiguous what the "or" in > "or the class" is actually connected to. It could be "a constructor", > "instance fields", or "class hierarchy". This is also the three examples and using a list doesn't work in this context. Like the JDWP spec, then changing it to an either-or construct should help here.. > src/java.se/share/data/jdwp/jdwp.spec line 2175: > >> 2173: "strictly-initialized instance >> fields in its class " >> 2174: "hierarchy or the class >> initializer of a class with " >> 2175: "strictly-initialized static >> fields).") > > It's hard to put together what the last "or" is applying to, especially since > "current frame" is mentioned separately for the first item, and then "current > frame" is mentioned again with the intent to apply it to both the 2nd and 3rd > items, but it is hard to read it that way. I think something of the form > "when the current frame is X, is Y, or is Z" is easier to read. It's three examples, two of which are when preview features are enabled in the target VM so it doesn't quite fit the suggested sentence construct. However, we can make it easier to read with an either-or construct. I'll try that. ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/32198#discussion_r3908003910 PR Review Comment: https://git.openjdk.org/jdk/pull/32198#discussion_r3907993521
