On Fri, 25 Oct 2024 20:13:52 GMT, Roger Riggs <rri...@openjdk.org> wrote:
>> Sean Mullan has updated the pull request with a new target base due to a >> merge or a rebase. The pull request now contains 150 commits: >> >> - Merge remote-tracking branch 'jdk-sandbox/jep486' into JDK-8338411 >> - Merge >> - Update @summary to replace "if the right permission is granted" can be >> replaced with "package java.lang is open to unnamed module". >> - Remove println about Security Manager. >> - Remove unused static variable NEW_PROXY_IN_PKG. >> - Remove static variable `DEFAULT_POLICY` and unused imports. >> - Remove hasSM() method and code that calls it, and remove comment about >> running test manually with SM. >> - clientlibs: import order >> - warning-string >> - java/net/httpclient/websocket/security/WSURLPermissionTest.java: >> integrated review feedback in renamed WSSanityTest.java >> - ... and 140 more: https://git.openjdk.org/jdk/compare/f7a61fce...cb50dfde > > test/jdk/java/util/concurrent/Executors/PrivilegedCallables.java line 28: > >> 26: * @bug 6552961 6558429 >> 27: * @summary Test privilegedCallable, >> privilegedCallableUsingCurrentClassLoader >> 28: * @run main PrivilegedCallables > > There's nothing privileged here; the test should be renamed or deleted if it > duplicates other non-privileged call tests. `Executors.privilegedCallable()` and `Executors.privilegedCallableUsingCurrentClassLoader()` are still present in the `Executors` class (though deprecated for removal). This test should be removed when those methods are removed. In the meantime, the name of the test seems reasonable to me. ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/21498#discussion_r1819824791