On Fri, 11 Oct 2024 11:01:54 GMT, Roman Kennke <rken...@openjdk.org> wrote:

>> William Kemper has updated the pull request with a new target base due to a 
>> merge or a rebase. The pull request now contains 478 commits:
>> 
>>  - Fix merge error
>>  - Merge remote-tracking branch 'jdk/master' into great-genshen-pr-redux
>>  - Merge remote-tracking branch 'jdk/master' into great-genshen-pr-redux
>>  - Merge branch 'shenandoah/master' into great-genshen-pr-redux
>>  - Merge
>>  - 8341099: GenShen: assert(HAS_FWD == _heap->has_forwarded_objects()) 
>> failed: Forwarded object status is sane
>>    
>>    Reviewed-by: kdnilsen
>>  - 8341485: GenShen: Make evac tracker a non-product feature and confine it 
>> to generational mode
>>    
>>    Reviewed-by: kdnilsen, ysr
>>  - Merge
>>  - 8341042: GenShen: Reset mark bitmaps for unaffiliated regions when 
>> preparing for a cycle
>>    
>>    Reviewed-by: kdnilsen
>>  - 8339616: GenShen: Introduce new state to distinguish promote-in-place 
>> phase as distinct from concurrent evacuation
>>    
>>    Reviewed-by: kdnilsen, shade, ysr
>>  - ... and 468 more: https://git.openjdk.org/jdk/compare/b9db74a6...4db1e0e1
>
> src/hotspot/share/gc/shenandoah/shenandoahHeap.hpp line 535:
> 
>> 533:   ShenandoahPacer*           pacer()             const { return _pacer; 
>>             }
>> 534: 
>> 535:   ShenandoahPhaseTimings*      phase_timings()   const { return 
>> _phase_timings;     }
> 
> The indentation is off here.

I'll fix this, but I secretly don't like this style of formatting because it is 
slightly tedious to maintain. It also suggests that these methods are somehow 
grouped and formatted together for a reason beyond aesthetics.

> src/hotspot/share/gc/shenandoah/shenandoahHeap.inline.hpp line 396:
> 
>> 394: }
>> 395: 
>> 396: inline bool ShenandoahHeap::is_old(oop obj) const {
> 
> What is the difference between this method and the above is_in_old()? Why 
> does it need to check that active generation is young?

This is just a bad, confusing method name. I'll fix this.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/21273#discussion_r1797432875
PR Review Comment: https://git.openjdk.org/jdk/pull/21273#discussion_r1797433441

Reply via email to