On Wed, 7 Aug 2024 17:13:06 GMT, Gerard Ziemski <gziem...@openjdk.org> wrote:
> Please review this cleanup, where we rename `MEMFLAGS` to `MemType`. > > `MEMFLAGS` implies that we can use more than one at the same time, but those > are exclusive values, so `MemType` is much more suitable name. > > There is a bunch of other related cleanup that we can do, but I will leave > for follow up issues such as [NMT: rename NMTUtil::flag to > NMTUtil::type](https://bugs.openjdk.org/browse/JDK-8337836) Hmmmm .... I like the structure of `NMT::MemType` but also prefer to keep "flag" in the name to avoid renaming parameters (or having oddly named parameters). Can I vote for `NMT::MemTypeFlag`? :) Otherwise: - `MemTypeFlag` - 3 points - `NMT::MemType` - 2 points - `NMT_MemType` - 1 point (but maybe `NMTMemType`?) ------------- PR Comment: https://git.openjdk.org/jdk/pull/20497#issuecomment-2313858939