We have a few places that uses the terms `KlassObj` and `klassOop` when referring to Klasses. This is old code from before the PermGen removal, when Klasses also were Java objects.
These names tripped me up when I was reading the heap heapInspection.cpp and first though we were mixing the klass *mirror* objects and klass pointers in the hash code calculation: // An aligned reference address (typically the least // address in the perm gen) used for hashing klass // objects. HeapWord* _ref; ... _ref = (HeapWord*) Universe::boolArrayKlassObj(); ... uint KlassInfoTable::hash(const Klass* p) { return (uint)(((uintptr_t)p - (uintptr_t)_ref) >> 2); } I propose that we rename these functions (and stop casting the Klass* to a (HeapWord*)). Tested with serviceability/dcmd/gc/ClassHistogramTest.java but will run this through our lower tiers. ------------- Commit messages: - 8329655: Cleanup KlassObj and klassOop names after the PermGen removal Changes: https://git.openjdk.org/jdk/pull/18618/files Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=18618&range=00 Issue: https://bugs.openjdk.org/browse/JDK-8329655 Stats: 125 lines in 29 files changed: 0 ins; 2 del; 123 mod Patch: https://git.openjdk.org/jdk/pull/18618.diff Fetch: git fetch https://git.openjdk.org/jdk.git pull/18618/head:pull/18618 PR: https://git.openjdk.org/jdk/pull/18618