On Tue, 25 Apr 2023 00:47:17 GMT, Jiangli Zhou <jian...@openjdk.org> wrote:

>> - Make functions 'static' when feasible:
>>   - throwByName() in 
>> src/java.security.jgss/share/native/libj2gss/NativeUtil.c.
>>   - throwByName(), throwIOException() and throwNullPointerException() in 
>> src/java.smartcardio/unix/native/libj2pcsc/pcsc_md.c.
>>   - throwByName() in 
>> src/jdk.crypto.cryptoki/share/native/libj2pkcs11/p11_util.c.
>>   - throwOutOfMemoryError() in 
>> src/java.smartcardio/share/native/libj2pcsc/pcsc.c.
>>   - Move throwDisconnectedRuntimeException() to 
>> src/jdk.crypto.cryptoki/share/native/libj2pkcs11/p11_util.c since it's only 
>> used in the file. Make it static.
>>   - Move throw_internal_error() to 
>> src/jdk.management/unix/native/libmanagement_ext/OperatingSystemImpl.c as 
>> it's only used in the file. Make it static.
>> 
>> - Rename functions by following the existing naming usages in different 
>> libraries code:
>>   - Rename throwOutOfMemoryError() to gssThrowOutOfMemoryError() in libj2gss.
>>   - Rename throwOutOfMemoryError() to p11ThrowOutOfMemoryError() in 
>> libj2pks11.
>>   - Rename throwNullPointerException() to p11ThrowNullPointerException() in 
>> libj2pks11.
>>   - Rename throwIOException() to p11ThrowIOException() in libj2pks11.
>>   - Rename throwPKCS11RuntimeException() to p11ThrowPKCS11RuntimeException() 
>> in libj2pks11. This function only exists in libj2pks11. The rename is done 
>> so the function naming is consistent with the other throw<exception> 
>> functions.
>> 
>> - Remove throw_internal_error() from 
>> src/java.management/share/native/libmanagement/management.h and 
>> src/java.management/share/native/libmanagement/management.c. It's not used.
>> - Remove throw_internal_error() from 
>> src/jdk.management/share/native/libmanagement_ext/management_ext.h and 
>> src/jdk.management/share/native/libmanagement_ext/management_ext.c.
>
> Jiangli Zhou has updated the pull request incrementally with one additional 
> commit since the last revision:
> 
>   Minor updates, as suggested by mcpowers:
>   - Update copyright headers in affected files.
>   - Formatting update in 
> src/java.security.jgss/share/native/libj2gss/GSSLibStub.c.
>   - Remove throwByName() and move the logic into gssThrowOutOfMemoryError() 
> (the only caller) in 
> src/java.security.jgss/share/native/libj2gss/NativeUtil.c.

Thanks for the reviews.

-------------

PR Comment: https://git.openjdk.org/jdk/pull/13497#issuecomment-1523566931

Reply via email to