security-dev
Thread
Date
Later messages
Messages by Thread
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v3]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v3]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v3]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v3]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v4]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v4]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v5]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v5]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v5]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v6]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v6]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v6]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v7]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v7]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v7]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v7]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v7]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v7]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v7]
Sean Mullan
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v7]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v7]
Sean Mullan
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v7]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v7]
Sean Mullan
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v7]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v8]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v8]
Sean Mullan
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v8]
Sean Mullan
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v8]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v8]
Sean Mullan
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v9]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v9]
Sean Mullan
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v10]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v11]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v11]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v11]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v11]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v11]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v12]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v13]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v13]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v13]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v14]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v14]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v14]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v15]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v15]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v15]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v15]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v16]
Mikhail Yankelevich
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v16]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v16]
Weijun Wang
Re: RFR: 8377979: Add new methods to X509Certificate to return Instant instead of Date [v16]
Weijun Wang
Re: RFR: 8378267: Test sun/security/util/HexDumpEncoderTests.java fails when unexpected warning appears [v4]
Mikhail Yankelevich
Re: RFR: 8378267: Test sun/security/util/HexDumpEncoderTests.java fails when unexpected warning appears [v4]
Weijun Wang
RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v2]
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v2]
Mikhail Yankelevich
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v2]
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v2]
Mikhail Yankelevich
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v2]
Mikhail Yankelevich
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v2]
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v2]
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v2]
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v2]
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v2]
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v3]
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v4]
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v5]
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v6]
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v7]
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v7]
Mikhail Yankelevich
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v8]
SendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v9]
SendaoYan
Withdrawn: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out
duke
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v10]
sendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v11]
sendaoYan
Re: RFR: 8379849: javax/net/ssl/Stapling/HttpsUrlConnClient.java fails Read timed out [v12]
sendaoYan
Re: RFR: 8364121: DES[ede]KeySpec do not consistently check for valid parameters [v4]
Shawn Emery
Re: RFR: 8378267: Test sun/security/util/HexDumpEncoderTests.java fails when unexpected warning appears [v3]
Mikhail Yankelevich
Re: RFR: 8378267: Test sun/security/util/HexDumpEncoderTests.java fails when unexpected warning appears [v3]
Weijun Wang
Re: RFR: 8378267: Test sun/security/util/HexDumpEncoderTests.java fails when unexpected warning appears [v3]
Mikhail Yankelevich
Re: RFR: 8378267: Test sun/security/util/HexDumpEncoderTests.java fails when unexpected warning appears [v3]
Weijun Wang
Re: RFR: 8378267: Test sun/security/util/HexDumpEncoderTests.java fails when unexpected warning appears [v3]
Weijun Wang
Re: RFR: 8378267: Test sun/security/util/HexDumpEncoderTests.java fails when unexpected warning appears [v2]
Mikhail Yankelevich
Re: RFR: 8378267: Test sun/security/util/HexDumpEncoderTests.java fails when unexpected warning appears [v2]
Weijun Wang
Re: RFR: 8378267: Test sun/security/util/HexDumpEncoderTests.java fails when unexpected warning appears [v2]
Mikhail Yankelevich
Re: RFR: 8378267: Test sun/security/util/HexDumpEncoderTests.java fails when unexpected warning appears [v2]
Mikhail Yankelevich
RFR: 8379804: Refactor jdk/com/sun tests to use JUnit
Christian Stein
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit
Daniel Fuchs
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit
David Beaumont
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit [v2]
Christian Stein
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit
David Beaumont
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit
David Beaumont
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit
Daniel Fuchs
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit [v3]
Christian Stein
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit [v3]
David Beaumont
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit [v3]
Daniel Fuchs
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit [v3]
Christian Stein
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit
David Beaumont
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit
Mikhail Yankelevich
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit [v3]
Christian Stein
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit [v2]
Christian Stein
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit [v3]
Christian Stein
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit [v3]
Daniel Fuchs
Re: RFR: 8379804: Refactor jdk/com/sun tests to use JUnit [v3]
Christian Stein
Integrated: 8379804: Refactor jdk/com/sun tests to use JUnit
Christian Stein
Re: RFR: 8378267: Test sun/security/util/HexDumpEncoderTests.java fails when unexpected warning appears
Weijun Wang
Re: RFR: 8378267: Test sun/security/util/HexDumpEncoderTests.java fails when unexpected warning appears
Mikhail Yankelevich
RFR: 8357404: jpackage should attempt to get a package version from the JDK's release file if the --version option is not specified
Alexey Semenyuk
Re: RFR: 8357404: jpackage should attempt to get a package version from the JDK's release file if the --version option is not specified
Alexey Semenyuk
Re: RFR: 8357404: jpackage should attempt to get a package version from the JDK's release file if the --version option is not specified
Alexander Matveev
Re: RFR: 8357404: jpackage should attempt to get a package version from the JDK's release file if the --version option is not specified [v2]
Alexey Semenyuk
Re: RFR: 8357404: jpackage should attempt to get a package version from the JDK's release file if the --version option is not specified [v2]
Alexander Matveev
Integrated: 8357404: jpackage should attempt to get a package version from the JDK's release file if the --version option is not specified
Alexey Semenyuk
Re: RFR: 8355216: Accelerate P-256 arithmetic on aarch64 [v10]
Ben Perez
Re: RFR: 8355216: Accelerate P-256 arithmetic on aarch64 [v10]
Andrew Haley
Re: RFR: 8355216: Accelerate P-256 arithmetic on aarch64 [v9]
Ben Perez
Re: RFR: 8355216: Accelerate P-256 arithmetic on aarch64 [v9]
Ben Perez
Re: RFR: 8355216: Accelerate P-256 arithmetic on aarch64 [v10]
Andrew Haley
RFR: 8379433: Throwing proper exceptions for invalid encapsulation length and invalid expectedSecretSize in Hybrid
Hai-May Chao
Re: RFR: 8379433: Throwing proper exceptions for invalid encapsulation length and invalid expectedSecretSize in Hybrid
Makondelela
Re: RFR: 8379433: Throwing proper exceptions for invalid encapsulation length and invalid expectedSecretSize in Hybrid
Mikhail Yankelevich
Re: RFR: 8379433: Throwing proper exception for invalid encapsulation length in Hybrid [v2]
Hai-May Chao
Re: RFR: 8379433: Throwing proper exceptions for invalid encapsulation length and invalid expectedSecretSize in Hybrid
Weijun Wang
Re: RFR: 8379433: Throwing proper exception for invalid encapsulation length in Hybrid [v2]
Hai-May Chao
Re: RFR: 8379433: Throwing proper exception for invalid encapsulation length in Hybrid [v2]
Hai-May Chao
Re: RFR: 8379433: Throwing proper exception for invalid encapsulation length in Hybrid [v2]
Weijun Wang
Re: RFR: 8379433: Throwing proper exception for invalid encapsulation length in Hybrid [v2]
Hai-May Chao
Integrated: 8379433: Throwing proper exception for invalid encapsulation length in Hybrid
Hai-May Chao
Withdrawn: 8366453: TLS 1.3 KeyUpdate record is not rejected if not on a record boundary
duke
Integrated: 8376164: Optimize AES/ECB implementation using full-message intrinsic stub and parallel RoundKey addition
xinyangwu
Re: RFR: 8325513: Export method for Cipher [v8]
Weijun Wang
Re: RFR: 8325513: Export method for Cipher [v8]
Weijun Wang
RFR: 8379541: Add HPKE Export
Weijun Wang
Re: RFR: 8379541: Add HPKE Export
Mikhail Yankelevich
Re: RFR: 8379541: Add HPKE Export
Weijun Wang
Re: RFR: 8379541: Add HPKE Export [v2]
Mikhail Yankelevich
Re: RFR: 8379541: Add HPKE Export
Weijun Wang
Re: RFR: 8379541: Add HPKE Export [v2]
Weijun Wang
Re: RFR: 8379541: Add HPKE Export [v2]
Mikhail Yankelevich
Re: RFR: 8379541: Add HPKE Export [v2]
Mark Powers
Re: RFR: 8379541: Add HPKE Export [v2]
Hai-May Chao
Re: RFR: 8379541: Add HPKE Export [v2]
Weijun Wang
Re: RFR: 8379541: Add HPKE Export [v3]
Weijun Wang
Re: RFR: 8379541: Add HPKE Export [v3]
Hai-May Chao
Re: RFR: 8379541: Add HPKE Export [v3]
Weijun Wang
Re: RFR: 8379541: Add HPKE Export [v3]
Sean Mullan
Re: RFR: 8379541: Add HPKE Export [v3]
Weijun Wang
Withdrawn: 8379541: Add HPKE Export
Weijun Wang
Re: RFR: 8368692: Restrict Password::readPassword from reading from System.in [v4]
Weijun Wang
Re: RFR: 8353290: C2: Refactor PhaseIdealLoop::is_counted_loop() [v40]
Kangcheng Xu
Re: RFR: 8353290: C2: Refactor PhaseIdealLoop::is_counted_loop() [v40]
Kangcheng Xu
RFR: 8379515: draft-ietf-lamps-kyber-certificates is now RFC 9935
Weijun Wang
Re: RFR: 8379515: draft-ietf-lamps-kyber-certificates is now RFC 9935
Sean Mullan
Integrated: 8379515: draft-ietf-lamps-kyber-certificates is now RFC 9935
Weijun Wang
Re: RFR: 8377506: Implementation of PEM Encodings of Cryptographic Objects [v3]
Jan Lahoda
Re: RFR: 8377506: Implementation of PEM Encodings of Cryptographic Objects [v6]
Anthony Scarpino
Re: RFR: 8364121: DESKeySpec.isWeak does not check negative offset [v3]
Shawn Emery
Re: RFR: 8376164: Optimize AES/ECB implementation using full-message intrinsic stub and parallel RoundKey addition [v12]
xinyangwu
Re: RFR: 8376164: Optimize AES/ECB implementation using full-message intrinsic stub and parallel RoundKey addition [v12]
Sandhya Viswanathan
Re: RFR: 8369917: LMS/HSS RFC 9858 Support [v3]
Mark Powers
Re: RFR: 8369917: LMS/HSS RFC 9858 Support [v3]
Weijun Wang
Integrated: 8379191: SunX509KeyManagerImpl alias chooser methods returns null for EC_EC
Artur Barashev
Re: RFR: 8379191: SunX509KeyManagerImpl alias chooser methods returns null for EC_EC
Pete Bentley
Re: RFR: 8376164: Optimize AES/ECB implementation using full-message intrinsic stub and parallel RoundKey addition [v11]
xinyangwu
Re: RFR: 8376164: Optimize AES/ECB implementation using full-message intrinsic stub and parallel RoundKey addition [v11]
Sandhya Viswanathan
Re: RFR: 8376164: Optimize AES/ECB implementation using full-message intrinsic stub and parallel RoundKey addition [v11]
xinyangwu
Re: RFR: 8376164: Optimize AES/ECB implementation using full-message intrinsic stub and parallel RoundKey addition [v10]
xinyangwu
RFR: 8367897: Document the javax.net.debug property in javadoc
Ozan Cetin
Re: RFR: 8367897: Document the javax.net.debug property in javadoc
Bradford Wetmore
Withdrawn: 8367897: Document the javax.net.debug property in javadoc
duke
Re: RFR: 8364121: DESKeySpec.isWeak does not check negative offset [v2]
Shawn Emery
Re: RFR: 8364121: DESKeySpec.isWeak does not check negative offset [v2]
Sean Mullan
Re: RFR: 8364121: DESKeySpec.isWeak does not check negative offset [v2]
Shawn Emery
Re: RFR: 8364121: DESKeySpec.isWeak does not check negative offset [v2]
Shawn Emery
Re: RFR: 8364121: DESKeySpec.isWeak does not check negative offset [v2]
Sean Mullan
Re: RFR: 8364121: DESKeySpec.isWeak does not check negative offset [v2]
Sean Mullan
Re: RFR: 8364121: DESKeySpec.isWeak does not check negative offset [v3]
Shawn Emery
Re: RFR: 8364121: DESKeySpec.isWeak does not check negative offset [v3]
Sean Mullan
Re: RFR: 8364121: DES[ede]KeySpec do not consistently check for valid parameters [v3]
Sean Mullan
Re: RFR: 8364121: DES[ede]KeySpec do not consistently check for valid parameters [v4]
Shawn Emery
Re: RFR: 8364121: DES[ede]KeySpec do not consistently check for valid parameters [v4]
Sean Mullan
Re: RFR: 8364121: DES[ede]KeySpec do not consistently check for valid parameters [v4]
Shawn Emery
Re: RFR: 8364121: DES[ede]KeySpec do not consistently check for valid parameters [v5]
Sean Mullan
Re: RFR: 8376164: Optimize AES/ECB implementation using full-message intrinsic stub and parallel RoundKey addition [v9]
Sandhya Viswanathan
Re: RFR: 8376164: Optimize AES/ECB implementation using full-message intrinsic stub and parallel RoundKey addition [v9]
xinyangwu
Re: RFR: 8369917: LMS/HSS RFC 9858 Support [v2]
Mark Powers
Re: RFR: 8378893: X25519 should utilize a larger limb size [v5]
Shawn Emery
Re: RFR: 8378893: X25519 should utilize a larger limb size [v5]
Shawn Emery
Re: RFR: 8378893: X25519 should utilize a larger limb size [v5]
Anthony Scarpino
Re: RFR: 8378893: X25519 should utilize a larger limb size [v5]
duke
Re: RFR: 8378893: X25519 should utilize a larger limb size [v5]
Ben Perez
Re: RFR: 8368841: X25519 implementation differs from the specification in RFC 7748 [v10]
Anthony Scarpino
Re: RFR: 8368841: X25519 implementation differs from the specification in RFC 7748 [v10]
Ben Perez
Re: RFR: 8379191: SunX509KeyManagerImpl alias chooser methods returns null for EC_EC [v5]
Artur Barashev
Re: RFR: 8379191: SunX509KeyManagerImpl alias chooser methods returns null for EC_EC [v5]
Sean Mullan
Re: RFR: 8379191: SunX509KeyManagerImpl alias chooser methods returns null for EC_EC [v5]
Mikhail Yankelevich
Re: RFR: 8379191: SunX509KeyManagerImpl alias chooser methods returns null for EC_EC [v4]
Sean Mullan
Re: RFR: 8379191: SunX509KeyManagerImpl alias chooser methods returns null for EC_EC [v4]
Artur Barashev
Re: RFR: 8379191: SunX509KeyManagerImpl alias chooser methods returns null for EC_EC [v4]
Sean Mullan
Later messages