On Wed, 16 Nov 2022 02:00:23 GMT, Bradford Wetmore <wetm...@openjdk.org> wrote:
>> java.util.Enumeration is a legacy interface from java 1.0. >> There are a few places with cycles which use it to iterate over collections. >> We can replace this manual cycle with enchanced-for, which is shorter and >> easier to read. > > src/java.base/share/classes/javax/crypto/CryptoPermissions.java line 232: > >> 230: // find out if there is anything we should add into >> 231: // ret. >> 232: Enumeration<String> thisKeys = this.perms.keys(); > > There are a couple other places where you could do the same enhanced for loop > with arrays: Current lines: 107, 254, 287. There are many places in javax crypto which iterate over an array. I think it's worth to create a separate issue ------------- PR: https://git.openjdk.org/jdk/pull/11022