Re: [PATCH v5 8/9] xen/arm: introduce legacy dom0less option for xenstore allocation

2025-02-06 Thread Orzel, Michal
On 06/02/2025 02:08, Stefano Stabellini wrote: > The new xenstore page allocation scheme might break older unpatches > Linux kernels that do not check for the Xenstore connection status > before proceeding with Xenstore initialization. > > Introduce a dom0less configuration option to retain the

Re: [PATCH v5 2/9] xen/arm/static-shmem: Static-shmem should be direct-mapped for direct-mapped domains

2025-02-06 Thread Orzel, Michal
On 06/02/2025 02:08, Stefano Stabellini wrote: > From: Henry Wang > > Currently, users are allowed to map static shared memory in a > non-direct-mapped way for direct-mapped domains. This can lead to > clashing of guest memory spaces. Also, the current extended region > finding logic only remo

Re: [PATCH] automation: enable UBSAN for debug tests

2025-02-05 Thread Orzel, Michal
On 06/02/2025 03:37, Stefano Stabellini wrote: > > > automation: enable UBSAN for debug tests > > Enable CONFIG_UBSAN and CONFIG_UBSAN_FATAL for the ARM64 and x86_64 > build jobs, with debug enabled, which are later used for Xen tests on > QEMU and/or real hardware. > > Signed-off-by: Stefan

Re: [PATCH v5 1/9] automation: upgrade Linux kernel for arm64 tests to 6.6.74

2025-02-05 Thread Orzel, Michal
On 06/02/2025 02:08, Stefano Stabellini wrote: > > > Signed-off-by: Stefano Stabellini Any particular reason behind choosing 6.6.74 and not the latest longterm 6.6.75? In any case: Reviewed-by: Michal Orzel ~Michal

Re: [PATCH v5 3/9] xen/arm: Alloc XenStore page for Dom0less DomUs from hypervisor

2025-02-06 Thread Orzel, Michal
On 06/02/2025 02:08, Stefano Stabellini wrote: > From: Henry Wang > > There are use cases (for example using the PV driver) in Dom0less > setup that require Dom0less DomUs start immediately with Dom0, but > initialize XenStore later after Dom0's successful boot and call to > the init-dom0less

Re: [PATCH 2/4] ARM: Fix register constraints in run_in_exception_handler()

2025-02-10 Thread Orzel, Michal
50_poll 52 48 -4 > dump_registers 432 428 -4 > > The other instruction dropped in ARM64's dump_registers() is an alignment nop. > > No functional change. > > Signed-off-by: Andrew Cooper Reviewed-by: Michal Orzel ~Michal

Re: [PATCH for-4.20? 1/4] ARM32/traps: Fix do_trap_undefined_instruction()'s detection of kernel text

2025-02-10 Thread Orzel, Michal
On 08/02/2025 01:02, Andrew Cooper wrote: > > > While fixing some common/arch boundaries for UBSAN support on other > architectures, the following debugging patch: > > diff --git a/xen/arch/arm/setup.c b/xen/arch/arm/setup.c > index c1f2d1b89d43..58d1d048d339 100644 > --- a/xen/arch/arm

Re: [PATCH v6 2/7] xen/arm: Alloc XenStore page for Dom0less DomUs from hypervisor

2025-02-07 Thread Orzel, Michal
status and HVM_PARAM_STORE_PFN from init-dom0less, as they are set > by the hypervisor. > > Take the opportunity to do some coding style improvements when possible. > > Reported-by: Alec Kwapis > Signed-off-by: Henry Wang > Signed-off-by: Stefano Stabellini Reviewed-by: Michal Orzel I tested all 3 configurations: regular domU and static mem domU w\o direct map: Tested-by: Michal Orzel ~Michal

Re: [PATCH v6 6/7] xen/arm: introduce legacy dom0less option for xenstore allocation

2025-02-07 Thread Orzel, Michal
default features (including Xenstore) will be > + * available. Note that an OS *must* not rely on > the > + * availability of Xen features if this is not set. > + * DOM0LESS_ENHANCED_LEGACY: Same as before, but using DOM0LESS_XS_LEGACY. > */ > #define DOM0LESS_ENHANCED_NO_XS BIT(0, U) > #define DOM0LESS_XENSTOREBIT(1, U) > +#define DOM0LESS_XS_LEGACY BIT(2, U) > +#define DOM0LESS_ENHANCED_LEGACY (DOM0LESS_ENHANCED_NO_XS | > DOM0LESS_XS_LEGACY) > #define DOM0LESS_ENHANCED(DOM0LESS_ENHANCED_NO_XS | > DOM0LESS_XENSTORE) > > struct kernel_info { Other than that: Reviewed-by: Michal Orzel ~Michal

Re: [PATCH v6 4/7] automation: add ping test to static-mem test

2025-02-07 Thread Orzel, Michal
end static-mem test with additional ping test to test PV network. > > Signed-off-by: Stefano Stabellini Reviewed-by: Michal Orzel ~Michal

Re: [PATCH v6 5/7] init-dom0less: allocate xenstore page is not already allocated

2025-02-07 Thread Orzel, Michal
ore_pfn == ~0ULL) > { If get_xs_page() returns != 0, then something is wrong and we definitiely should not try to allocate a page. The only reason the script should allocate a page is if xenstore_pfn is invalid i.e. ~0ULL or not set i.e. 0. At this point we already validated that guest is xenstore enhanced so the only possibility is ~0ULL. So the code should be: if (get_xs_page(xch, info, &xenstore_pfn) != 0) { return 1; } if (xenstore_pfn == ~0ULL) { ... Other than that: Reviewed-by: Michal Orzel ~Michal

Re: [PATCH v6 3/7] docs/features/dom0less: Update the late XenStore init protocol

2025-02-07 Thread Orzel, Michal
On 07/02/2025 02:53, Stefano Stabellini wrote: > From: Henry Wang > > With the new allocation strategy of Dom0less DomUs XenStore page, > update the doc of the late XenStore init protocol accordingly. > > Signed-off-by: Henry Wang @Stefano, your SOB is missing. Reviewe

Re: [PATCH] device-tree: optimize dt_device_for_passthrough()

2025-02-11 Thread Orzel, Michal
On 11/02/2025 12:18, Grygorii Strashko wrote: > > > The dt_device_for_passthrough() is called many times during Xen > initialization and Dom0 creation. On every call it traverses struct > dt_device_node properties list and compares compares properties name with double "compares" > "xen,passth

Re: [PATCH] device-tree: optimize dt_device_for_passthrough()

2025-02-12 Thread Orzel, Michal
On 11/02/2025 16:14, Grygorii Strashko wrote: > > > On 11.02.25 14:32, Julien Grall wrote: >> >> >> On 11/02/2025 11:57, Orzel, Michal wrote: >>> On 11/02/2025 12:18, Grygorii Strashko wrote: >>>> >>>> >>>> The dt_devi

Re: [PATCH v2 2/2] arch: arm64: always set IL=1 when injecting an abort exception

2025-02-14 Thread Orzel, Michal
set to 1 unconditionally. > > To align code with the specification, set .len field to 1 in > inject_abt64_exception() and remove unneeded third parameter. > > Signed-off-by: Volodymyr Babchuk Reviewed-by: Michal Orzel ~Michal

Re: [PATCH] arch: arm64: always set EL=1 when injecting undefined exception

2025-02-13 Thread Orzel, Michal
Hi Volodymyr, NIT: s/EL/IL/ in commit title One remark below. On 12/02/2025 23:03, Stefano Stabellini wrote: > > > On Wed, 12 Feb 2025, Volodymyr Babchuk wrote: >> ARM Architecture Reference Manual states that EL field of ESR_EL1 >> register should be 1 when EC is 0b00 aka HSR_EC_UNKNOWN.

Re: [PATCH] arch: arm64: always set EL=1 when injecting undefined exception

2025-02-13 Thread Orzel, Michal
You seem to have accidentally dropped xen-devel. Re-adding. On 13/02/2025 12:04, Volodymyr Babchuk wrote: > > > Hi Michal, > > "Orzel, Michal" writes: > >> Hi Volodymyr, >> >> NIT: s/EL/IL/ in commit title > > Sure, thanks. >

Re: xen | Failed pipeline for staging | b5b2f987

2025-02-13 Thread Orzel, Michal
On 13/02/2025 21:18, Stefano Stabellini wrote: > > > On Thu, 13 Feb 2025, Jan Beulich wrote: >> On 13.02.2025 15:18, GitLab wrote: >>> >>> >>> Pipeline #1669696445 has failed! >>> >>> Project: xen ( https://gitlab.com/xen-project/hardware/xen ) >>> Branch: staging ( >>> https://gitlab.com/xen

Re: [PATCH] xen/arm: Create GIC node using the node name from host dt

2025-02-20 Thread Orzel, Michal
On 20/02/2025 03:26, Stefano Stabellini wrote: > > > On Wed, 19 Feb 2025, Michal Orzel wrote: >> At the moment the GIC node we create for hwdom has a name >> "interrupt-controller". Change it so that we use the same name as the >> GIC node from host device tree. This is done for at least 2 pur

Re: [PATCH v2] xen/arm: Don't use copy_from_paddr for DTB relocation

2025-02-26 Thread Orzel, Michal
n. > > Given that there is nothing preventing the relocation since the region > is already mapped, fix that by open-coding copy_from_paddr inside > relocate_fdt, without mapping on the fixmap. > > Signed-off-by: Luca Fancellu Acked-by: Michal Orzel ~Michal

Re: [PATCH] xen/arm: Don't use copy_from_paddr for DTB relocation

2025-02-26 Thread Orzel, Michal
On 26/02/2025 09:36, Luca Fancellu wrote: > > > Currently the early stage of the Arm boot maps the DTB using > early_fdt_map() using PAGE_HYPERVISOR_RO which is cacheable > read-only memory, later during DTB relocation the function > copy_from_paddr() is used to map pages in the same range on

Re: [PATCH] xen/arm: Don't use copy_from_paddr for DTB relocation

2025-02-26 Thread Orzel, Michal
On 26/02/2025 11:45, Luca Fancellu wrote: > > > Hi Michal, > >> On 26 Feb 2025, at 10:38, Orzel, Michal wrote: >> >> >> >> On 26/02/2025 09:36, Luca Fancellu wrote: >>> >>> >>> Currently the early stage of the Arm boot map

Re: [PATCH] xen/arm: Don't use copy_from_paddr for DTB relocation

2025-02-26 Thread Orzel, Michal
On 26/02/2025 11:59, Luca Fancellu wrote: > > >>> > >return fdt; > } > @@ -362,7 +363,7 @@ void asmlinkage __init start_xen(unsigned long > fdt_paddr) >if ( acpi_disabled ) >{ >printk("Booting using Device Tree\n"); > -devic

Re: [PATCH v2 2/2] xen/arm: Restrict Kconfig configuration for LLC coloring

2025-02-17 Thread Orzel, Michal
On 17/02/2025 14:15, Luca Fancellu wrote: > > > Hi Michal, > >> On 17 Feb 2025, at 12:55, Orzel, Michal wrote: >> >> >> >> On 17/02/2025 11:27, Luca Fancellu wrote: >>> >>> >>> LLC coloring can be used only on MMU sys

Re: [PATCH v2 2/2] xen/arm: Restrict Kconfig configuration for LLC coloring

2025-02-17 Thread Orzel, Michal
On 17/02/2025 11:27, Luca Fancellu wrote: > > > LLC coloring can be used only on MMU system, move the code > that selects it from ARM_64 to MMU and add the ARM_64 > dependency. > > While there, add a clarification comment in the startup > code related to the LLC coloring, because boot_fdt_inf

Re: [PATCH v2] xen/dom0less: support for vcpu affinity

2025-02-17 Thread Orzel, Michal
On 15/02/2025 01:17, Stefano Stabellini wrote: > > > Add vcpu affinity to the dom0less bindings. Example: > > dom1 { > ... > cpus = <4>; > vcpu0 { >

Re: [PATCH v3 2/2] xen/arm: Restrict Kconfig configuration for LLC coloring

2025-02-18 Thread Orzel, Michal
On 18/02/2025 10:51, Luca Fancellu wrote: > > > LLC coloring can be used only on MMU system, move the code > that selects it from ARM_64 to MMU and add the ARM_64 > dependency. > > Signed-off-by: Luca Fancellu Reviewed-by: Michal Orzel ~Michal

Re: [PATCH v3 2/2] xen/arm: Restrict Kconfig configuration for LLC coloring

2025-02-18 Thread Orzel, Michal
On 18/02/2025 14:44, Jan Beulich wrote: > > > On 18.02.2025 10:51, Luca Fancellu wrote: >> LLC coloring can be used only on MMU system, > > Just for my own education: Why is this? I read this as it refers to the feature we have in Xen, not the generic concept. You could in theory achieve cach

Re: [PATCH] xen/arm: Fix platforms Kconfig indent

2025-03-03 Thread Orzel, Michal
On 03/03/2025 11:08, Bertrand Marquis wrote: > > > Fix platforms/Kconfig help indent to respect the standard (tab + 2 > spaces). > > Signed-off-by: Bertrand Marquis Reviewed-by: Michal Orzel Do you plan to fix also arch/arm/Kconfig.debug? You could squeeze it in this patch as well :) ~Mic

Re: [PATCH] xen/arm: Fix platforms Kconfig indent

2025-03-03 Thread Orzel, Michal
On 03/03/2025 11:15, Bertrand Marquis wrote: > > > Hi Michal, > >> On 3 Mar 2025, at 11:13, Orzel, Michal wrote: >> >> >> >> On 03/03/2025 11:08, Bertrand Marquis wrote: >>> >>> >>> Fix platforms/Kconfig help inden

Re: [PATCH v2] xen/arm: Fix platforms Kconfig indent

2025-03-03 Thread Orzel, Michal
On 03/03/2025 11:55, Bertrand Marquis wrote: > > >> On 3 Mar 2025, at 11:37, Orzel, Michal wrote: >> >> >> >> On 03/03/2025 11:27, Bertrand Marquis wrote: >>> >>> >>> Fix platforms/Kconfig and Kconfig.debug help ident to respect

Re: [PATCH v2] xen/arm: Fix platforms Kconfig indent

2025-03-03 Thread Orzel, Michal
off-by: Bertrand Marquis Reviewed-by: Michal Orzel ~Michal

Re: [PATCH v2 1/2] xen/arm: mpu: Move some of the definitions to common file

2025-03-05 Thread Orzel, Michal
On 05/03/2025 10:37, Ayan Kumar Halder wrote: > Hi Michal > > On 05/03/2025 07:28, Orzel, Michal wrote: >> >> On 04/03/2025 18:57, Ayan Kumar Halder wrote: >>> For AArch32, refer to ARM DDI 0568A.c ID110520. >>> MPU_REGION_SHIFT is same between

Re: [PATCH v2 2/2] xen/arm: mpu: Ensure that the page size is 4KB

2025-03-04 Thread Orzel, Michal
sertion is moved under "xen/arch/arm/mpu" as it applies > for both arm64 and arm32 based systems. > > Signed-off-by: Ayan Kumar Halder Acked-by: Michal Orzel ~Michal

Re: [PATCH v2 1/2] xen/arm: mpu: Move some of the definitions to common file

2025-03-04 Thread Orzel, Michal
ONS_SHIFT) > #define NUM_MPU_REGIONS_MASK(NUM_MPU_REGIONS - 1) > -#endif /* __ARM64_MPU_H__ */ > +#endif /* __ARM_MPU_H__ */ Would you mind adding extra line between last definition and #endif? With that: Acked-by: Michal Orzel ~Michal

Re: [PATCH v3] xen/arm: Don't use copy_from_paddr for DTB relocation

2025-03-04 Thread Orzel, Michal
n. > > Given that there is nothing preventing the relocation since the region > is already mapped, fix that by open-coding copy_from_paddr inside > relocate_fdt, without mapping on the fixmap. > > Signed-off-by: Luca Fancellu Reviewed-by: Michal Orzel ~Michal

Re: xen | Failed pipeline for staging | fe5757f2

2025-03-07 Thread Orzel, Michal
On 07/03/2025 08:28, Jan Beulich wrote: > > > On 06.03.2025 18:25, GitLab wrote: >> >> >> Pipeline #1703410235 has failed! >> >> Project: xen ( https://gitlab.com/xen-project/hardware/xen ) >> Branch: staging ( >> https://gitlab.com/xen-project/hardware/xen/-/commits/staging ) >> >> Commit: f

Re: [PATCH 1/2] xen/arm: Improve handling of nr_spis

2025-03-11 Thread Orzel, Michal
On 11/03/2025 14:26, Bertrand Marquis wrote: > > > Hi Michal, > >> On 11 Mar 2025, at 12:06, Orzel, Michal wrote: >> >> >> >> On 11/03/2025 11:12, Bertrand Marquis wrote: >>> >>> >>>> On 11 Mar 2025, at 10:59, Orzel,

Re: [PATCH 1/2] xen/arm: Improve handling of nr_spis

2025-03-11 Thread Orzel, Michal
On 11/03/2025 10:30, Bertrand Marquis wrote: > > > Hi Michal, > >> On 11 Mar 2025, at 10:04, Michal Orzel wrote: >> >> At the moment, we print a warning about max number of IRQs supported by >> GIC bigger than vGIC only for hardware domain. This check is not hwdom >> special, and should be m

Re: [PATCH 1/2] xen/arm: Improve handling of nr_spis

2025-03-11 Thread Orzel, Michal
On 11/03/2025 11:12, Bertrand Marquis wrote: > > >> On 11 Mar 2025, at 10:59, Orzel, Michal wrote: >> >> >> >> On 11/03/2025 10:30, Bertrand Marquis wrote: >>> >>> >>> Hi Michal, >>> >>>> On 11 Mar 2025,

Re: [PATCH] tools/init-dom0less: Fix cpus > 1 and xenstore entries

2025-03-11 Thread Orzel, Michal
On 05/03/2025 22:58, Jason Andryuk wrote: > > > The trailing / in the path is incorrect and generates an error when > writing to xenstore: > Checking domid: 1 > Init dom0less domain: 1 > init-dom0less: writing to xenstore: No error information > > init-dom0less exits without finishing initial