On 10/24/24 10:26, Andrew Cooper wrote:
From: "Daniel P. Smith"
The former is about to disappear.
In some cases, introduce a local struct boot_module pointer. Judgement on
where to do this, and on constness, is based on what creates least churn
overall.
No functional change.
Signed-off-by:
Hi Jani,
kernel test robot noticed the following build warnings:
[auto build test WARNING on drm-misc/drm-misc-next]
[also build test WARNING on next-20241024]
[cannot apply to drm-exynos/exynos-drm-next shawnguo/for-next
drm-xe/drm-xe-next linus/master v6.12-rc4]
[If your patch is applied to
Hi Jani,
kernel test robot noticed the following build errors:
[auto build test ERROR on drm-misc/drm-misc-next]
[also build test ERROR on next-20241024]
[cannot apply to drm-exynos/exynos-drm-next shawnguo/for-next
drm-xe/drm-xe-next linus/master v6.12-rc4]
[If your patch is applied to the
On Thu, 24 Oct 2024, Javi Merino wrote:
> Use FF_DISABLE_UMASK_FOR_DOCKER_EXECUTOR so that GitLab CI clones xen
> using the user in the image, instead of as root[0].
>
> In qemu-smoke-dom0*.sh and qemu-alpine-x86_64.sh, use fakeroot to
> create the rootfs images that untar a tarball that create ch
Hi Jani,
kernel test robot noticed the following build errors:
[auto build test ERROR on drm-misc/drm-misc-next]
[also build test ERROR on next-20241024]
[cannot apply to drm-exynos/exynos-drm-next shawnguo/for-next
drm-xe/drm-xe-next linus/master v6.12-rc4]
[If your patch is applied to the
On 24/10/2024 11:04 am, Javi Merino wrote:
> Rework the container to use heredocs for readability, and use
> apt-get --no-install-recommends to keep the size down.
>
> This reduces the size of the (uncompressed) container from 3.44GB to 1.67GB.
!!
>
> Signed-off-by: Javi Merino
> ---
> automati
Hi Ayan,
> On 24 Oct 2024, at 09:02, Ayan Kumar Halder wrote:
>
> Hi Julien,
>
> On 23/10/2024 17:30, Julien Grall wrote:
>>
>>
>> On 23/10/2024 17:18, Julien Grall wrote:
>>>
>>>
>>> On 23/10/2024 17:13, Julien Grall wrote:
On 23/10/2024 17:06, Ayan Kumar Halder wrote:
>>>
On 23/10/2024 02:23, Stefano Stabellini wrote:
> +Julien
>
> On Wed, 16 Oct 2024, Ryan Roberts wrote:
>> + Juergen Gross, Stefano Stabellini
>>
>> This was a rather tricky series to get the recipients correct for and my
>> script
>> did not realize that "supporter" was a pseudonym for "maintainer
On Thu, Oct 24, 2024 at 12:33 PM Jani Nikula wrote:
>
> We stopped using the driver initialized date in commit 7fb8af6798e8
> ("drm: deprecate driver date") and (eventually) started returning "0"
> for drm_version ioctl instead.
>
> Finish the job, and remove the unused date member from struct
> d
We stopped using the driver initialized date in commit 7fb8af6798e8
("drm: deprecate driver date") and (eventually) started returning "0"
for drm_version ioctl instead.
Finish the job, and remove the unused date member from struct
drm_driver, its initialization from drivers, along with the common
drm_dev_register() already prints the same information on successful
init. Remove the redundant prints.
Signed-off-by: Jani Nikula
---
Note: I prefer to merge this together with the next patch via
drm-misc-next.
Cc: Oleksandr Andrushchenko
Cc: Maarten Lankhorst
Cc: Maxime Ripard
Cc: Thomas
Jani Nikula writes:
Hello Jani,
> We stopped using the driver initialized date in commit 7fb8af6798e8
> ("drm: deprecate driver date") and (eventually) started returning "0"
> for drm_version ioctl instead.
>
> Finish the job, and remove the unused date member from struct
> drm_driver, its initi
We can't drop them fully yet, but we can limit their scope to almost nothing,
which serves the same purpose.
This removes the ability to accidentally reintroduce buggy uses of
__va(mbi->mods_addr).
No functional change.
Signed-off-by: Andrew Cooper
---
CC: Jan Beulich
CC: Roger Pau Monné
CC:
From: "Daniel P. Smith"
Now that the module list is encapsulated inside boot_info, we can do away with
the initial_images pointer.
No functional change.
Signed-off-by: Daniel P. Smith
Signed-off-by: Andrew Cooper
---
CC: Jan Beulich
CC: Roger Pau Monné
CC: Daniel P. Smith
v7.5:
* Rearran
We're about to introduce alternative mapping functions, and passing NULL was
always a slightly weird way to express unmap. Make an explicit unmap
function, to avoid having two different valid ways of unmapping.
No functional change.
Signed-off-by: Andrew Cooper
---
CC: Jan Beulich
CC: Roger Pa
From: "Daniel P. Smith"
Convert converting the call to bzimage_headroom(), as well as using
bi->mod[0]. It will be used externally by later changes.
No functional change.
Signed-off-by: Daniel P. Smith
Signed-off-by: Andrew Cooper
---
CC: Jan Beulich
CC: Roger Pau Monné
CC: Daniel P. Smith
From: "Daniel P. Smith"
The former is about to disappear.
In some cases, introduce a local struct boot_module pointer. Judgement on
where to do this, and on constness, is based on what creates least churn
overall.
No functional change.
Signed-off-by: Daniel P. Smith
Signed-off-by: Andrew Coo
discard_initial_images() only works because init_domheap_pages() with ps==pe
is a no-op.
In dom0_construct(), explaining the significance of setting the initrd length
to 0, and put an explicit check in discard_initial_images().
No functional change.
Signed-off-by: Andrew Cooper
---
CC: Jan Beul
On Thu, Oct 24, 2024 at 11:51:16AM +, Anthony PERARD wrote:
> On Thu, Oct 24, 2024 at 11:04:19AM +0100, Javi Merino wrote:
> > diff --git a/automation/build/debian/12-arm64v8-arm32-gcc.dockerfile
> > b/automation/build/debian/12-arm64v8-arm32-gcc.dockerfile
> > new file mode 100644
> > index 0
On Thu, Oct 24, 2024 at 11:04:19AM +0100, Javi Merino wrote:
> diff --git a/automation/build/debian/12-arm64v8-arm32-gcc.dockerfile
> b/automation/build/debian/12-arm64v8-arm32-gcc.dockerfile
> new file mode 100644
> index ..bdc935706bfa
> --- /dev/null
> +++ b/automation/build/debian/
Hi Bertrand,
On Thu, Oct 24, 2024 at 11:46 AM Bertrand Marquis
wrote:
>
> Hi Jens,
>
> > On 23 Oct 2024, at 16:51, Jens Wiklander wrote:
> >
> > Hi Bertrand,
> >
> > On Wed, Oct 16, 2024 at 10:32 AM Bertrand Marquis
> > wrote:
> >>
> >> When an RXTX buffer is mapped by a VM transmit it to the S
Hi Bertrand,
On Thu, Oct 24, 2024 at 11:50 AM Bertrand Marquis
wrote:
>
> Hi Jens,
>
> > On 24 Oct 2024, at 09:41, Jens Wiklander wrote:
> >
> > Hi Bertrand,
> >
> > On Wed, Oct 16, 2024 at 10:32 AM Bertrand Marquis
> > wrote:
> >>
> >> Remove the per VM flag to store if notifications are enabl
On 10/24/24 05:13, Jürgen Groß wrote:
On 23.10.24 17:55, Daniel P. Smith wrote:
On 10/23/24 09:10, Juergen Gross wrote:
Add a new domctl sub-function to get data of a domain having changed
state (this is needed by Xenstore).
The returned state just contains the domid, the domain unique id,
and
Hi Jens,
> On 24 Oct 2024, at 10:50, Jens Wiklander wrote:
>
> Hi Bertrand,
>
> On Wed, Oct 16, 2024 at 10:32 AM Bertrand Marquis
> wrote:
>>
>> Add support for FFA_MSG_SEND2 to send indirect messages from a VM to a
>> secure partition.
>>
>> Signed-off-by: Bertrand Marquis
>> ---
>> Change
Hi,
These series continues the refresh of the CI containers after[0], focusing on
the
remaining Debian 12 containers. The containers now build and run as a
non-root user, use heredocs for readability, and use
apt-get --no-install-recommends to minimize the installation of unnecessary
packages.
On Wed, 2024-10-23 at 17:03 +0200, Takashi Iwai wrote:
> On Wed, 23 Oct 2024 15:50:09 +0200,
> Philipp Stanner wrote:
> >
> > On Tue, 2024-10-22 at 16:08 +0200, Takashi Iwai wrote:
> > > On Tue, 15 Oct 2024 20:51:12 +0200,
> > > Philipp Stanner wrote:
> > > >
> > > > pci_intx() is a hybrid functi
Rework the container to use heredocs for readability and use apt-get
--no-install-recommends to keep the size down. Rename the job to
debian-12-arm64-* to follow the naming scheme of all the other CI jobs.
This reduces the size of the debian:12-arm64v8 from 2.25GB down to 1.62GB.
Signed-off-by:
Rework the container to run as non-root, use heredocs for readability and use
apt-get
--no-install-recommends to keep the size down. Rename the CI jobs to
debian-12-arm32- to follow the naming scheme of all the other
CI jobs.
Signed-off-by: Javi Merino
---
.../debian/12-arm64v8-arm32-gcc.docke
On Thu, Oct 24, 2024 at 11:04:17AM +0100, Javi Merino wrote:
> Rework the container to be non-root, use heredocs for readability, and
> use apt-get --no-install-recommends to keep the size down. Rename the
> job to x86_32, to be consistent with XEN_TARGET_ARCH and the
> naming scheme of all the ot
Hi Bertrand,
On Thu, Oct 24, 2024 at 12:05 PM Bertrand Marquis
wrote:
>
> Hi Jens,
>
> > On 24 Oct 2024, at 10:50, Jens Wiklander wrote:
> >
> > Hi Bertrand,
> >
> > On Wed, Oct 16, 2024 at 10:32 AM Bertrand Marquis
> > wrote:
> >>
> >> Add support for FFA_MSG_SEND2 to send indirect messages fr
The microcode suffix is redundant, and "microcode loading" is the more common
term
---
xen/arch/x86/cpu/microcode/amd.c | 6 +++---
xen/arch/x86/cpu/microcode/core.c| 27 ---
xen/arch/x86/cpu/microcode/intel.c | 8
xen/arch/x86/cpu/microcode/private.h |
This separates the collect_cpu_info() and cpu_request_microcode() calls for
later cleanup, and frees up the name to be reused a little differently.
No functional change.
Signed-off-by: Andrew Cooper
---
CC: Jan Beulich
CC: Roger Pau Monné
---
xen/arch/x86/cpu/microcode/core.c | 21 ++-
Misc cleanup without functional change. Mostly to improve clarity.
Andrew Cooper (5):
x86/ucode: Rename hypercall-context functions
x86/ucode: Drop the parse_blob() wrapper
x86/ucode: Rename the cpu_request_microcode() hook to parse()
x86/ucode: Rename the apply_microcode() hook to load()
Hi Bertrand,
On Thu, Oct 24, 2024 at 12:01 PM Bertrand Marquis
wrote:
>
> Hi Jens,
>
> > On 24 Oct 2024, at 10:15, Jens Wiklander wrote:
> >
> > On Wed, Oct 23, 2024 at 11:58 AM Jens Wiklander
> > wrote:
> >>
> >> Hi Bertrand,
> >>
> >> On Wed, Oct 16, 2024 at 10:32 AM Bertrand Marquis
> >> wr
On Thu, Oct 24, 2024 at 03:04:10PM +0100, Andrew Cooper wrote:
> On 24/10/2024 11:04 am, Javi Merino wrote:
> > Rework the container to use heredocs for readability, and use
> > apt-get --no-install-recommends to keep the size down.
> >
> > This reduces the size of the (uncompressed) container from
On 10/24/24 10:26, Andrew Cooper wrote:
From: "Daniel P. Smith"
Now that the module list is encapsulated inside boot_info, we can do away with
the initial_images pointer.
No functional change.
Signed-off-by: Daniel P. Smith
Signed-off-by: Andrew Cooper
---
CC: Jan Beulich
CC: Roger Pau Mon
On 10/24/24 10:26, Andrew Cooper wrote:
From: "Daniel P. Smith"
Convert converting the call to bzimage_headroom(), as well as using
bi->mod[0]. It will be used externally by later changes.
No functional change.
Signed-off-by: Daniel P. Smith
Signed-off-by: Andrew Cooper
---
CC: Jan Beulich
Hi Jens,
> On 24 Oct 2024, at 15:43, Jens Wiklander wrote:
>
> Hi Bertrand,
>
> On Thu, Oct 24, 2024 at 12:05 PM Bertrand Marquis
> wrote:
>>
>> Hi Jens,
>>
>>> On 24 Oct 2024, at 10:50, Jens Wiklander wrote:
>>>
>>> Hi Bertrand,
>>>
>>> On Wed, Oct 16, 2024 at 10:32 AM Bertrand Marquis
>
On 10/24/24 12:03, Andrew Cooper wrote:
discard_initial_images() only works because init_domheap_pages() with ps==pe
is a no-op.
In dom0_construct(), explaining the significance of setting the initrd length
to 0, and put an explicit check in discard_initial_images().
No functional change.
Sign
On 24/10/2024 4:48 pm, Roger Pau Monne wrote:
> When using AMD-VI interrupt remapping the vector field in the IO-APIC RTE is
> repurposed to contain part of the offset into the remapping table. Previous
> to
> 2ca9fbd739b8 Xen had logic so that the offset into the interrupt remapping
> table woul
On Thu, 24 Oct 2024, victorm.l...@amd.com wrote:
> From: Victor Lira
>
> Add container image build files:
> - alpine/x86_64-build
> - alpine/x86_64-rootfs
> - Makefile
>
> Add CI configuration and jobs to produce binaries for xen tests:
> - xen-argo Linux Xen Argo kernel module
> - bzIm
From: Victor Lira
Add container image build files:
- alpine/x86_64-build
- alpine/x86_64-rootfs
- Makefile
Add CI configuration and jobs to produce binaries for xen tests:
- xen-argo Linux Xen Argo kernel module
- bzImage Linux kernel
- libargo Linux Argo shared libr
From: Victor Lira
The current configuration of Xen CI generates test binaries using "export"
jobs in every pipeline. This unecessarily uses a large amount of storage
and network traffic because artifacts are duplicated over each project and
branch that uses this configuration.
Instead, use a sep
On 10/24/24 10:26, Andrew Cooper wrote:
We're about to introduce alternative mapping functions, and passing NULL was
always a slightly weird way to express unmap. Make an explicit unmap
function, to avoid having two different valid ways of unmapping.
No functional change.
Signed-off-by: Andrew
> heredocs for readability and use apt-get --no-install-recommends to
> keep the size down.
>
> Changed the libpcre3-dev dependency to libpcre3, as the -dev package
> is only needed for building, not for running.
>
> With the cleanups, the size of the container is reduced from 882MB to
> 782MB.
On Thu, 24 Oct 2024, Javi Merino wrote:
> Rework the container to use heredocs for readability and use apt-get
> --no-install-recommends to keep the size down. Rename the job to
> debian-12-arm64-* to follow the naming scheme of all the other CI jobs.
>
> This reduces the size of the debian:12-ar
On 10/24/24 10:26, Andrew Cooper wrote:
We can't drop them fully yet, but we can limit their scope to almost nothing,
which serves the same purpose.
This removes the ability to accidentally reintroduce buggy uses of
__va(mbi->mods_addr).
No functional change.
Signed-off-by: Andrew Cooper
---
Hi Julien,
On 23/10/2024 17:30, Julien Grall wrote:
On 23/10/2024 17:18, Julien Grall wrote:
On 23/10/2024 17:13, Julien Grall wrote:
On 23/10/2024 17:06, Ayan Kumar Halder wrote:
Hi Luca/Julien,
On 22/10/2024 17:31, Luca Fancellu wrote:
Hi Julien,
On 22 Oct 2024, at 14:13, Julien G
On 23.10.24 17:55, Daniel P. Smith wrote:
On 10/23/24 09:10, Juergen Gross wrote:
Add a new domctl sub-function to get data of a domain having changed
state (this is needed by Xenstore).
The returned state just contains the domid, the domain unique id,
and some flags (existing, shutdown, dying)
Hi Jens,
> On 24 Oct 2024, at 10:15, Jens Wiklander wrote:
>
> On Wed, Oct 23, 2024 at 11:58 AM Jens Wiklander
> wrote:
>>
>> Hi Bertrand,
>>
>> On Wed, Oct 16, 2024 at 10:32 AM Bertrand Marquis
>> wrote:
>>>
>>> Create a bitmap to store which feature is supported or not by the
>>> firmware
Use FF_DISABLE_UMASK_FOR_DOCKER_EXECUTOR so that GitLab CI clones xen
using the user in the image, instead of as root[0].
In qemu-smoke-dom0*.sh and qemu-alpine-x86_64.sh, use fakeroot to
create the rootfs images that untar a tarball that create character
devices. cpio replicates the block and ch
Rework the container to be non-root, use heredocs for readability, and
use apt-get --no-install-recommends to keep the size down. Rename the
job to x86_32, to be consistent with XEN_TARGET_ARCH and the
naming scheme of all the other CI jobs:
${VERSION}-${ARCH}-${BUILD_NAME}
Remove build dependenc
Rework the container to build and run cppcheck as a normal user. Use
heredocs for readability and use apt-get --no-install-recommends to
keep the size down.
Changed the libpcre3-dev dependency to libpcre3, as the -dev package
is only needed for building, not for running.
With the cleanups, the s
Hi Jens,
> On 23 Oct 2024, at 15:15, Jens Wiklander wrote:
>
> Hi Bertrand,
>
> On Wed, Oct 16, 2024 at 10:32 AM Bertrand Marquis
> wrote:
>>
>> Make use and required to have bit 15 convention respected by secure
>> world (having bit 15 of IDs set for secure endpoints and non-set for
>> non-s
Hi Bertrand,
On Wed, Oct 16, 2024 at 10:32 AM Bertrand Marquis
wrote:
>
> Add support for FFA_MSG_SEND2 to send indirect messages from a VM to a
> secure partition.
>
> Signed-off-by: Bertrand Marquis
> ---
> Changes in v2:
> - rebase
> ---
> xen/arch/arm/tee/ffa.c | 5
> xen/arch
On Wed, Oct 23, 2024 at 11:58 AM Jens Wiklander
wrote:
>
> Hi Bertrand,
>
> On Wed, Oct 16, 2024 at 10:32 AM Bertrand Marquis
> wrote:
> >
> > Create a bitmap to store which feature is supported or not by the
> > firmware and use it to filter which calls are done to the firmware.
> >
> > While th
Hi Jens,
> On 23 Oct 2024, at 16:51, Jens Wiklander wrote:
>
> Hi Bertrand,
>
> On Wed, Oct 16, 2024 at 10:32 AM Bertrand Marquis
> wrote:
>>
>> When an RXTX buffer is mapped by a VM transmit it to the SPMC when it
>> supports RX_ACQUIRE.
>> As a consequence of that, we must acquire the RX bu
Hi Jens,
> On 24 Oct 2024, at 09:41, Jens Wiklander wrote:
>
> Hi Bertrand,
>
> On Wed, Oct 16, 2024 at 10:32 AM Bertrand Marquis
> wrote:
>>
>> Remove the per VM flag to store if notifications are enabled or not as
>> the only case where they are not, if notifications are enabled globally,
>
On Tue, Oct 22, 2024 at 05:25:00PM +0100, Andrew Cooper wrote:
> diff --git a/tools/firmware/xen-dir/Makefile b/tools/firmware/xen-dir/Makefile
> index 6f5e208ab413..e19916f76722 100644
> --- a/tools/firmware/xen-dir/Makefile
> +++ b/tools/firmware/xen-dir/Makefile
> @@ -1,4 +1,5 @@
> XEN_ROOT = $
Rework the container to use heredocs for readability, and use
apt-get --no-install-recommends to keep the size down.
This reduces the size of the (uncompressed) container from 3.44GB to 1.67GB.
Signed-off-by: Javi Merino
---
automation/build/debian/12-x86_64.dockerfile | 68
Hi Bertrand,
On Wed, Oct 16, 2024 at 10:32 AM Bertrand Marquis
wrote:
>
> Move the direct message handling function in its own source file and
> rename it to have a ffa_ prefix.
> This is a preparation to add support for indirect messages which will
> go into this newly created source file.
>
> S
61 matches
Mail list logo