On 04/06/2019 13:55, Julien Grall wrote:
>> @@ -476,8 +474,6 @@ struct arch_domain
>> #define has_pirq(d) (!!((d)->arch.emulation_flags &
>> X86_EMU_USE_PIRQ))
>> #define has_vpci(d) (!!((d)->arch.emulation_flags &
>> X86_EMU_VPCI))
>> -#define has_arch_pdevs(d) (!list_empty(
On 6/4/19 2:14 PM, Jan Beulich wrote:
On 04.06.19 at 15:05, wrote:
Hi Jan,
On 6/4/19 2:03 PM, Jan Beulich wrote:
On 04.06.19 at 14:55, wrote:
On 6/4/19 1:42 PM, Jan Beulich wrote:
--- a/xen/include/xen/pci.h
+++ b/xen/include/xen/pci.h
@@ -121,7 +121,9 @@ struct pci_dev {
};
>>> On 04.06.19 at 15:05, wrote:
> Hi Jan,
>
> On 6/4/19 2:03 PM, Jan Beulich wrote:
> On 04.06.19 at 14:55, wrote:
>>> On 6/4/19 1:42 PM, Jan Beulich wrote:
--- a/xen/include/xen/pci.h
+++ b/xen/include/xen/pci.h
@@ -121,7 +121,9 @@ struct pci_dev {
};
Hi Jan,
On 6/4/19 2:03 PM, Jan Beulich wrote:
On 04.06.19 at 14:55, wrote:
On 6/4/19 1:42 PM, Jan Beulich wrote:
--- a/xen/include/xen/pci.h
+++ b/xen/include/xen/pci.h
@@ -121,7 +121,9 @@ struct pci_dev {
};
#define for_each_pdev(domain, pdev) \
-list_for_each_entry(pdev, &(do
>>> On 04.06.19 at 14:55, wrote:
> On 6/4/19 1:42 PM, Jan Beulich wrote:
>> --- a/xen/include/xen/pci.h
>> +++ b/xen/include/xen/pci.h
>> @@ -121,7 +121,9 @@ struct pci_dev {
>> };
>>
>> #define for_each_pdev(domain, pdev) \
>> -list_for_each_entry(pdev, &(domain->arch.pdev_list), domai
Hi,
On 6/4/19 1:42 PM, Jan Beulich wrote:
Its management shouldn't be arch-specific, and in particular there
should be no need for special precautions when creating the special
domains.
At this occasion
- correct parenthesization of for_each_pdev(),
- stop open-coding for_each_pdev() in vPCI co
Its management shouldn't be arch-specific, and in particular there
should be no need for special precautions when creating the special
domains.
At this occasion
- correct parenthesization of for_each_pdev(),
- stop open-coding for_each_pdev() in vPCI code.
Signed-off-by: Jan Beulich
--- a/xen/a