>>> On 04.06.19 at 14:55, <julien.gr...@arm.com> wrote: > On 6/4/19 1:42 PM, Jan Beulich wrote: >> --- a/xen/include/xen/pci.h >> +++ b/xen/include/xen/pci.h >> @@ -121,7 +121,9 @@ struct pci_dev { >> }; >> >> #define for_each_pdev(domain, pdev) \ >> - list_for_each_entry(pdev, &(domain->arch.pdev_list), domain_list) >> + list_for_each_entry(pdev, &(domain)->pdev_list, domain_list) >> + >> +#define has_arch_pdevs(d) (!list_empty(&(d)->pdev_list)) > > This feels a bit strange to keep "arch" in the macro name when the code > is now generic. How about "domain_has_pdevs"?
Indeed I did notice this oddity too, but if such an adjustment is to be made then imo not in this patch. After all in turn I'd need to change all use sites. Jan _______________________________________________ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel