Re: [PATCH v3 3/6] arch/x86: rename debug.c to gdbsx.c

2021-08-24 Thread Bobby Eshleman
On Tue, Aug 24, 2021, 2:20 PM Jan Beulich wrote: > On 18.08.2021 22:29, Bobby Eshleman wrote: > > --- /dev/null > > +++ b/xen/include/asm-x86/gdbsx.h > > @@ -0,0 +1,17 @@ > > +#ifndef __X86_GDBX_H > > +#define __X86_GDBX_H__ > > + > > +#ifdef CONFIG_GDBSX > > + > > +int gdbsx_guest_mem_io(domid_t

Re: [PATCH v3 3/6] arch/x86: rename debug.c to gdbsx.c

2021-08-24 Thread Jan Beulich
On 18.08.2021 22:29, Bobby Eshleman wrote: > --- /dev/null > +++ b/xen/include/asm-x86/gdbsx.h > @@ -0,0 +1,17 @@ > +#ifndef __X86_GDBX_H > +#define __X86_GDBX_H__ > + > +#ifdef CONFIG_GDBSX > + > +int gdbsx_guest_mem_io(domid_t domid, struct xen_domctl_gdbsx_memio *iop); > + > +#else > + > +static

Re: [PATCH v3 3/6] arch/x86: rename debug.c to gdbsx.c

2021-08-24 Thread Andrew Cooper
On 18/08/2021 21:29, Bobby Eshleman wrote: > diff --git a/xen/arch/x86/Makefile b/xen/arch/x86/Makefile > index fe38cfd544..ef8c2c4770 100644 > --- a/xen/arch/x86/Makefile > +++ b/xen/arch/x86/Makefile > @@ -20,7 +20,7 @@ obj-y += cpuid.o > obj-$(CONFIG_PV) += compat.o > obj-$(CONFIG_PV32) += x86

[PATCH v3 3/6] arch/x86: rename debug.c to gdbsx.c

2021-08-18 Thread Bobby Eshleman
This commit renames debug.c to gdbsx.c to clarify its purpose. The function gdbsx_guest_mem_io() is moved from domctl.c to gdbsx.c. Although gdbsx_guest_mem_io() is conditionally removed from its single call site in domctl.c upon !CONFIG_GDBSX and so no stub is technically necessary, this commit