(2):
tests/qtest: Extract qtest_qom_has_concrete_type() helper
tests/qtest: Make qtest_has_accel() generic
tests/qtest/libqtest.c | 110 +++--
1 file changed, 61 insertions(+), 49 deletions(-)
Reviewed-by: Akihiko Odaki
On 2025/01/28 20:18, Philippe Mathieu-Daudé wrote:
Since commit b14a0b7469f ("accel: Use QOM classes for accel types")
accelerators are registered as QOM objects. Use QOM as a generic
API to query for available accelerators. This is in particular
useful to query hardware accelerators such HFV, Xe
On 2024/12/14 4:07, Richard Henderson wrote:
Signed-off-by: Richard Henderson
Reviewed-by: Akihiko Odaki
On 2024/04/24 21:32, Thomas Huth wrote:
On 24/04/2024 12.41, Prasad Pandit wrote:
On Wednesday, 24 April, 2024 at 03:36:01 pm IST, Philippe
Mathieu-Daudé wrote:
On 1/6/23 05:18, Akihiko Odaki wrote:
Recently MemReentrancyGuard was added to DeviceState to record that the
device is engaging in
XT_CREATE_WITH_FLAGS
+DEFINE_PROP_BIT("context_init", VirtIOGPU, parent_obj.conf.flags,
The convention is to use "-" instead of "_" as delimiters. See comments
for object_property_add() in: include/qom/object.h
Regards,
Akihiko Odaki
On 2024/01/03 0:35, Stefan Hajnoczi wrote:
v3:
- Rebase
- Define bql_lock() macro on a single line [Akihiko Odaki]
v2:
- Rename APIs bql_*() [PeterX]
- Spell out "Big QEMU Lock (BQL)" in doc comments [PeterX]
- Rename "iolock" variables in hw/remote/mpqemu-link.c [Harsh]
On 2023/12/19 16:53, Huang Rui wrote:
From: Antonio Caggiano
Support BLOB resources creation, mapping and unmapping by calling the
new stable virglrenderer 0.10 interface. Only enabled when available and
via the blob config. E.g. -device virtio-vga-gl,blob=true
I have another concern about de
On 2023/12/21 16:35, Xenia Ragiadakou wrote:
On 21/12/23 07:45, Akihiko Odaki wrote:
On 2023/12/19 16:53, Huang Rui wrote:
From: Xenia Ragiadakou
When the memory region has a different life-cycle from that of her
parent,
could be automatically released, once has been unparent and once all
On 2023/12/19 23:14, Peter Maydell wrote:
On Tue, 19 Dec 2023 at 13:49, Huang Rui wrote:
On Tue, Dec 19, 2023 at 08:20:22PM +0800, Akihiko Odaki wrote:
On 2023/12/19 16:53, Huang Rui wrote:
Sync up kernel headers to update venus macro till they are merged into
mainline.
Thanks for sorting
On 2023/12/19 16:53, Huang Rui wrote:
From: Robert Beckett
This relies on a virglrenderer change to include the dmabuf fd when
returning resource info.
Signed-off-by: Robert Beckett
Signed-off-by: Huang Rui
---
Changes in v6:
- Add scanout_blob function for virtio-gpu-virgl.
- Update for ne
On 2023/12/19 16:53, Huang Rui wrote:
From: Antonio Caggiano
Enable resource UUID feature and implement command resource assign UUID.
This is done by introducing a hash table to map resource IDs to their
UUIDs.
What about putting QemuUUID in struct virtio_gpu_simple_resource?
On 2023/12/19 16:53, Huang Rui wrote:
From: Antonio Caggiano
Support BLOB resources creation, mapping and unmapping by calling the
new stable virglrenderer 0.10 interface. Only enabled when available and
via the blob config. E.g. -device virtio-vga-gl,blob=true
Signed-off-by: Antonio Caggiano
On 2023/12/19 16:53, Huang Rui wrote:
From: Xenia Ragiadakou
When the memory region has a different life-cycle from that of her parent,
could be automatically released, once has been unparent and once all of her
references have gone away, via the object's free callback.
However, currently, the
On 2023/12/19 22:27, Huang Rui wrote:
On Tue, Dec 19, 2023 at 08:35:27PM +0800, Akihiko Odaki wrote:
On 2023/12/19 16:53, Huang Rui wrote:
Introduce a new virgl_gpu_resource data structure and helper functions
for virgl. It's used to add new member which is specific for virgl in
foll
On 2023/12/19 16:53, Huang Rui wrote:
Introduce a new virgl_gpu_resource data structure and helper functions
for virgl. It's used to add new member which is specific for virgl in
following patches of blob memory support.
The name is ambigious. It should tell that it's specific for virgl.
On 2023/12/19 16:53, Huang Rui wrote:
Sync up kernel headers to update venus macro till they are merged into
mainline.
Thanks for sorting things out with the kernel and spec.
Signed-off-by: Huang Rui
---
Changes in v6:
- Venus capset is applied in kernel, so update it in qemu for future us
On 2023/12/13 0:39, Stefan Hajnoczi wrote:
The Big QEMU Lock (BQL) has many names and they are confusing. The
actual QemuMutex variable is called qemu_global_mutex but it's commonly
referred to as the BQL in discussions and some code comments. The
locking APIs, however, are called qemu_mutex_lock
On 2023/09/22 16:42, Alyssa Ross wrote:
Akihiko Odaki writes:
Practically there is very low chance to hit the bug. I think only
fuzzers and malicious actors will trigger it, and probably no one will
dare using virtio-gpu-rutabaga or virtio-gpu-gl in a security-sensitive
context.
Well, this
On 2023/09/22 9:03, Gurchetan Singh wrote:
On Wed, Sep 20, 2023 at 5:05 AM Mark Cave-Ayland
mailto:mark.cave-ayl...@ilande.co.uk>>
wrote:
On 20/09/2023 12:42, Akihiko Odaki wrote:
> On 2023/08/29 9:36, Gurchetan Singh wrote:
>> This adds initial support fo
On 2023/06/01 12:18, Akihiko Odaki wrote:
Recently MemReentrancyGuard was added to DeviceState to record that the
device is engaging in I/O. The network device backend needs to update it
when delivering a packet to a device.
This implementation follows what bottom half does, but it does not add
Singh
Tested-by: Alyssa Ross
Tested-by: Emmanouil Pitsidianakis
Tested-by: Akihiko Odaki
Reviewed-by: Emmanouil Pitsidianakis
Reviewed-by: Antonio Caggiano
Reviewed-by: Akihiko Odaki
---
hw/display/virtio-gpu-pci-rutabaga.c | 47 ++
hw/display/virtio-gpu-rutabaga.c | 1119 +++
On 2023/09/20 17:57, Xenia Ragiadakou wrote:
On 20/9/23 01:18, Akihiko Odaki wrote:
On 2023/09/19 23:21, Xenia Ragiadakou wrote:
On 19/9/23 13:44, Akihiko Odaki wrote:
On 2023/09/19 19:28, Xenia Ragiadakou wrote:
On 15/9/23 18:11, Akihiko Odaki wrote:
On 2023/09/15 20:11, Huang Rui wrote
On 2023/09/20 14:50, Huang Rui wrote:
On Sat, Sep 16, 2023 at 12:37:29AM +0800, Akihiko Odaki wrote:
On 2023/09/16 1:04, Akihiko Odaki wrote:
On 2023/09/15 20:11, Huang Rui wrote:
From: Antonio Caggiano
Support BLOB resources creation, mapping and unmapping by calling the
new stable
On 2023/09/19 23:21, Xenia Ragiadakou wrote:
On 19/9/23 13:44, Akihiko Odaki wrote:
On 2023/09/19 19:28, Xenia Ragiadakou wrote:
On 15/9/23 18:11, Akihiko Odaki wrote:
On 2023/09/15 20:11, Huang Rui wrote:
From: Xenia Ragiadakou
When the memory region has a different life-cycle from that
On 2023/09/19 19:28, Xenia Ragiadakou wrote:
On 15/9/23 18:11, Akihiko Odaki wrote:
On 2023/09/15 20:11, Huang Rui wrote:
From: Xenia Ragiadakou
When the memory region has a different life-cycle from that of her
parent,
could be automatically released, once has been unparent and once all
On 2023/09/18 17:36, Huang Rui wrote:
On Sat, Sep 16, 2023 at 12:04:17AM +0800, Akihiko Odaki wrote:
On 2023/09/15 20:11, Huang Rui wrote:
From: Antonio Caggiano
Support BLOB resources creation, mapping and unmapping by calling the
new stable virglrenderer 0.10 interface. Only enabled when
On 2023/09/18 15:20, Huang Rui wrote:
On Mon, Sep 18, 2023 at 02:07:25PM +0800, Akihiko Odaki wrote:
On 2023/09/18 14:43, Huang Rui wrote:
On Sun, Sep 17, 2023 at 01:49:19PM +0800, Akihiko Odaki wrote:
On 2023/09/17 14:45, Huang Rui wrote:
On Sat, Sep 16, 2023 at 06:42:04PM +0800, Akihiko
On 2023/09/18 14:43, Huang Rui wrote:
On Sun, Sep 17, 2023 at 01:49:19PM +0800, Akihiko Odaki wrote:
On 2023/09/17 14:45, Huang Rui wrote:
On Sat, Sep 16, 2023 at 06:42:04PM +0800, Akihiko Odaki wrote:
On 2023/09/16 19:32, Huang Rui wrote:
On Fri, Sep 15, 2023 at 11:20:46PM +0800, Akihiko
On 2023/09/17 14:45, Huang Rui wrote:
On Sat, Sep 16, 2023 at 06:42:04PM +0800, Akihiko Odaki wrote:
On 2023/09/16 19:32, Huang Rui wrote:
On Fri, Sep 15, 2023 at 11:20:46PM +0800, Akihiko Odaki wrote:
On 2023/09/15 20:11, Huang Rui wrote:
Patch "virtio-gpu: CONTEXT_INIT feature"
On 2023/09/16 19:32, Huang Rui wrote:
On Fri, Sep 15, 2023 at 11:20:46PM +0800, Akihiko Odaki wrote:
On 2023/09/15 20:11, Huang Rui wrote:
Patch "virtio-gpu: CONTEXT_INIT feature" has added the context_init
feature flags.
We would like to enable the feature with virglrenderer, so add
On 2023/09/15 20:11, Huang Rui wrote:
Patch "virtio-gpu: CONTEXT_INIT feature" has added the context_init
feature flags.
We would like to enable the feature with virglrenderer, so add to create
virgl renderer context with flags using context_id when valid.
Originally-by: Antonio Caggiano
Signed
On 2023/09/15 20:11, Huang Rui wrote:
From: Antonio Caggiano
Enable resource UUID feature and implement command resource assign UUID.
This is done by introducing a hash table to map resource IDs to their
UUIDs.
Signed-off-by: Antonio Caggiano
Signed-off-by: Huang Rui
---
V4 -> V5:
- Ad
On 2023/09/16 1:04, Akihiko Odaki wrote:
On 2023/09/15 20:11, Huang Rui wrote:
From: Antonio Caggiano
Support BLOB resources creation, mapping and unmapping by calling the
new stable virglrenderer 0.10 interface. Only enabled when available and
via the blob config. E.g. -device virtio-vga-gl
On 2023/09/15 20:11, Huang Rui wrote:
From: Antonio Caggiano
Support BLOB resources creation, mapping and unmapping by calling the
new stable virglrenderer 0.10 interface. Only enabled when available and
via the blob config. E.g. -device virtio-vga-gl,blob=true
Signed-off-by: Antonio Caggiano
On 2023/09/15 20:11, Huang Rui wrote:
Patch "virtio-gpu: CONTEXT_INIT feature" has added the context_init
feature flags.
We would like to enable the feature with virglrenderer, so add to create
virgl renderer context with flags using context_id when valid.
Originally-by: Antonio Caggiano
Signed
ion, which can be freed anytime
before the device gets finalized. Even in this case, the owner removes
the reference to the memory owner by doing res->region = NULL;
Regards,
Akihiko Odaki
On 2023/09/14 17:29, Albert Esteve wrote:
On Thu, Sep 14, 2023 at 9:17 AM Akihiko Odaki <mailto:akihiko.od...@daynix.com>> wrote:
On 2023/09/13 23:18, Albert Esteve wrote:
>
>
> On Wed, Sep 13, 2023 at 3:43 PM Akihiko Odaki
mailto:akihik
On 2023/09/13 23:18, Albert Esteve wrote:
On Wed, Sep 13, 2023 at 3:43 PM Akihiko Odaki <mailto:akihiko.od...@daynix.com>> wrote:
On 2023/09/13 21:58, Albert Esteve wrote:
>
>
> On Wed, Sep 13, 2023 at 2:22 PM Akihiko Odaki
mailto:akihik
On 2023/09/13 21:58, Albert Esteve wrote:
On Wed, Sep 13, 2023 at 2:22 PM Akihiko Odaki <mailto:akihiko.od...@daynix.com>> wrote:
On 2023/09/13 20:34, Albert Esteve wrote:
>
>
> On Wed, Sep 13, 2023 at 12:34 PM Akihiko Odaki
mailto:akihik
On 2023/09/13 20:34, Albert Esteve wrote:
On Wed, Sep 13, 2023 at 12:34 PM Akihiko Odaki <mailto:akihiko.od...@daynix.com>> wrote:
On 2023/09/13 16:55, Albert Esteve wrote:
> Hi Antonio,
>
> If I'm not mistaken, this patch is related with:
>
ation.
Regards,
Akihiko Odaki
On 2023/09/09 18:29, Huang Rui wrote:
On Thu, Aug 31, 2023 at 06:43:17PM +0800, Akihiko Odaki wrote:
On 2023/08/31 18:32, Huang Rui wrote:
From: Antonio Caggiano
Add support for the Venus capset, which enables Vulkan support through
the Venus Vulkan driver for virtio-gpu.
Signed-off-by
On 2023/09/09 18:09, Huang Rui wrote:
On Thu, Aug 31, 2023 at 06:36:57PM +0800, Akihiko Odaki wrote:
On 2023/08/31 18:32, Huang Rui wrote:
From: Antonio Caggiano
Enable resource UUID feature and implement command resource assign UUID.
This is done by introducing a hash table to map resource
On 2023/09/06 16:56, Huang Rui wrote:
On Wed, Sep 06, 2023 at 11:39:09AM +0800, Akihiko Odaki wrote:
On 2023/09/06 12:09, Huang Rui wrote:
On Tue, Sep 05, 2023 at 05:20:43PM +0800, Akihiko Odaki wrote:
On 2023/09/05 18:08, Huang Rui wrote:
On Thu, Aug 31, 2023 at 06:24:32PM +0800, Akihiko
On 2023/09/06 12:09, Huang Rui wrote:
On Tue, Sep 05, 2023 at 05:20:43PM +0800, Akihiko Odaki wrote:
On 2023/09/05 18:08, Huang Rui wrote:
On Thu, Aug 31, 2023 at 06:24:32PM +0800, Akihiko Odaki wrote:
On 2023/08/31 18:32, Huang Rui wrote:
From: Antonio Caggiano
Support BLOB resources
On 2023/09/05 18:08, Huang Rui wrote:
On Thu, Aug 31, 2023 at 06:24:32PM +0800, Akihiko Odaki wrote:
On 2023/08/31 18:32, Huang Rui wrote:
From: Antonio Caggiano
Support BLOB resources creation, mapping and unmapping by calling the
new stable virglrenderer 0.10 interface. Only enabled when
On 2023/09/05 18:07, Huang Rui wrote:
On Thu, Aug 31, 2023 at 06:10:08PM +0800, Akihiko Odaki wrote:
On 2023/08/31 18:32, Huang Rui wrote:
From: Xenia Ragiadakou
When the memory region has a different life-cycle from that of her parent,
could be automatically released, once has been unparent
On 2023/08/31 18:32, Huang Rui wrote:
From: Antonio Caggiano
Add support for the Venus capset, which enables Vulkan support through
the Venus Vulkan driver for virtio-gpu.
Signed-off-by: Antonio Caggiano
Signed-off-by: Huang Rui
---
hw/display/virtio-gpu-virgl.c | 21
On 2023/08/31 18:32, Huang Rui wrote:
From: Antonio Caggiano
Enable resource UUID feature and implement command resource assign UUID.
This is done by introducing a hash table to map resource IDs to their
UUIDs.
The hash table does not seem to be stored during migration.
Signed-off-by: Anto
On 2023/08/31 18:32, Huang Rui wrote:
From: Antonio Caggiano
Support BLOB resources creation, mapping and unmapping by calling the
new stable virglrenderer 0.10 interface. Only enabled when available and
via the blob config. E.g. -device virtio-vga-gl,blob=true
Signed-off-by: Antonio Caggiano
On 2023/08/31 18:32, Huang Rui wrote:
From: Xenia Ragiadakou
When the memory region has a different life-cycle from that of her parent,
could be automatically released, once has been unparent and once all of her
references have gone away, via the object's free callback.
However, currently, ref
On 2023/06/05 17:06, Alexander Bulekov wrote:
On 230601 1218, Akihiko Odaki wrote:
Recently MemReentrancyGuard was added to DeviceState to record that the
device is engaging in I/O. The network device backend needs to update it
when delivering a packet to a device.
In preparation for such a
On 2023/06/01 16:16, Philippe Mathieu-Daudé wrote:
On 1/6/23 05:18, Akihiko Odaki wrote:
Recently MemReentrancyGuard was added to DeviceState to record that the
device is engaging in I/O. The network device backend needs to update it
when delivering a packet to a device.
This implementation
device backend started
delivering a packet to a device which is already engaging in I/O. This
is because such reentrancy frequently happens for
qemu_flush_queued_packets() and is insignificant.
Fixes: CVE-2023-3019
Reported-by: Alexander Bulekov
Signed-off-by: Akihiko Odaki
---
include/net/net.h
qemu_new_nic() and does not contain behavioral changes.
The second patch actually implements MemReentrancyGuard update.
V1 -> V2: Added the 'Fixes: CVE-2023-3019' tag
Akihiko Odaki (2):
net: Provide MemReentrancyGuard * to qemu_new_nic()
net: Update MemReentrancyGuard for NIC
incl
: Akihiko Odaki
---
include/net/net.h | 1 +
hw/net/allwinner-sun8i-emac.c | 3 ++-
hw/net/allwinner_emac.c | 3 ++-
hw/net/cadence_gem.c | 3 ++-
hw/net/dp8393x.c | 3 ++-
hw/net/e1000.c| 3 ++-
hw/net/e1000e.c | 2 +-
hw/net/eepro100
: Akihiko Odaki
---
include/net/net.h | 1 +
hw/net/allwinner-sun8i-emac.c | 3 ++-
hw/net/allwinner_emac.c | 3 ++-
hw/net/cadence_gem.c | 3 ++-
hw/net/dp8393x.c | 3 ++-
hw/net/e1000.c| 3 ++-
hw/net/e1000e.c | 2 +-
hw/net/eepro100
qemu_new_nic() and does not contain behavioral changes.
The second patch actually implements MemReentrancyGuard update.
Akihiko Odaki (2):
net: Provide MemReentrancyGuard * to qemu_new_nic()
net: Update MemReentrancyGuard for NIC
include/net/net.h | 2 ++
hw/net/allwinner-sun8i-emac.c
device backend started
delivering a packet to a device which is already engaging in I/O. This
is because such reentrancy frequently happens for
qemu_flush_queued_packets() and is insignificant.
Reported-by: Alexander Bulekov
Signed-off-by: Akihiko Odaki
---
include/net/net.h | 1 +
net/net.c
ch series which allow to find files not in pc-bios directory
even if started directly from the build directory:
https://patchew.org/QEMU/20220228005710.10442-1-akihiko.od...@gmail.com/
Regards,
Akihiko Odaki
On 2022/06/09 21:02, Gerd Hoffmann wrote:
On Thu, Jun 09, 2022 at 08:45:41PM +0900, Akihiko Odaki wrote:
On 2022/06/09 19:28, Gerd Hoffmann wrote:
--- a/include/ui/console.h
+++ b/include/ui/console.h
@@ -139,6 +139,7 @@ typedef struct QemuUIInfo {
int yoff;
uint32_t width
sh_rate
(2) update users one by one
(3) finally drop update_interval when no user is left.
thanks,
Gerd
I think 1 and 3 should have to be done once since refresh_rate and
update_interval would interfere with each other otherwise. Does that
make sense?
Regards,
Akihiko Odaki
Signed-off-by: Akihiko Odaki
---
hw/display/virtio-gpu-base.c | 1 +
hw/display/virtio-gpu.c| 1 +
include/hw/virtio/virtio-gpu.h | 1 +
3 files changed, 3 insertions(+)
diff --git a/hw/display/virtio-gpu-base.c b/hw/display/virtio-gpu-base.c
index c73b3aa06b8..ee2587a8c36 100644
s frequent changes
of the display mode.
Signed-off-by: Akihiko Odaki
---
hw/display/xenfb.c | 14 +++---
include/ui/console.h | 2 +-
include/ui/gtk.h | 2 +-
ui/console.c | 6 --
ui/gtk-egl.c | 4 ++--
ui/gtk-gl-area.c | 3 +--
The returned value is not used and misleading.
Signed-off-by: Akihiko Odaki
---
hw/display/virtio-gpu-base.c | 6 +++---
hw/display/virtio-vga.c | 5 ++---
hw/vfio/display.c| 8 +++-
include/ui/console.h | 2 +-
4 files changed, 9 insertions(+), 12 deletions
does not maintain
a seperate code path to avoid the throttling because the difference is little
if it xists. Usually the refresh rate of display does not change frequently and
most guests are not prepared for that anyway.
v3: Rebased to the latest QEMU.
Akihiko Odaki (3):
ui/console: Do not return
Anyway, I'd also like to hear opinions from Xen developers.
>
> Otherwise looks good to me overall. Splitting the ui/gtk update to a
> separate patch is probably a good idea.
>
I'll do so when submitting the next version.
Regards,
Akihiko Odaki
s frequent changes
of the display mode.
Signed-off-by: Akihiko Odaki
---
hw/display/virtio-gpu-base.c | 1 +
hw/display/virtio-gpu.c| 1 +
hw/display/xenfb.c | 14 ---
include/hw/virtio/virtio-gpu.h | 1 +
include/ui/console.h | 2 +-
include/ui/gtk.h
Signed-off-by: Akihiko Odaki
---
hw/display/edid-generate.c | 9 +
include/hw/display/edid.h | 12 +++-
2 files changed, 12 insertions(+), 9 deletions(-)
diff --git a/hw/display/edid-generate.c b/hw/display/edid-generate.c
index 1665b7cbb29..b0ce583d436 100644
--- a/hw/display
g while the window size change
has. I don't think it is problematic because it should be rare to move
the window across physical displays, but I can implement one if you
don't agree or know other cases the refresh rate frequently changes.
Regards,
Akihiko Odaki
2021年2月24日(水) 20:17 Gerd Hoffmann :
>
> On Tue, Feb 23, 2021 at 01:50:51PM +0900, Akihiko Odaki wrote:
> > 2021年2月22日(月) 19:57 Gerd Hoffmann :
> > >
> > > On Sun, Feb 21, 2021 at 10:34:14PM +0900, Akihiko Odaki wrote:
> > > > This change introd
2021年2月22日(月) 19:57 Gerd Hoffmann :
>
> On Sun, Feb 21, 2021 at 10:34:14PM +0900, Akihiko Odaki wrote:
> > This change introduces an additional member, refresh_rate to
> > qemu_edid_info in include/hw/display/edid.h.
> >
> > This change also isolates the gra
a
dynamic interval, for example to save update costs aggresively
(vnc) or to respond to user-generated events (sdl).
It stabilizes the graphics update interval and prevents the guest
from being confused.
Signed-off-by: Akihiko Odaki
---
hw/display/edid-generate.c | 7 ---
hw/display
73 matches
Mail list logo