On 03.03.2025 17:52, Andrew Cooper wrote:
> On 26/02/2025 7:33 am, Jan Beulich wrote:
>> On 26.02.2025 00:02, Andrew Cooper wrote:
>>> The final hunk is `(struct vcpu *)v` in disguise, expressed using a runtime
>>> pointer chase through memory and a technicality of the C type system to work
>>> aro
On 28.02.2025 17:24, Andrew Cooper wrote:
> On 27/02/2025 8:11 am, Jan Beulich wrote:
>> On 26.02.2025 18:20, Andrew Cooper wrote:
>>> --- a/xen/arch/riscv/include/asm/bitops.h
>>> +++ b/xen/arch/riscv/include/asm/bitops.h
>>> @@ -125,6 +125,13 @@ static inline void clear_bit(int nr, volatile void
On 04/03/2025 18:57, Ayan Kumar Halder wrote:
> Similar to commit (d736b6eb451b, "xen/arm: mpu: Define Xen start address for
> MPU systems"), one needs to add a build assertion to ensure that the page size
> is 4KB on arm32 based systems as well.
> The existing build assertion is moved under "xe
On 04/03/2025 18:57, Ayan Kumar Halder wrote:
> For AArch32, refer to ARM DDI 0568A.c ID110520.
> MPU_REGION_SHIFT is same between AArch32 and AArch64 (HPRBAR).
> Also, NUM_MPU_REGIONS_SHIFT is same between AArch32 and AArch64
> (HMPUIR).
>
> Signed-off-by: Ayan Kumar Halder
> Reviewed-by: Luc
This is a chunk of the FRED work split out because it's pretty self contained.
It's mostly cleanup/refactoring, although patch
traps.c is already overly large and going to get larger with FRED, so I'm
splitting traps-setup.c out of it, as the two have reasonably-different logic.
That's implemente
On Friday, February 21st, 2025 at 2:13 PM, Marek Marczykowski-Górecki
wrote:
>
>
> On Fri, Feb 21, 2025 at 08:52:47PM +, Denis Mukhin wrote:
>
> > Also, since there's a build-time configuration parameter along with the
> > boot-time
> > configuration, perhaps it makes sense to retire boo
On Monday, February 24th, 2025 at 2:44 AM, Jan Beulich
wrote:
>
>
> On 21.02.2025 21:52, Denis Mukhin wrote:
>
> > On Tuesday, February 18th, 2025 at 8:05 AM, Jan Beulich jbeul...@suse.com
> > wrote:
> >
> > > On 12.02.2025 23:31, dm...@proton.me wrote:
> > >
> > > > --- a/xen/drivers/char
Add new CONRING_SHIFT Kconfig parameter to specify the boot console buffer size
as a power of 2.
The supported range is [14..27] -> [16KiB..128MiB].
Set default to 15 (32 KiB).
Link: https://gitlab.com/xen-project/xen/-/issues/185
Signed-off-by: Denis Mukhin
---
Changes v1->v2:
- Switched to us
On Monday, February 24th, 2025 at 11:23 PM, Jan Beulich
wrote:
>
>
> On 25.02.2025 03:45, Denis Mukhin wrote:
>
> > On Monday, February 24th, 2025 at 2:44 AM, Jan Beulich jbeul...@suse.com
> > wrote:
> >
> > > On 21.02.2025 21:52, Denis Mukhin wrote:
> > >
> > > > On Tuesday, February 18th
On Tue, 4 Mar 2025, Andrew Cooper wrote:
> The use of "legitimately" mixes the concepts of "it was designed to do this"
> and "it was correct to do this".
>
> The latter in particular can go stale. "intended" is a better way of phrasing
> this.
>
> No functional change.
>
> Signed-off-by: Andre
With most of pv_trap_init() being done at build time, opening of NMI_SOFTIRQ
can be a regular initcall, simplifying trap_init().
No functional change.
Signed-off-by: Andrew Cooper
Reviewed-by: Jan Beulich
---
CC: Jan Beulich
CC: Roger Pau Monné
For Branch:
https://gitlab.com/xen-project/p
The use of "legitimately" mixes the concepts of "it was designed to do this"
and "it was correct to do this".
The latter in particular can go stale. "intended" is a better way of phrasing
this.
No functional change.
Signed-off-by: Andrew Cooper
---
CC: Anthony PERARD
CC: Michal Orzel
CC: Jan
Having variables named idt_table[] and idt_tables[] is not ideal.
Use X86_IDT_VECTORS and remove IDT_ENTRIES. State the size of bsp_idt[] in
idt.h so that load_system_tables() and cpu_smpboot_alloc() can use sizeof()
rather than opencoding the calculation.
Move the variable into a new traps-setu
... rather than dynamically at boot time. Aside from less runtime overhead,
this approach is less fragile than the preexisting autogen stubs mechanism.
We can manage this with some linker calculations. See patch comments for full
details.
For simplicity, we create a new set of entry stubs here,
Now that bsp_idt[] is constructed at build time, we do not need to manually
initialise it in init_idt_traps() and trap_init().
When swapping the early pagefault handler for the normal one, switch to using
_update_gate_addr_lower() as we do on the kexec path for NMI and #MC.
This in turn allows us
On Tue, 4 Mar 2025, Nicola Vetrini wrote:
> While activating verbose logging simplifies debugging, this causes
> GitLab logs to be truncated, preventing the links to the ECLAIR
> analysis database to be shown.
>
> No functional change.
>
> Fixes: c4392ec83244 ("automation: Add ECLAIR utilities an
On 04/03/2025 10:47 pm, Stefano Stabellini wrote:
> On Mon, 3 Mar 2025, Andrew Cooper wrote:
>> When a watchdog fires, the domain is crashed and can't dump any state.
>>
>> Xen allows a domain to have two separate watchdogs. Therefore, for a
>> domain running multiple watchdogs (e.g. one based aro
There are two issues. First, pi_test_and_clear_on() pulls the cache-line to
the CPU and dirties it even if there's nothing outstanding, but the final
bitmap_for_each() is O(256) when O(8) would do, and would avoid multiple
atomic updates to the same IRR word.
Rewrite it from scratch, explaining w
On Mon, 3 Mar 2025, Andrew Cooper wrote:
> When a watchdog fires, the domain is crashed and can't dump any state.
>
> Xen allows a domain to have two separate watchdogs. Therefore, for a
> domain running multiple watchdogs (e.g. one based around network, one
> for disk), it is important for diagn
On Mon, 3 Mar 2025, Andrew Cooper wrote:
> struct domain is always a page aligned allocation. Update it's type to
> reflect this, so we can safely reuse the lower bits in the pointer for
> auxiliary information.
>
> No functional change.
>
> Signed-off-by: Andrew Cooper
Reviewed-by: Stefano St
Hi Oleksandr,
I really appreciate the examples you provided; they were very
enlightening regarding the way forward.
Today we discussed the topic with the maintainers again, and I believe
we have identified the best approach to take.
Since it is not feasible to use clang-format to make changes to
From: Stefano Stabellini
Define "Hardware Domain", "Control Domain", "DomUs", "SafeVMs" and
"UnsafeVMs".
Explain the limitations that VirtIO introduces and the way they affect
the defined roles.
Signed-off-by: Stefano Stabellini
Signed-off-by: Ayan Kumar Halder
---
docs/fusa/arch_specs/roles
On Tue, Mar 04, 2025, Michael Kelley wrote:
> From: Sean Christopherson Sent: Wednesday, February 26,
> 2025 6:18 PM
> >
> > Register the Hyper-V timer callbacks or saving/restoring its PV sched_clock
>
> s/or/for/
>
> > if and only if the timer is actually being used for sched_clock.
> > Curr
On 2/26/25 7:26 AM, Jan Beulich wrote:
> On 21.02.2025 21:10, Shawn Anastasio wrote:
>> --- a/xen/include/xen/mm.h
>> +++ b/xen/include/xen/mm.h
>> @@ -69,6 +69,7 @@
>> #include
>> #include
>> #include
>> +#include
>>
>> struct page_info;
>>
>> @@ -113,9 +114,9 @@ int map_pages_to_xen(
>>
Hello, Roger!
On 04.03.25 10:17, Roger Pau Monné wrote:
On Mon, Mar 03, 2025 at 09:23:57PM +0200, Oleksandr Andrushchenko wrote:
Hello, Roger!
On 03.03.25 17:05, Roger Pau Monné wrote:
On Sat, Mar 01, 2025 at 01:42:39PM +0200, Oleksandr Andrushchenko wrote:
Disable coding style checks for th
On Wed, 19 Feb 2025, Jan Beulich wrote:
> On 19.02.2025 16:25, Luca Fancellu wrote:
> >> On 19 Feb 2025, at 13:30, Jan Beulich wrote:
> >> On 19.02.2025 14:06, Luca Fancellu wrote:
> On 19 Feb 2025, at 12:45, Jan Beulich wrote:
> As per the
> respective revlog entry, this change lo
On Tue, 4 Mar 2025, Luca Fancellu wrote:
> Hi,
>
> > On 18 Feb 2025, at 15:06, Jan Beulich wrote:
> >
> > On 18.02.2025 16:01, Orzel, Michal wrote:
> >> On 18/02/2025 14:44, Jan Beulich wrote:
> >>> On 18.02.2025 10:51, Luca Fancellu wrote:
> LLC coloring can be used only on MMU system,
> >
Similar to commit (d736b6eb451b, "xen/arm: mpu: Define Xen start address for
MPU systems"), one needs to add a build assertion to ensure that the page size
is 4KB on arm32 based systems as well.
The existing build assertion is moved under "xen/arch/arm/mpu" as it applies
for both arm64 and arm32 ba
For AArch32, refer to ARM DDI 0568A.c ID110520.
MPU_REGION_SHIFT is same between AArch32 and AArch64 (HPRBAR).
Also, NUM_MPU_REGIONS_SHIFT is same between AArch32 and AArch64
(HMPUIR).
Signed-off-by: Ayan Kumar Halder
Reviewed-by: Luca Fancellu
---
Changes from
v1 - 1. Add the R-b.
xen/arch/
Hi,
I have extracted patches 1, 2 from
"https://patchew.org/Xen/20250204192357.1862264-1-ayan.kumar.hal...@amd.com/";
as it will introduce the common files on which the following can be based :-
1. "[PATCH 0/9] First chunk for Arm R82 and MPU support"
2. "Enable early bootup of AArch32 MPU systems
While activating verbose logging simplifies debugging, this causes
GitLab logs to be truncated, preventing the links to the ECLAIR
analysis database to be shown.
No functional change.
Fixes: c4392ec83244 ("automation: Add ECLAIR utilities and settings")
Signed-off-by: Nicola Vetrini
---
automat
On Tue, Mar 04, 2025 at 10:15:21AM -0500, Jason Andryuk wrote:
> On 2025-03-04 05:23, Roger Pau Monné wrote:
> > On Fri, Feb 28, 2025 at 03:25:52PM -0500, Jason Andryuk wrote:
> > > On 2025-02-28 04:36, Roger Pau Monné wrote:
> > > > On Thu, Feb 27, 2025 at 01:28:11PM -0500, Jason Andryuk wrote:
>
On 04/03/2025 11:59 am, Milan Đokić wrote:
> Hello Andrew,
> On Fri, Feb 28, 2025 at 4:47 PM Andrew Cooper
> wrote:
>> On 28/02/2025 2:59 pm, Milan Djokic wrote:
>>> From: Slavisa Petrovic
>>>
>>> This patch implements copy_to_guest/copy_from_guest functions for RISC-V.
>>> These functions are d
On 2025-03-04 05:23, Roger Pau Monné wrote:
On Fri, Feb 28, 2025 at 03:25:52PM -0500, Jason Andryuk wrote:
On 2025-02-28 04:36, Roger Pau Monné wrote:
On Thu, Feb 27, 2025 at 01:28:11PM -0500, Jason Andryuk wrote:
On 2025-02-27 05:23, Roger Pau Monné wrote:
On Wed, Feb 26, 2025 at 04:11:25PM
On Tue Mar 4, 2025 at 1:22 PM GMT, Frediano Ziglio wrote:
> Describe the usage of devices 5853:0002 and 5853:C000.
>
> Signed-off-by: Frediano Ziglio
> ---
> Changes since v1:
> - address minor comments
> ---
> docs/man/xen-pci-device-reservations.7.pod | 7 +++
> 1 file changed, 7 insertions
For the record, my remarks are fairly inconsequential. This patch is a net
positive addition to the man page and I think it should go in.
On Tue Mar 4, 2025 at 12:29 PM GMT, Roger Pau Monné wrote:
> On Tue, Mar 04, 2025 at 11:17:42AM +, Frediano Ziglio wrote:
> > On Tue, Mar 4, 2025 at 11:08 A
On 25/02/2025 4:33 pm, Jan Beulich wrote:
> On 25.02.2025 16:40, Andrew Cooper wrote:
>> On 25/02/2025 9:07 am, Jan Beulich wrote:
>>> On 24.02.2025 17:05, Andrew Cooper wrote:
--- a/xen/arch/x86/cpu/common.c
+++ b/xen/arch/x86/cpu/common.c
@@ -819,6 +819,7 @@ void load_system_tables
Describe the usage of devices 5853:0002 and 5853:C000.
Signed-off-by: Frediano Ziglio
---
Changes since v1:
- address minor comments
---
docs/man/xen-pci-device-reservations.7.pod | 7 +++
1 file changed, 7 insertions(+)
diff --git a/docs/man/xen-pci-device-reservations.7.pod
b/docs/man/xe
On 06/11/2024 4:23 pm, Stefano Stabellini wrote:
> On Wed, 6 Nov 2024, Javi Merino wrote:
>> Rework the container to use heredocs for readability and use
>> apt-get --no-install-recommends to keep the size down. Rename the job
>> to debian-12-arm64-* to follow the naming scheme of all the other CI
On Tue, Mar 4, 2025 at 12:30 PM Roger Pau Monné wrote:
>
> On Tue, Mar 04, 2025 at 11:17:42AM +, Frediano Ziglio wrote:
> > On Tue, Mar 4, 2025 at 11:08 AM Roger Pau Monné
> > wrote:
> > >
> > > On Tue, Mar 04, 2025 at 10:21:52AM +, Alejandro Vallejo wrote:
> > > > Hi,
> > > >
> > > > On
Hi Ayan,
> On 4 Mar 2025, at 10:53, Ayan Kumar Halder wrote:
>
> Hi Luca,
>
> On 28/02/2025 16:18, Luca Fancellu wrote:
>> CAUTION: This message has originated from an External Source. Please use
>> proper judgment and caution when opening attachments, clicking links, or
>> responding to this
> On 28 Feb 2025, at 10:34, Ayan Kumar Halder wrote:
>
> Hi Julien/Luca,
>
> On 28/02/2025 09:22, Julien Grall wrote:
>>
>>
>> On 26/02/2025 08:28, Luca Fancellu wrote:
>>> Hi Julien,
>>
>> Hi Luca,
>>
>>>
>>
>> #ifdef CONFIG_EARLY_PRINTK
>> diff --git a/xen/arch/arm/include
On 17/02/2025 2:49 am, Volodymyr Babchuk wrote:
> This patch is preparation for making stack protector
> configurable. First step is to remove -fno-stack-protector flag from
> EMBEDDED_EXTRA_CFLAGS so separate components (Hypervisor in this case)
> can enable/disable this feature by themselves.
>
>
Hi Ayan,
> On 4 Mar 2025, at 12:13, Ayan Kumar Halder wrote:
>
> Hi Luca,
>
> On 28/02/2025 16:18, Luca Fancellu wrote:
>> CAUTION: This message has originated from an External Source. Please use
>> proper judgment and caution when opening attachments, clicking links, or
>> responding to this
On Tue, Mar 04, 2025 at 11:17:42AM +, Frediano Ziglio wrote:
> On Tue, Mar 4, 2025 at 11:08 AM Roger Pau Monné wrote:
> >
> > On Tue, Mar 04, 2025 at 10:21:52AM +, Alejandro Vallejo wrote:
> > > Hi,
> > >
> > > On Fri Feb 28, 2025 at 3:21 PM GMT, Frediano Ziglio wrote:
> > > > Describe the
Hi Ayan,
> On 4 Mar 2025, at 11:55, Ayan Kumar Halder wrote:
>
> Hi Luca,
>
> On 28/02/2025 16:18, Luca Fancellu wrote:
>> CAUTION: This message has originated from an External Source. Please use
>> proper judgment and caution when opening attachments, clicking links, or
>> responding to thi
> On 4 Mar 2025, at 11:45, Ayan Kumar Halder wrote:
>
> Hi Luca,
>
> On 28/02/2025 16:18, Luca Fancellu wrote:
>> CAUTION: This message has originated from an External Source. Please use
>> proper judgment and caution when opening attachments, clicking links, or
>> responding to this email.
Hi Luca,
On 28/02/2025 16:18, Luca Fancellu wrote:
CAUTION: This message has originated from an External Source. Please use proper
judgment and caution when opening attachments, clicking links, or responding to
this email.
Implement early_fdt_map() function, that is responsible to map the
de
Hello Oleksii,
On Fri, Feb 28, 2025 at 5:03 PM Oleksii Kurochko
wrote:
>
>
> On 2/28/25 3:59 PM, Milan Djokic wrote:
>
> From: Slavisa Petrovic
>
> This patch implements copy_to_guest/copy_from_guest functions for RISC-V.
> These functions are designed to facilitate data exchange between guest an
Hello Andrew,
On Fri, Feb 28, 2025 at 4:47 PM Andrew Cooper wrote:
>
> On 28/02/2025 2:59 pm, Milan Djokic wrote:
> > From: Slavisa Petrovic
> >
> > This patch implements copy_to_guest/copy_from_guest functions for RISC-V.
> > These functions are designed to facilitate data exchange between guest
Hi Luca,
On 28/02/2025 16:18, Luca Fancellu wrote:
CAUTION: This message has originated from an External Source. Please use proper
judgment and caution when opening attachments, clicking links, or responding to
this email.
Introduce the MPU memory mapping flags in asm/page.h.
Signed-off-by:
Hi Luca,
On 28/02/2025 16:18, Luca Fancellu wrote:
CAUTION: This message has originated from an External Source. Please use proper
judgment and caution when opening attachments, clicking links, or responding to
this email.
Provide a function that creates a pr_t object from a memory
range and
Hi,
> On 18 Feb 2025, at 15:06, Jan Beulich wrote:
>
> On 18.02.2025 16:01, Orzel, Michal wrote:
>> On 18/02/2025 14:44, Jan Beulich wrote:
>>> On 18.02.2025 10:51, Luca Fancellu wrote:
LLC coloring can be used only on MMU system,
>>>
>>> Just for my own education: Why is this?
>> I read t
Hi Luca,
On 28/02/2025 16:18, Luca Fancellu wrote:
CAUTION: This message has originated from an External Source. Please use proper
judgment and caution when opening attachments, clicking links, or responding to
this email.
Introduce few utility function to manipulate and handle the
pr_t type
On Tue, Mar 4, 2025 at 11:08 AM Roger Pau Monné wrote:
>
> On Tue, Mar 04, 2025 at 10:21:52AM +, Alejandro Vallejo wrote:
> > Hi,
> >
> > On Fri Feb 28, 2025 at 3:21 PM GMT, Frediano Ziglio wrote:
> > > Describe the usage of devices 5853:0002 and 5853:C000.
> > >
> > > Signed-off-by: Frediano
The logic has too many levels of indirection and it's very hard to
understand it its current form. Split it between the corner case where
the adjustment is bigger than the current claim and the rest to avoid 5
auxiliary variables.
Add a functional change to prevent negative adjustments from
re-inc
On Tue, Mar 04, 2025 at 10:21:52AM +, Alejandro Vallejo wrote:
> Hi,
>
> On Fri Feb 28, 2025 at 3:21 PM GMT, Frediano Ziglio wrote:
> > Describe the usage of devices 5853:0002 and 5853:C000.
> >
> > Signed-off-by: Frediano Ziglio
> > ---
> > docs/man/xen-pci-device-reservations.7.pod | 9 +++
Hi Luca,
On 28/02/2025 16:18, Luca Fancellu wrote:
CAUTION: This message has originated from an External Source. Please use proper
judgment and caution when opening attachments, clicking links, or responding to
this email.
From: Penny Zheng
Introduce pr_t typedef which is a structure havin
Hi,
> On 26 Feb 2025, at 15:58, Jan Beulich wrote:
>
> Besides the (now) last patch only Arm32 adjustments are left in this
> series.
>
> 1: Arm32: use new-style entry annotations for library code
> 2: Arm32: use new-style entry annotations for MMU code
> 3: Arm32: use new-style entry annotatio
On Fri, Feb 28, 2025 at 03:25:52PM -0500, Jason Andryuk wrote:
> On 2025-02-28 04:36, Roger Pau Monné wrote:
> > On Thu, Feb 27, 2025 at 01:28:11PM -0500, Jason Andryuk wrote:
> > > On 2025-02-27 05:23, Roger Pau Monné wrote:
> > > > On Wed, Feb 26, 2025 at 04:11:25PM -0500, Jason Andryuk wrote:
>
Hi,
On Fri Feb 28, 2025 at 3:21 PM GMT, Frediano Ziglio wrote:
> Describe the usage of devices 5853:0002 and 5853:C000.
>
> Signed-off-by: Frediano Ziglio
> ---
> docs/man/xen-pci-device-reservations.7.pod | 9 +
> 1 file changed, 9 insertions(+)
>
> diff --git a/docs/man/xen-pci-device-
On Mon, Mar 03, 2025 at 10:14:38PM +, Andrew Cooper wrote:
> "find upstream bridge" is surprisingly jarring in context, considering that's
> the name of the function who's return value we're testing.
>
> Signed-off-by: Andrew Cooper
Acked-by: Roger Pau Monné
Thanks, Roger.
On 26/02/2025 22:52, Luca Fancellu wrote:
>
>
> Currently the early stage of the Arm boot maps the DTB using
> early_fdt_map() using PAGE_HYPERVISOR_RO which is cacheable
> read-only memory, later during DTB relocation the function
> copy_from_paddr() is used to map pages in the same range on
On Mon, Mar 03, 2025 at 09:23:57PM +0200, Oleksandr Andrushchenko wrote:
> Hello, Roger!
>
> On 03.03.25 17:05, Roger Pau Monné wrote:
> > On Sat, Mar 01, 2025 at 01:42:39PM +0200, Oleksandr Andrushchenko wrote:
> > > Disable coding style checks for the project, but xen/ folder:
> > > this is done
64 matches
Mail list logo