On 17.01.2025 01:31, Stefano Stabellini wrote:
> On Wed, 1 Mar 2023, Jan Beulich wrote:
>> While we want certain things turned off in shim-exclusive mode, doing
>> so via "depends on !PV_SHIM_EXCLUSIVE" badly affects allyesconfig: Since
>> that will turn on PV_SHIM_EXCLUSIVE, other options will be
On Wed, 1 Mar 2023, Jan Beulich wrote:
> While we want certain things turned off in shim-exclusive mode, doing
> so via "depends on !PV_SHIM_EXCLUSIVE" badly affects allyesconfig: Since
> that will turn on PV_SHIM_EXCLUSIVE, other options will be turned off as
> a result. Yet allyesconfig wants to
Applied, thanks.
Please update the changelog at https://wiki.qemu.org/ChangeLog/10.0 for any
user-visible changes.
signature.asc
Description: PGP signature
On Thu, 16 Jan 2025, Nicola Vetrini wrote:
> On 2025-01-16 10:51, Jan Beulich wrote:
> > On 16.01.2025 10:31, Nicola Vetrini wrote:
> > > MISRA C Rule 20.7 states:
> > > "Expressions resulting from the expansion of macro parameters shall
> > > be enclosed in parentheses".
> > >
> > > Document the
On Thu, 16 Jan 2025, Milan Đokić wrote:
> On Wed, Jan 15, 2025 at 10:14 PM Stefano Stabellini
> wrote:
> >
> > On Wed, 15 Jan 2025, Milan Đokić wrote:
> > > Hello Stefano, Oleksii
> > >
> > > On Wed, Jan 15, 2025 at 5:30 PM Oleksii Kurochko
> > > wrote:
> > > >
> > > > Hi Stefano,
> > > >
> > > >
On Thu, Jan 16, 2025 at 11:23 AM Radim Krčmář wrote:
>
> 2025-01-16T09:51:25+01:00, Andrew Jones :
> > On Wed, Jan 15, 2025 at 08:04:05PM +0100, Milan Đokić wrote:
> >> On Tue, Jan 14, 2025 at 7:18 PM Andrew Jones
> >> wrote:
> >> > On Tue, Jan 14, 2025 at 05:09:36PM +0100, Milan Djokic wrote:
>
On Wed, Jan 15, 2025 at 10:14 PM Stefano Stabellini
wrote:
>
> On Wed, 15 Jan 2025, Milan Đokić wrote:
> > Hello Stefano, Oleksii
> >
> > On Wed, Jan 15, 2025 at 5:30 PM Oleksii Kurochko
> > wrote:
> > >
> > > Hi Stefano,
> > >
> > > On 1/15/25 1:01 AM, Stefano Stabellini wrote:
> > >
> > > +Olek
From: Artem Savkov
According to gcc8's man pages gcc can put functions into .text.unlikely
or .text.hot subfunctions during optimization. Add ".text.hot" to the
list of bundleable functions in is_bundleable().
Signed-off-by: Artem Savkov
Signed-off-by: Roger Pau Monné
---
common.c | 5 +
From: Artem Savkov
Propagate child symbol changes to it's parent.
Signed-off-by: Artem Savkov
Signed-off-by: Roger Pau Monné
---
create-diff-object.c | 10 --
1 file changed, 8 insertions(+), 2 deletions(-)
diff --git a/create-diff-object.c b/create-diff-object.c
index b041d94d9723..
From: Artem Savkov
While building a gcc-consprop patch from integration tests gcc8 would place a
__timekeeping_inject_sleeptime.constprop.18.cold.27 symbol into
.text.unlikely.__timekeeping_inject_sleeptime.constprop.18 section. Because
section name doesn't have the '.cold.27' suffix this symbol
From: Artem Savkov
create-build-diff expects .cold functions to be suffixed by an id, which
is not always the case. Drop the trailing '.' when searching for cold
functions.
Fixes: #1160
Signed-off-by: Artem Savkov
Signed-off-by: Roger Pau Monné
---
common.c | 2 +-
create-diff-ob
From: Artem Savkov
Add child symbols to .kpatch.ignore.functions in case their parents are
added to the list.
Signed-off-by: Artem Savkov
Signed-off-by: Roger Pau Monné
---
create-diff-object.c | 4
1 file changed, 4 insertions(+)
diff --git a/create-diff-object.c b/create-diff-object.c
From: Artem Savkov
Add a function that would detect parent/child symbol relations. So far
it only supports .cold.* symbols as children.
Signed-off-by: Artem Savkov
Signed-off-by: Roger Pau Monné
---
common.h | 2 ++
create-diff-object.c | 35 +++
2
Hello,
Fixes picked from kpatch to deal with .cold and .hot sub-functions
sections generated by gcc.
Thanks, Roger.
Artem Savkov (7):
create-diff-object: ignore .cold.* suffixes in is_bundleable()
create-diff-object: add symbol relations
create-diff-object: propagate child symbol changes
From: Artem Savkov
gcc8 can place functions to .text.unlikely and .text.hot subsections
during optimizations. Allow symbols to change subsections instead of
failing.
Signed-off-by: Artem Savkov
Signed-off-by: Roger Pau Monné
---
create-diff-object.c | 29 +++--
1 file
On Thu Jan 16, 2025 at 9:46 AM GMT, Jan Beulich wrote:
> On 15.01.2025 19:06, Bernhard Kaindl wrote:
> > Fix missing commas after linking adverbs such as currently, fortunately,
> > hence, instead, and thus, when used as linking adverbs at the beginning
> > of sentences. I saw them with LTeX; other
On 16.01.2025 12:29, Sergiy Kibrik wrote:
> 07.01.25 10:46, Jan Beulich:
>> On 06.01.2025 19:09, Tamas K Lengyel wrote:
>>> On Mon, Jan 6, 2025 at 10:10 AM Jan Beulich wrote:
On 06.01.2025 15:05, Tamas K Lengyel wrote:
> On Mon, Jan 6, 2025 at 5:16 AM Jan Beulich wrote:
>>
>
On Thu, Jan 16, 2025 at 02:02:38PM +, Andrew Cooper wrote:
> On 16/01/2025 1:59 pm, Roger Pau Monne wrote:
> > Add a new randconfig job for each FreeBSD version. This requires some
> > rework of the template so common parts can be shared between the full and
> > the randconfig builds. Such ra
On 16/01/2025 1:59 pm, Roger Pau Monne wrote:
> Add a new randconfig job for each FreeBSD version. This requires some
> rework of the template so common parts can be shared between the full and
> the randconfig builds. Such randconfig builds are relevant because FreeBSD
> is the only tested syste
Add a new randconfig job for each FreeBSD version. This requires some
rework of the template so common parts can be shared between the full and
the randconfig builds. Such randconfig builds are relevant because FreeBSD
is the only tested system that has a full non-GNU toolchain.
While there repl
On Thu, Jan 09, 2025 at 11:59:35AM +0100, Juergen Gross wrote:
> Replace the current use of the unstable xc_domain_getinfo_single()
> interface with the stable domctl XEN_DOMCTL_get_domain_state call
> via the new libxenmanage library.
>
> This will remove the last usage of libxenctrl by Xenstore,
On Tue, Jan 14, 2025 at 02:29:12PM +0100, Jan Beulich wrote:
> The ssid_label field requires separate freeing; make sure to call
> libxl_dominfo_dispose() as well as libxl_dominfo_init(). Since vcpuset()
> calls only the former, add a call to the latter there at the same time.
>
> Coverity-ID: 163
On Tue, Jan 14, 2025 at 09:13:16AM +0100, Jan Beulich wrote:
> The backend_domname field requires separate freeing; make sure to call
> libxl_device_vtpm_dispose() also on respective error paths.
>
> Coverity-ID: 1638719
> Fixes: dde22055ac3a ("libxl: add vtpm support")
> Signed-off-by: Jan Beulic
On Tue, Jan 14, 2025 at 09:12:37AM +0100, Jan Beulich wrote:
> While multiple -c options may be unexpected, we'd still better deal with
> them properly.
>
> Also restore the blank line that was bogusly zapped by the same commit.
>
> Coverity-ID: 1638723
> Fixes: e4ad2836842a ("xentrace: Implement
On Thu, 16 Jan 2025 at 10:35, Dmitry Baryshkov
wrote:
> On Thu, Jan 16, 2025 at 11:17:50AM +0100, Geert Uytterhoeven wrote:
> > On Thu, Jan 16, 2025 at 11:03 AM Tomi Valkeinen
> > wrote:
> > > On the platforms I have been using (omap, tidss, xilinx, rcar) the dumb
> > > buffers are the only buffe
On Thu, Jan 16, 2025 at 09:46:33AM +, Andrew Cooper wrote:
> On 16/01/2025 8:58 am, Roger Pau Monne wrote:
> > Add a new randconfig job for each FreeBSD version. This requires some
> > rework of the template so common parts can be shared between the full and
> > the randconfig builds. Such ra
07.01.25 10:46, Jan Beulich:
On 06.01.2025 19:09, Tamas K Lengyel wrote:
On Mon, Jan 6, 2025 at 10:10 AM Jan Beulich wrote:
On 06.01.2025 15:05, Tamas K Lengyel wrote:
On Mon, Jan 6, 2025 at 5:16 AM Jan Beulich wrote:
On 30.12.2024 07:30, Sergiy Kibrik wrote:
From: Stefano Stabellini
E
On 15/01/2025 3:09 pm, Bernhard Kaindl wrote:
> While skimming through the misc docs, I spotted a few typos.
>
> Signed-off-by: Bernhard Kaindl
> ---
> docs/misc/livepatch.pandoc| 8
specifc -> specific
perfomed -> performed
randezvous -> rendezvous
seperate -> separate (mul
On 15/01/2025 1:44 pm, Bernhard Kaindl wrote:
> diff --git a/docs/designs/argo.pandoc b/docs/designs/argo.pandoc
> index e18aacea7c..cd854d2a7a 100644
> --- a/docs/designs/argo.pandoc
> +++ b/docs/designs/argo.pandoc
> @@ -127,7 +127,7 @@ by the domain.
>
> ## Hierarchical Locking Model and Prot
2025-01-16T09:51:25+01:00, Andrew Jones :
> On Wed, Jan 15, 2025 at 08:04:05PM +0100, Milan Đokić wrote:
>> On Tue, Jan 14, 2025 at 7:18 PM Andrew Jones wrote:
>> > On Tue, Jan 14, 2025 at 05:09:36PM +0100, Milan Djokic wrote:
>> > > +#define SBI_ECALL 0xE
>> >
>> > Shouldn't this be 0xA07, i.
On Thu, Jan 16, 2025 at 11:17:50AM +0100, Geert Uytterhoeven wrote:
> On Thu, Jan 16, 2025 at 11:03 AM Tomi Valkeinen
> wrote:
> > On 16/01/2025 10:09, Thomas Zimmermann wrote:
> > > Am 15.01.25 um 15:20 schrieb Tomi Valkeinen:
> > > [...]
> > >>
> > >> My point is that we have the current UAPI, a
On 2025-01-16 10:51, Jan Beulich wrote:
On 16.01.2025 10:31, Nicola Vetrini wrote:
MISRA C Rule 20.7 states:
"Expressions resulting from the expansion of macro parameters shall
be enclosed in parentheses".
Document the behaviour of ECLAIR with respect to the CPP extension
that allows variable m
Hi,
On 16/01/2025 12:17, Geert Uytterhoeven wrote:
On Thu, Jan 16, 2025 at 11:03 AM Tomi Valkeinen
wrote:
On 16/01/2025 10:09, Thomas Zimmermann wrote:
Am 15.01.25 um 15:20 schrieb Tomi Valkeinen:
[...]
My point is that we have the current UAPI, and we have userspace using
it, but we don't
On Thu, Jan 16, 2025 at 11:03 AM Tomi Valkeinen
wrote:
> On 16/01/2025 10:09, Thomas Zimmermann wrote:
> > Am 15.01.25 um 15:20 schrieb Tomi Valkeinen:
> > [...]
> >>
> >> My point is that we have the current UAPI, and we have userspace using
> >> it, but we don't have clear rules what the ioctl d
Hi,
On 16/01/2025 11:38, Laurent Pinchart wrote:
On Thu, Jan 16, 2025 at 10:43:40AM +0200, Laurent Pinchart wrote:
On Wed, Jan 15, 2025 at 02:34:26PM +, Daniel Stone wrote:
On Wed, 15 Jan 2025 at 14:20, Tomi Valkeinen wrote:
No disagreement there, we need CREATE_DUMB2.
My point is that w
Hi,
On 16/01/2025 10:09, Thomas Zimmermann wrote:
Hi
Am 15.01.25 um 15:20 schrieb Tomi Valkeinen:
[...]
My point is that we have the current UAPI, and we have userspace using
it, but we don't have clear rules what the ioctl does with specific
parameters, and we don't document how it has to
On 16.01.2025 10:31, Nicola Vetrini wrote:
> MISRA C Rule 20.7 states:
> "Expressions resulting from the expansion of macro parameters shall
> be enclosed in parentheses".
>
> Document the behaviour of ECLAIR with respect to the CPP extension
> that allows variable macro arguments to be named.
>
On 15.01.2025 19:06, Bernhard Kaindl wrote:
> Fix missing commas after linking adverbs such as currently, fortunately,
> hence, instead, and thus, when used as linking adverbs at the beginning
> of sentences. I saw them with LTeX; other checkers have this rule too.
I'm unconvinced, and despite Ste
On 16/01/2025 8:58 am, Roger Pau Monne wrote:
> Add a new randconfig job for each FreeBSD version. This requires some
> rework of the template so common parts can be shared between the full and
> the randconfig builds. Such randconfig builds are relevant because FreeBSD
> is the only tested syste
MISRA C Rule 20.7 states:
"Expressions resulting from the expansion of macro parameters shall
be enclosed in parentheses".
Document the behaviour of ECLAIR with respect to the CPP extension
that allows variable macro arguments to be named.
Signed-off-by: Nicola Vetrini
---
docs/misra/rules.rst
On Thu, Jan 16, 2025 at 10:43:40AM +0200, Laurent Pinchart wrote:
> On Wed, Jan 15, 2025 at 02:34:26PM +, Daniel Stone wrote:
> > On Wed, 15 Jan 2025 at 14:20, Tomi Valkeinen wrote:
> > > No disagreement there, we need CREATE_DUMB2.
> > >
> > > My point is that we have the current UAPI, and we
From: David Woodhouse
This returns the full contents of the node, having created the node path
from the printf-style format string provided in its arguments.
This will save various callers from having to do so for themselves (and
from using xs_node_scanf() with the non-portable %ms format string
2/qemu.git tags/pull-xenfv-20250116
for you to fetch changes up to e7bc0204e57836b3df611b73d2decc56ed698c4a:
system/runstate: Fix regression, clarify BQL status of exit notifiers
(2025-01-15 18:05:19 +)
Xen regression fixes an
On 16/01/2025 8:58 am, Roger Pau Monne wrote:
> Signed-off-by: Roger Pau Monné
Acked-by: Andrew Cooper
Add a new randconfig job for each FreeBSD version. This requires some
rework of the template so common parts can be shared between the full and
the randconfig builds. Such randconfig builds are relevant because FreeBSD
is the only tested system that has a full non-GNU toolchain.
While there remo
On Wed, Jan 15, 2025 at 08:04:05PM +0100, Milan Đokić wrote:
> Hello Andrew,
>
> On Tue, Jan 14, 2025 at 7:18 PM Andrew Jones wrote:
> >
> > On Tue, Jan 14, 2025 at 05:09:36PM +0100, Milan Djokic wrote:
...
> > > +++ b/arch/riscv/xen/hypercall.S
> > > @@ -0,0 +1,71 @@
> > > +/* SPDX-License-Ident
Signed-off-by: Roger Pau Monné
---
.cirrus.yml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/.cirrus.yml b/.cirrus.yml
index 4a120fad41b2..ee80152890f2 100644
--- a/.cirrus.yml
+++ b/.cirrus.yml
@@ -18,7 +18,7 @@ freebsd_template: &FREEBSD_TEMPLATE
task:
name: 'FreeBSD 1
From: David Woodhouse
Now that xs_node_read() can construct a node path, no need to open-code it.
Signed-off-by: David Woodhouse
Reviewed-by: Anthony PERARD
Acked-by: Roger Pau Monné
---
hw/net/xen_nic.c | 13 ++---
1 file changed, 6 insertions(+), 7 deletions(-)
diff --git a/hw/net
From: Phil Dennis-Jordan
By changing the way the main QEMU event loop is invoked, I inadvertently
changed the BQL status of exit notifiers: some of them implicitly
assumed they would be called with the BQL held; the BQL is however
not held during the exit(status) call in qemu_default_main().
Ins
From: David Woodhouse
Now that xs_node_read() can construct a node path, no need to open-code it.
Signed-off-by: David Woodhouse
Reviewed-by: Anthony PERARD
Acked-by: Roger Pau Monné
---
hw/char/xen_console.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --gi
From: David Woodhouse
Signed-off-by: David Woodhouse
Reviewed-by: Anthony PERARD
Acked-by: Roger Pau Monné
---
hw/xen/xen_pvdev.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/hw/xen/xen_pvdev.c b/hw/xen/xen_pvdev.c
index c5ad71e8dc..c9143ba259 100644
--- a/hw/xen/
From: Roger Pau Monne
The 'm' parameter used to request auto-allocation of the destination variable
is not supported on FreeBSD, and as such leads to failures to parse.
What's more, the current usage of '%ms' with xs_node_scanf() is pointless, as
it just leads to a double allocation of the same
From: David Woodhouse
Reduce some duplication.
Signed-off-by: David Woodhouse
Reviewed-by: Anthony PERARD
Acked-by: Roger Pau Monné
---
hw/xen/trace-events | 1 -
hw/xen/xen-bus-helper.c | 15 ++-
2 files changed, 6 insertions(+), 10 deletions(-)
diff --git a/hw/xen/trace-e
From: David Woodhouse
When attempting to read the 'output' node, interpret any error *other*
than ENOENT as a fatal error. For ENOENT, fall back to serial_hd() to
find a character device, or create a null device.
Do not attempt to prepend to errp when serial_hd() fails; the error
isn't relevant
On Wed, Jan 15, 2025 at 02:34:26PM +, Daniel Stone wrote:
> On Wed, 15 Jan 2025 at 14:20, Tomi Valkeinen wrote:
> > No disagreement there, we need CREATE_DUMB2.
> >
> > My point is that we have the current UAPI, and we have userspace using
> > it, but we don't have clear rules what the ioctl do
Hi
Am 15.01.25 um 15:20 schrieb Tomi Valkeinen:
[...]
My point is that we have the current UAPI, and we have userspace using
it, but we don't have clear rules what the ioctl does with specific
parameters, and we don't document how it has to be used.
Perhaps the situation is bad, and all we
56 matches
Mail list logo