On Sat, Dec 04, 2021 at 03:09:59PM -0700, Simon Glass wrote:
> Hi Tom,
>
> On Sat, 4 Dec 2021 at 11:03, Tom Rini wrote:
> >
> > On Sat, Dec 04, 2021 at 08:20:55AM -0700, Simon Glass wrote:
> > > Hi Tom,
> > >
> > > On Sat, 4 Dec 2021 at 06:52, Tom Rini wrote:
> > > >
> > > > On Fri, Dec 03, 2021
On Sat, Dec 04, 2021 at 07:52:46PM +0100, François Ozog wrote:
> Hi Simon
>
> Le sam. 4 déc. 2021 à 18:35, Simon Glass a écrit :
>
> > Hi François,
> >
> > On Sat, 4 Dec 2021 at 09:55, François Ozog
> > wrote:
> > >
> > > Hi Simon
> > >
> > > Le sam. 4 déc. 2021 à 16:21, Simon Glass a écrit :
On 12/4/21 16:56, Simon Glass wrote:
> That script is not intended for use with EFI, so update the logic to avoid
> using it.
>
> Signed-off-by: Simon Glass
Signed-off-by: Christian Melki
> ---
>
> Changes in v5:
> - Add new patch to avoid using the 64-bit link script for the EFI app
>
> arch
On 12/4/21 16:56, Simon Glass wrote:
> At present some 32-bit settings are used with the 64-bit app. Fix this by
> separating out the two cases.
>
> Be careful not to break the 64-bit payload, which needs to build a 64-bit
> EFI stub with a 32-bit U-Boot.
>
> Signed-off-by: Simon Glass
Signed-of
Some boards still use the old timer mechanism. Set a deadline for them to
update to driver model.
This needs a bit of a strange rule to avoid an error on some boards.
Signed-off-by: Simon Glass
---
(no changes since v1)
Makefile | 4
doc/develop/driver-model
This is not needed anymore. Drop it to simplify the code.
Signed-off-by: Simon Glass
Suggested-by: Heinrich Schuchardt
---
Changes in v2:
- Add new patch to drop ATA_PORT_ADDR
drivers/block/ide.c | 12
1 file changed, 4 insertions(+), 8 deletions(-)
Applied to u-boot-dm/next, th
This converts the following to Kconfig:
CONFIG_KEYBOARD
Signed-off-by: Simon Glass
---
(no changes since v1)
README | 8
arch/Kconfig| 1 +
arch/arm/mach-exynos/Kconfig| 1 +
configs/chromebit_mickey_defconfig | 1 +
con
A few boards still use the old keyboard mechanism. Set a deadline for them
to update to driver model.
Signed-off-by: Simon Glass
---
(no changes since v1)
Makefile | 1 +
doc/develop/driver-model/migration.rst | 8
2 files changed, 9 insertions(+)
Applie
This is not used by sandbox since it uses driver model for the timer.
Drop it.
Also update the tools_only build to avoid build errors, since it does
actually build U-Boot too. Enable DM so we can use CONFIG_TIMER,
disable EFI_LOADER to avoid an error about board_quiesce_devices() and
disable NET
This can go in the related header file. Drop the CONFIG option.
Signed-off-by: Simon Glass
Reviewed-by: Heinrich Schuchardt
---
(no changes since v1)
cmd/host.c | 2 +-
drivers/block/sandbox.c | 6 +++---
include/configs/sandbox.h| 2 --
include/sandboxblockdev.h
This converts the following to Kconfig:
CONFIG_SYS_FDT_LOAD_ADDR
Signed-off-by: Simon Glass
---
(no changes since v1)
arch/sandbox/Kconfig | 10 ++
include/configs/sandbox.h| 6 --
scripts/config_whitelist.txt | 1 -
3 files changed, 10 insertions(+), 7 deletions(-
At present there are Kconfig options for tracing, but sandbox uses
plain #defines to set them. Correct this and make the tracing command
default to enabled so that this is not needed.
Signed-off-by: Simon Glass
---
Changes in v2:
- Drop the unnecessary defconfig changes from the docs
cmd/Kconf
Add a function to read a list of strings from the devicetree.
Signed-off-by: Simon Glass
---
tools/dtoc/fdt_util.py | 21 +
tools/dtoc/test_fdt.py | 9 +
2 files changed, 30 insertions(+)
Applied to u-boot-dm/next, thanks!
Sometimes it is useful to have a list of related external blobs in a
single entry. An example is the DDR binaries used by meson. There are
9 files in total. Add support for this, so we don't have to have a
separate entry for each.
Signed-off-by: Simon Glass
---
scripts/pylint.base
At present it is necessary to symlink files containing external blobs into
the U-Boot tree in order for binman to find them. This is not very
convenient.
Add two new environment/Makefile variables to help with this. Add
documentation as well, fixing a related nit.
Signed-off-by: Simon Glass
---
In some cases entries encapsulate other data and it is useful to access
the data within. An example is the fdtmap which consists of a 16-byte
header, followed by a devicetree.
Provide an option to specify an alternative format when extracting files.
In the case of fdtmap, this is 'fdt', which prod
If an older version of binman is used to list images created by a newer
one, it is possible that it will contain entry types that are not
supported. At present this produces an error.
Adjust binman to use a plain 'blob' entry type to cope with this, so the
image can at least be listed.
Signed-off
Typically the bloblist is positioned at a fixed address in memory until
relocation. This is convenient when it is set up in SPL or before
relocation.
But for EFI we want to set it up only when U-Boot proper is running. Add
a way to allocate it using malloc() and update the documentation to cover
t
This method name is more commonly used for this function. Use it
consistently.
Signed-off-by: Simon Glass
---
tools/binman/etype/fit.py| 4 ++--
tools/binman/etype/intel_ifwi.py | 4 ++--
tools/binman/etype/mkimage.py| 4 ++--
3 files changed, 6 insertions(+), 6 deletions(-)
Applie
Hi Tom,
https://source.denx.de/u-boot/custodians/u-boot-dm/-/pipelines/10137
The following changes since commit f89615088fba1b1f33713ad26dbe3a3c82b692ec:
Merge branch 'next' of
https://source.denx.de/u-boot/custodians/u-boot-net into next
(2021-12-02 07:16:04 -0500)
are available in the Git
Hi François,
On Sat, 4 Dec 2021 at 05:35, François Ozog wrote:
>
> Hi Simon and Sandrine
>
> Le jeu. 2 déc. 2021 à 08:10, Sandrine Bailleux a
> écrit :
>>
>> Hi Simon,
>>
>> On 12/1/21 5:51 PM, Simon Glass wrote:
>> > Hi Sandrine,
>> >
>> > On Wed, 1 Dec 2021 at 03:32, Sandrine Bailleux
>> > w
On Sun, Dec 05, 2021 at 12:53:43PM -0700, Simon Glass wrote:
> Hi Tom,
>
> https://source.denx.de/u-boot/custodians/u-boot-dm/-/pipelines/10137
>
>
> The following changes since commit f89615088fba1b1f33713ad26dbe3a3c82b692ec:
>
> Merge branch 'next' of
> https://source.denx.de/u-boot/custod
Commit 03510bf62149 ("sunxi: only include alias for eMMC when mmc2
used") protected the eMMC alias in U-Boot's DT stub the with the
associated Kconfig symbol, but was actually using the wrong name.
Fix the name of the symbol to match what's defined in Kconfig and what
the defconfig files actually
Hi Tom,
I left out another pending patch but completely forgot to drop the
timer patch last time. Here it is again.
(next branch)
The following changes since commit f89615088fba1b1f33713ad26dbe3a3c82b692ec:
Merge branch 'next' of
https://source.denx.de/u-boot/custodians/u-boot-net into next
On Fri, Dec 03, 2021 at 05:32:49PM +0100, Heinrich Schuchardt wrote:
> On 11/25/21 06:44, AKASHI Takahiro wrote:
> > Heinrich,
> >
> > On Wed, Nov 24, 2021 at 12:10:32PM +0900, AKASHI Takahiro wrote:
> > > On Sat, Nov 20, 2021 at 01:54:30PM +0100, Heinrich Schuchardt wrote:
> > > > Hello Takahiro,
On Fri, Dec 03, 2021 at 05:06:56PM +0100, Heinrich Schuchardt wrote:
> On 12/3/21 08:16, AKASHI Takahiro wrote:
> > Heinrich,
> >
> > On Tue, Nov 16, 2021 at 12:01:27PM +0900, AKASHI Takahiro wrote:
> > > On Tue, Nov 16, 2021 at 01:02:55AM +0100, Heinrich Schuchardt wrote:
> > > > On 11/16/21 00:5
Hello
> -Original Message-
> From: Simon Glass
> Sent: Wednesday, December 1, 2021 11:32 PM
> To: Gaurav Jain
> Cc: U-Boot Mailing List ; Stefano Babic
> ; Fabio Estevam ; Peng Fan
> ; Priyanka Jain ; Ye Li
> ; Horia Geanta ; Ji Luo
> ; Franck Lenormand ; Silvano Di
> Ninno ; Sahil Malho
Hello Simon
> -Original Message-
> From: Simon Glass
> Sent: Wednesday, December 1, 2021 11:32 PM
> To: Gaurav Jain
> Cc: u-boot@lists.denx.de; Stefano Babic ; Fabio Estevam
> ; Peng Fan ; Priyanka Jain
> ; Ye Li ; Horia Geanta
> ; Ji Luo ; Franck Lenormand
> ; Silvano Di Ninno ;
> Sahil
Hi,
This series is improving DFU subsystem. This improves dfu_alt_info
parser and fixing documents etc.
When I was debuging my patch for updating dfu_alt_info on the
DeveloperBox platform, I found that dfu_alt_info parser doesn't
accept redundant spaces and tabs. Also the dfu.rst description
seem
Hi,
This series is improving DFU subsystem. This improves dfu_alt_info
parser and fixing documents etc.
When I was debuging my patch for updating dfu_alt_info on the
DeveloperBox platform, I found that dfu_alt_info parser doesn't
accept redundant spaces and tabs. Also the dfu.rst description
seem
Use strlcpy() instead of strcpy() to prevent copying the
entity name over the name buffer size.
Signed-off-by: Masami Hiramatsu
---
drivers/dfu/dfu.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/dfu/dfu.c b/drivers/dfu/dfu.c
index af3975925a..66c41b5e76 100644
-
If dfu_alt_info has repeated spaces or tab (for indentation or
readability), the dfu fails to parse it. For example, if
dfu_alt_info="mtd nor1=image raw 10 20" (double spaces
after "raw"), the image entity start address is '0' and the size
'0x10'. This is because the repeated space is
When parsing the dfu_alt_info, check the number of arguments
and argument string strictly. If there is any garbage data
(which is not able to be parsed correctly) in dfu_alt_info,
that means something wrong and user may make a typo or mis-
understanding about the syntax. Since the dfu_alt_info is
u
Fix some typo and wrong information about dfu_alt_info.
- Add the parameter format, decimal only or hexadecimal.
- Use same parameter name for the same kind of parameters.
(e.g. dev -> dev_id)
Signed-off-by: Masami Hiramatsu
---
doc/usage/dfu.rst | 57 +---
Since dfu is not only used for USB, and some platform only
supports DFU_OVER_TFTP or EFI capsule update, dfu_alt_info
is defined on such platforms too.
For such platform, 'dfu list' command is useful to check
how the current dfu_alt_info setting is parsed.
Signed-off-by: Masami Hiramatsu
---
cm
Hi, all!
Anastasiia has left EPAM, so now her e-mail bounces.
I can updated the e-mail if Anastasiia is still up to maintaining Xen part in
U-boot.
Thank you,
Oleksandr
On 06.12.21 09:09, Oleksandr Andrushchenko wrote:
> From: Oleksandr Andrushchenko
>
> Anastasiia Lukianenko's e-mail is now b
Sorry, please ignore this mail, i missed to update the subject.
Thanks,
2021年12月6日(月) 14:43 Masami Hiramatsu :
>
> Hi,
>
> This series is improving DFU subsystem. This improves dfu_alt_info
> parser and fixing documents etc.
>
> When I was debuging my patch for updating dfu_alt_info on the
> Devel
37 matches
Mail list logo