Hi Tim,
On 19.03.21 19:40, Tim Harvey wrote:
On Fri, Mar 19, 2021 at 10:17 AM Stefano Babic wrote:
Hi Tim,
On 19.03.21 16:50, Tim Harvey wrote:
Greetings,
I'm looking at using SWUpdate to facilitate an A/B ping-pong method of
firmware updates where a state is stored in U-Boot env by the SW
Dear Tom,
The following changes since commit e3310c21a43c1e3c004c6b53ee9179420a1be375:
Merge tag 'video-for-v2021.04' of
https://source.denx.de/u-boot/custodians/u-boot-video (2021-03-19
08:20:19 -0400)
are available in the Git repository at:
https://source.denx.de/u-boot/custodians/u-boot
Hi Eugen,
It didn't work I'm afraid. I took a look at the code and I don't think the
stack is available, in start.S we have the following for the reset vector:
reset:
/*
* set the cpu to SVC32 mode
*/
mrs r0,cpsr
bic r0,r0,#0x1f
orr r0,r0,#0xd3
msr cpsr,r0
/*
* we do sys-critical inits only at
Provide optimized versions of memcpy(), memmove(), memset() copied from
the Linux kernel.
Signed-off-by: Heinrich Schuchardt
---
arch/riscv/Kconfig | 78 ++
arch/riscv/include/asm/string.h | 36 +-
arch/riscv/lib/Makefile | 5 ++
arch/riscv/li
Hi Stefano and Tom,
On Thu, Mar 4, 2021 at 9:59 AM Andrey Zhizhikin wrote:
>
> Hello Fabio,
>
> On Thu, Mar 4, 2021 at 12:07 PM Fabio Estevam wrote:
> >
> > Currently it is not possible to boot Linux from the SD card
> > by default.
> >
> > Make the necessary adjustments to allow it.
> >
> > Rep
On Sat, Mar 20, 2021 at 02:59:05PM +1300, Simon Glass wrote:
> Hi Tom,
>
> On Sat, 20 Mar 2021 at 14:06, Tom Rini wrote:
> >
> > On Sat, Mar 20, 2021 at 12:54:00PM +1300, Simon Glass wrote:
> > > On Sat, 20 Mar 2021 at 09:42, Tom Rini wrote:
> > > >
> > > > On Tue, Mar 16, 2021 at 09:51:44PM +01
On Sat, Mar 20, 2021 at 11:06:18AM +0100, Heinrich Schuchardt wrote:
> Dear Tom,
>
> The following changes since commit e3310c21a43c1e3c004c6b53ee9179420a1be375:
>
> Merge tag 'video-for-v2021.04' of
> https://source.denx.de/u-boot/custodians/u-boot-video (2021-03-19
> 08:20:19 -0400)
>
> are
Hi Fabio,
On 20.03.21 15:05, Fabio Estevam wrote:
Hi Stefano and Tom,
On Thu, Mar 4, 2021 at 9:59 AM Andrey Zhizhikin wrote:
Hello Fabio,
On Thu, Mar 4, 2021 at 12:07 PM Fabio Estevam wrote:
Currently it is not possible to boot Linux from the SD card
by default.
Make the necessary adjus
Hi Tom,
This is for the -next branch, mostly the of-platdata-inst implementation.
https://source.denx.de/u-boot/custodians/u-boot-dm/-/pipelines/6844
The following changes since commit f879f2621b42529cf5f88912a07d2866cfc8fd45:
Merge branch 'next' of git://source.denx.de/u-boot-sh into next
(
diff --git a/arch/arm/mach-rockchip/board.c b/arch/arm/mach-rockchip/board.c
index c386b529..11866e6e 100644
--- a/arch/arm/mach-rockchip/board.c
+++ b/arch/arm/mach-rockchip/board.c
@@ -67,7 +67,7 @@ static struct dwc2_plat_otg_data otg_data = {
.tx_fifo_sz = 128,
};
-int board_usb_i
On Arm-based Macs, -no_pie is ignored and gives a linker warning.
Moreover, the build falls over with:
ld: Absolute addressing not allowed in arm64 code but used in
'_image_type_ptr_aisimage' referencing '_image_type_aisimage'
for dumpimage and mkimage, since we put data structs in text sectio
Simon,
you forgot to drop my regmap patch.
Marek
On Mon, Feb 15, 2021 at 07:07:44PM +0100, Fabien Parent wrote:
> More than one pumpkin board has been made with different MediaTek SoCs.
> Rename the pumpkin board to follow the naming convention of all
> other MediaTek boards and also to not be confusing when other pumpkin
> boards will be added
On Mon, Feb 15, 2021 at 07:07:45PM +0100, Fabien Parent wrote:
> Init USB Ether if CONFIG_USB_ETHER is enabled.
>
> Signed-off-by: Fabien Parent
Applied to u-boot/next, thanks!
--
Tom
signature.asc
Description: PGP signature
On Mon, Feb 15, 2021 at 07:07:46PM +0100, Fabien Parent wrote:
> Instead of redefining our own way to boot, let's just use
> config_distro_bootcmd.h.
>
> Signed-off-by: Fabien Parent
Applied to u-boot/next, thanks!
--
Tom
signature.asc
Description: PGP signature
On Mon, Feb 15, 2021 at 07:21:11PM +0100, Fabien Parent wrote:
> Add the MT8183 SoC support.
>
> Signed-off-by: Fabien Parent
Applied to u-boot/next, thanks!
--
Tom
signature.asc
Description: PGP signature
On Mon, Feb 15, 2021 at 07:21:12PM +0100, Fabien Parent wrote:
> Add the MT8183 pumpkin board support.
>
> Signed-off-by: Fabien Parent
Applied to u-boot/next, thanks!
--
Tom
signature.asc
Description: PGP signature
On Fri, Mar 05, 2021 at 10:22:11AM +0800, Weijie Gao wrote:
> From: Sam Shih
>
> This is a bug fix for mtk pinctrl common part. Appearently pins should be
> used instead of grps in mtk_get_pin_name().
>
> Signed-off-by: Sam Shih
Applied to u-boot/next, thanks!
--
Tom
signature.asc
Descrip
On Fri, Mar 05, 2021 at 10:22:19AM +0800, Weijie Gao wrote:
> From: Sam Shih
>
> This patch add get_pin_muxing support for mediatek pinctrl drivers
>
> Signed-off-by: Sam Shih
Applied to u-boot/next, thanks!
--
Tom
signature.asc
Description: PGP signature
On Fri, Mar 05, 2021 at 10:22:26AM +0800, Weijie Gao wrote:
> The mtk pinctrl driver is a combination driver with support for both
> pinctrl and gpio. When this driver is used in SPL, gpio support may not be
> enabled, and this will result in a compilation error.
>
> To fix this, macros are added
On Fri, Mar 05, 2021 at 10:22:31AM +0800, Weijie Gao wrote:
> The EPHY LEDs of mt7629 can be used as JTAG. This patch adds the jtag pin
> group to the pinctrl driver.
>
> Signed-off-by: Weijie Gao
Applied to u-boot/next, thanks!
--
Tom
signature.asc
Description: PGP signature
On Fri, Mar 05, 2021 at 10:24:58AM +0800, Weijie Gao wrote:
> It's better to use the generic timer which is correctly initialized by
> the ATF. The generic timer has higher resolution than the mtk_timer.
>
> Signed-off-by: Weijie Gao
Applied to u-boot/next, thanks!
--
Tom
signature.asc
Desc
On Fri, Mar 05, 2021 at 10:27:46AM +0800, Weijie Gao wrote:
> The EPHY LEDs belongs to the built-in FE switch of MT7629, which is barely
> used. These LED pins on reference boards are used as JTAG socket. So it's
> a good idea to change the default state to JTAG, and this will make it
> convenienc
On Fri, Mar 05, 2021 at 10:35:39AM +0800, Weijie Gao wrote:
> Currently the setbrg logic of serial-mtk is messy, and should be rewritten.
> Also an option is added to make it possible to use highspeed-3 mode for all
> bauds.
>
> The new logic is:
> 1. If baud clock > 12MHz
>a) If baud <= 1152
On Fri, Mar 05, 2021 at 10:39:55AM +0800, Weijie Gao wrote:
> This patch makes use of the decompression mechanism implemented for mt7628
> previously to reduce the total image size. Binman will be also removed.
>
> Signed-off-by: Weijie Gao
Applied to u-boot/next, thanks!
--
Tom
signature.a
On Fri, Mar 05, 2021 at 10:41:33AM +0800, Weijie Gao wrote:
> Enable debug uart for mt7622_rfb_defconfig
>
> Signed-off-by: Weijie Gao
Applied to u-boot/next, thanks!
--
Tom
signature.asc
Description: PGP signature
On Tue, Mar 09, 2021 at 03:52:31PM +0800, Weijie Gao wrote:
> This patch adds an option which allows setting the device header offset.
> This is useful if this tool is used to generate ATF BL2 image of mt7622 for
> SD cards.
>
> Signed-off-by: Weijie Gao
Applied to u-boot/next, thanks!
--
Tom
Hi Marek,
On Sun, 21 Mar 2021 at 12:21, Marek Behún wrote:
>
> Simon,
>
> you forgot to drop my regmap patch.
Ah yes, I dropped it from dm/master, but left it in -next. I am hoping
that git will figure it out as that is what it is supposed to be good
at :-)
Regards,
Simon
>
>
Hi Simon,
On Sun, Mar 21, 2021 at 8:21 AM Simon Glass wrote:
>
> Hi Marek,
>
> On Sun, 21 Mar 2021 at 12:21, Marek Behún wrote:
> >
> > Simon,
> >
> > you forgot to drop my regmap patch.
>
> Ah yes, I dropped it from dm/master, but left it in -next. I am hoping
> that git will figure it out as t
Hi Bin,
On Sun, 21 Mar 2021 at 14:16, Bin Meng wrote:
>
> Hi Simon,
>
> On Sun, Mar 21, 2021 at 8:21 AM Simon Glass wrote:
> >
> > Hi Marek,
> >
> > On Sun, 21 Mar 2021 at 12:21, Marek Behún wrote:
> > >
> > > Simon,
> > >
> > > you forgot to drop my regmap patch.
> >
> > Ah yes, I dropped it f
On Sun, Mar 21, 2021 at 02:18:40PM +1300, Simon Glass wrote:
> Hi Bin,
>
> On Sun, 21 Mar 2021 at 14:16, Bin Meng wrote:
> >
> > Hi Simon,
> >
> > On Sun, Mar 21, 2021 at 8:21 AM Simon Glass wrote:
> > >
> > > Hi Marek,
> > >
> > > On Sun, 21 Mar 2021 at 12:21, Marek Behún wrote:
> > > >
> > >
Hi Tom,
This is for the -next branch
https://source.denx.de/u-boot/custodians/u-boot-dm/-/pipelines/6849
The following changes since commit f879f2621b42529cf5f88912a07d2866cfc8fd45:
Merge branch 'next' of git://source.denx.de/u-boot-sh into next
(2021-03-19 08:20:34 -0400)
are available in
A few places use -ENOTSUPP when they should use -ENOSYS. In two cases both
are used. This little series tidies this up.
Simon Glass (6):
usb: Return -ENOSYS when system call is not available
spi: Return -ENOSYS when system call is not available
tlv_eeprom: Return -ENOSYS when system call is
Update usb_gadget_release() to use -ENOSYS, which is the correct error
code for U-Boot.
Signed-off-by: Simon Glass
---
drivers/usb/gadget/udc/udc-uclass.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/usb/gadget/udc/udc-uclass.c
b/drivers/usb/gadget/udc/udc-uclass
When CMD_TLV_EEPROM is not enabled, use -ENOSYS, which is the correct
error code for U-Boot.
Signed-off-by: Simon Glass
---
include/tlv_eeprom.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/include/tlv_eeprom.h b/include/tlv_eeprom.h
index 1de2fe2337c..a2c333e7446 1
We don't need to check -ENOTSUPP since this is not used for this purpose
in U-Boot. Update the code accordingly.
Signed-off-by: Simon Glass
---
drivers/core/simple-pm-bus.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/core/simple-pm-bus.c b/drivers/core/simple
Update spi_controller_dma_map_mem_op_data() to use -ENOSYS, which is the
correct error code for U-Boot.
Signed-off-by: Simon Glass
---
include/spi-mem.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/spi-mem.h b/include/spi-mem.h
index 8be3e2bf6b5..e354c388979 10064
Update clk_composite_set_parent() to use -ENOSYS, which is the correct
error code for U-Boot. Also rearrange the code so that the error condition
is clearly indicated and the function runs to the end in the normal case,
since this is the common style in U-Boot.
Signed-off-by: Simon Glass
---
dr
Update the code to use -ENOSYS, which is the correct error code for an
unimplemented system call in U-Boot.
Also we should not check for a missing operations array as this is not
permitted. For now this can be covered by an assert().
Signed-off-by: Simon Glass
---
drivers/pinctrl/pinctrl-uclas
This series provides a few improvements for loading of images. It also
provides a way to show more detailed model information as well as an
of-platdata fix noticed recently.
Note that this series depends on the GPIO series here:
http://patchwork.ozlabs.org/project/uboot/list/?series=226118
Ch
Some boards may want to show the SKU ID or other information obtained at
runtime. Allow this to come from sysinfo. The board can then provide a
sysinfo driver to provide it.
Signed-off-by: Simon Glass
Reviewed-by: Bin Meng
---
(no changes since v3)
Changes in v3:
- Rebase to master
common/bo
Provide the model information through sysinfo so that it shows up on
boot. For memconfig 4 pins are provided, for 16 combinations. For SKU
ID there are two options:
- two pins provided in a ternary arrangement, for 9 combinations.
- reading from the EC
Add a binding doc and drop the unused
Hi Bin,
On Mon, 15 Mar 2021 at 18:30, Simon Glass wrote:
>
> Hi Bin,
>
> On Tue, 9 Mar 2021 at 15:34, Bin Meng wrote:
> >
> > Hi Simon,
> >
> > On Sun, Feb 7, 2021 at 12:13 AM Simon Glass wrote:
> > >
> > > Provide the model information through sysinfo so that it shows up on
> > > boot. For mem
On 3/21/21 4:18 AM, Simon Glass wrote:
Update usb_gadget_release() to use -ENOSYS, which is the correct error
code for U-Boot.
It would be good if you could explain _why_ this change is required. Why
is ENOSYS the correct return value ? It is not clear from the patch
description, sorry.
Hi Marek,
On Sun, 21 Mar 2021 at 17:09, Marek Vasut wrote:
>
> On 3/21/21 4:18 AM, Simon Glass wrote:
> > Update usb_gadget_release() to use -ENOSYS, which is the correct error
> > code for U-Boot.
>
> It would be good if you could explain _why_ this change is required. Why
> is ENOSYS the correc
At present the GPIO uclass mirrors what was in U-Boot before driver model.
It works well in most cases but is becoming cumbersome with things like
pull-up/down and drive strength. In those cases it is easier for the
driver to deal with all the flags at one, rather than piece by piece.
In fact the
This is the only driver that uses this function. Update it to use the
alternative which is dm_gpio_set_dir_flags().
Signed-off-by: Simon Glass
---
Changes in v6:
- Use dm_gpio_clrset_flags() so that direction can be changed
- Simplify the code since masking is not needed
drivers/i2c/i2c-gpio.c
This function is not used. Drop it.
Signed-off-by: Simon Glass
Reviewed-by: Patrick Delaunay
---
(no changes since v5)
Changes in v5:
- Drop patches previously applied
drivers/gpio/gpio-uclass.c | 11 ---
include/asm-generic/gpio.h | 11 ---
2 files changed, 22 deletions(-)
On 3/20/21 11:18 PM, Simon Glass wrote:
Update clk_composite_set_parent() to use -ENOSYS, which is the correct
error code for U-Boot. Also rearrange the code so that the error condition
is clearly indicated and the function runs to the end in the normal case,
since this is the common style in U
On 3/20/21 11:18 PM, Simon Glass wrote:
We don't need to check -ENOTSUPP since this is not used for this purpose
in U-Boot. Update the code accordingly.
Signed-off-by: Simon Glass
---
drivers/core/simple-pm-bus.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/driv
At present it is not always possible to have an expanded entry as a
sibling of another node. This limitation applies in most situations where
the other node has properties which binman must update, or when other
nodes appear after the expanded entry. An example is a 'hash' node in
the same section
Two test devicetree files currently have 192 as their unique number. Fix
this by separating them out.
Signed-off-by: Simon Glass
---
tools/binman/ftest.py | 2 +-
.../test/{192_symbols_nodtb.dts => 196_symbols_nodtb.dts} | 0
2 files changed, 1 in
At present there is a command-line flag to disable substitution of expanded
entries. Add an option to the entry node as well, so it can be controlled
at the node level.
Add a test to cover this. Fix up the comment to the checkSymbols() function
it uses, while we are here.
Signed-off-by: Simon Gla
The vblock entry type includes code to collect the data from a number of
other entries (not necessarily subentries) and concatenating it. This is
a useful feature for other entry types.
Make it a base class, so that vblock can use it, along with other entry
types.
Signed-off-by: Simon Glass
---
Generally the content of sections is not built until the final assembly
of the image. This is partly to avoid wasting time, since the entries
within sections may change multiple times as binman works through its
various stages. This works quite well since sections exist in a strict
hierarchy, so th
Sometimes it is useful to specify the default alignment for all entries
in a section, such as when word-alignment is necessary, for example. It
is tedious and error-prone to specify this individually for each section.
Add a property to control this for a section.
Signed-off-by: Simon Glass
---
Add the node name too so it is easy to see which node failed.
Signed-off-by: Simon Glass
---
tools/dtoc/fdt.py | 4 ++--
tools/dtoc/test_fdt.py | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/tools/dtoc/fdt.py b/tools/dtoc/fdt.py
index 25ce5136ebf..f0d1384ccc3 100644
If a property does not yet have an offset, then that means it exists in
the cache'd fdt but has not yet been synced back to the flat tree. Use
the dirty flag for this so we don't need to check the offset too. Improve
the comments for Prop and Node to make it clear what an offset of None
means.
Als
Once the tree has been synced, thus potentially moving things around in the
fdt, we set _cached_offsets to False so that a refresh will happen next
time a property is accessed.
This 'lazy' refresh doesn't really save much time, since refresh is a very
fast operation, just a single walk of the tree
Add a new test that adds a subnode alongside an existing one, as well as
adding properties to a subnode. This will expand to adding multiple
subnodes in future patches. Put a node after the one we are adding to so
we can check that things sync correctly.
The testAddNode() test should be in the Tes
Add a few more internal checks to make sure offsets are correct, before
updating the dtb.
To make this easier, update the functions which add a property to return
that property,.
Signed-off-by: Simon Glass
---
tools/dtoc/fdt.py | 27 ---
tools/dtoc/test_fdt.py | 16
So far we have only needed to add subnodes to empty notds, so have not
had to deal with ordering. However this feature is needed for binman's
expanded nodes, since there may be another node in the same section.
While libfdt adds new properties after existing properties, it adds new
subnodes before
62 matches
Mail list logo